Previous 1 2 Next 28 Replies Latest reply: May 4, 2015 11:15 AM by troga1
quatrieme Level 1 (0 points)

I am aware there is this thread on basically the same problem How can I regain Preview as my default PDF browser in Safari?.

However my circumstances are a bit different.


One of my content vendors uses FileOpen to lock their PDFs and that is why I even bothered to install adobe (v10.1.4). Thru the install process I was careful not to have adobe become the default viewer by checking all the relevant boxes I saw.


When I go to Finder and doubleclick on a PDF, they are still opened by Preview. Right click->Get Info does show Preview as default viewer.


However in Safari, Adobe has taken over despite in Adobe->Preferences->display pdf in browser is not only unchecked but grayed out. But even though grayed out, right below that checkbox shows Adobe is the browser view and I see no way of changing it.


In Library/Internet Plug-ins there are NO pdf plug ins. In fact I have only a single one (picasa).


I am not aware how to get to Username/Library/Internet Plug-ins as the reference thread talks about.


Whatever the solution, I still need adobe working on my machine otherwise I cannot view the content from that one vendor.


Any suggestions? Thanks.


Message was edited by: quatrieme to clarify Adobe->Preferences settings

MacBook Pro, Mac OS X (10.7)
  • Linc Davis Level 10 (192,897 points)

    From the Safari menu bar, select


    Help Installed Plug-ins


    Besides the following, what plugins are listed?

    • iPhotoPhotocast
    • Java
    • QuickTime
    • Shockwave Flash
    • WebKit built-in PDF
  • quatrieme Level 1 (0 points)

    thanks, Linc. interesting suggestion. It shows the following unfortunately. The background: I initially installed adobe reader 11.0.01 but discovered the production version of FileOpen does not work with it. So I uninstalled it and installed 10.1.4 instead. But looks like some parts of it lingers.


    Adobe Acrobat NPAPI Plug-in, Version 11.0.01

    Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.01 — from file “AdobePDFViewerNPAPI.plugin”.
    application/pdfAcrobat Portable Document Formatpdf
    application/vnd.adobe.pdfAcrobat Portable Document Format (Interim)pdf
    application/vnd.adobe.pdfxmlAcrobat XML Portable Document Formatpdfxml
    application/vnd.adobe.x-marsAcrobat XML Portable Document Format (Interim)mars
    application/vnd.adobe.xdp+xmlXML Data Packagexdp
    application/vnd.adobe.xfd+xmlFormFlow99 Data Filexfd
    application/vnd.adobe.xfdfAcrobat Forms Data Format in XMLxfdf
    application/vnd.fdfAcrobat Forms Data Formatfdf
  • Linc Davis Level 10 (192,897 points)

    Back up all data.


    Triple-click the line of text below to select it, the copy the selected text to the Clipboard (command-C):


    /Library/Internet Plug-ins


    In the Finder, select


    Go Go to Folder


    from the menu bar, or press the key combination shift-command-G. Paste (command-V) into the text box that opens, then press return.


    From the folder that opens, remove any items that have the letters “PDF” in the name. You may be prompted for your login password. Then quit and relaunch Safari, and test.


    I've seen an unconfirmed report that the "Silverlight" web plugin distributed by Microsoft can also interfere with PDF display in Safari, so you might need to remove it as well, if applicable.


    If you still have the issue, repeat with this line:


    ~/Library/Internet Plug-ins


    If you don’t like the results of this procedure, restore the items from the backup you made before you started. Relaunch Safari again.

  • quatrieme Level 1 (0 points)



    Thanks a lot, Linc. These PDF plug-ins were there:





    Removing them & restarting safari does put Preview back in business. I also verified that opening my vendor's FileOpen-locked PDFs using Right click->Open With->Adobe still works.


    Thanks a lot for your quick help!

  • Sandra47 Level 1 (0 points)

    You  are wonderful. This finally solved my problem.

  • kctalker Level 1 (0 points)

    Awesome! Thanks for the help on this! Those two plug-ins were the culprits for me, too!

  • Chris Damico Level 1 (5 points)

    Hi same problem here and I cannot get the command go - go to folder to open up the folder.  It is telling me "The folder can't be found"


    I checked the internet plug-ins folder on my library and there are only 2 plug-ins listed but are not related.


    When I go to help - internet plug-ins in safari the same adobe items are listed as the original author showed.


    Help I need my preview back it's killing me!  I deleted Reader and what I thought to be all of the associated files.

  • Chris Damico Level 1 (5 points)

    OK I figured it out... I was able to find the plugin by searching for it by name "AdobePDFViewer....plugin"


    Deleted and whoala it worked!! Thanks

  • DoubleDeadGuy Level 1 (0 points)

    I used the AppCleaner app to delete Adobe Reader and it took care of the Internet Plugins and application support stuff. So now there is absolutely nothing in my internet plugins folder, but I'm still having the problem. Help would be greatly appreciated. Adobe Reader is just awful.


    Using latest versions of all software and a 2013 MB Air.

  • kctalker Level 1 (0 points)

    Dumb question for you, DoubleDead: Did you empty the Internet Plug-Ins from your user Library folder and not the system Library folder? The original post directs you to the system's Library folder; perhaps that difference is affecting you.

  • DoubleDeadGuy Level 1 (0 points)

    Thanks, I think that was the problem. I just did a spotlight search and found it. I just made the jump up from 10.5 so I'm still acclimating to where everything is located.

  • kaycek1 Level 1 (0 points)

    I am also having this problem.  I tried to follow Linc Davis's instructions, but I keep getting the message "folder not found".......

  • sigbiz Level 1 (0 points)

    There's a simpler workaround that works for me (MacBook Pro), Mavericks and Safari 7.

    If you let Safari do its useless display and move the cursor to bottom middle of the screen you get the four icons appear.  Click on the third symbol (The one after the expand / reduce size) and - the PDF then opens in Adobe Reader.

  • ultramantis Level 1 (0 points)

    Here is a link to the official Adobe page telling you how to do it. What I found is changing it under get info is not enough. Adobe recommends creating a new folder in your library called disabled Internet plugins. You can read the official adobe page or get to it under preferences in Adobe reader under internet.



    There is one little hitch, you can't just move the files. You have to move them to the trash first and then move them to that file. If you don't it thinks you just want to make copies.


    Beware every time you install adobe reader, it will take over Safari. It has done this for years. The problem that has been mentioned is the two plugins:





    In \Library\Internet Plug-ins

Previous 1 2 Next