Previous 1 2 3 Next 132 Replies Latest reply: May 25, 2015 6:52 AM by Angel of D4rkness Branched to a new discussion.
dsanc89 Level 1 (5 points)

Hey everyone,


I just want to know one thing...


I'm researching USB 3.0 hubs for my rMBP running OS X 10.8.2 (Mountain Lion) and I've found nothing but results with terrible reviews and/or comments and I don't want to make a purchase I'm going to regret. So I ask you, the people: Has anyone found a USB 3.0 hub that just works flawlessly on a 15'' Retina MacBook Pro running OS X Mountain Lion?


Thanks for your help in advance!



MacBook Pro (Retina, Mid 2012), OS X Mountain Lion (10.8.2)
  • AWMarine Level 1 (5 points)

    The lack of a positive reply in the interim since you posted is likely an excellent indicator.


    My response is no, there is not a USB 3.0 hub that is reliable with the MacBook Pro Retina 15", at least  that I've found. I'm also running the current Mountain Lion. 10.8.2.


    This is based on my experience with 14 powered USB 3.0 hubs ranging from 4 to 10-ports. They include Belkin, IOGear, Ultra, Targus, Inland, SIIG, and the Uspeed (before and after the chipset and firmware upgrade.) The ones I purchased have been returned for a refund, except for one. (This may be one way to get the vendors and manufacturers to stand up to Apple and demand a fix for what appears to be their design problem.)


    I've been asking the same question as you since June. Neither AppleCare nor Geniuses have had a solution. Apple engineering appears to take a cavalier attitude and blames the incompatibility on the hub manufacturers. (What? All of them?)

    Apple says that their responsibility ends with the ports on the Mac. I don't believe it does. The Mac needs to effectively communicate with the USB 3.0 devcices it's connected to, and it does not.


    Excerpt from Apples Knowledge Base Article at:

    What USB 3 devices are supported?

    All devices that conform to what is commonly referred to as the "2008 version 1 USB 3.0 specification" are supported.

    Are USB 3 hubs supported?

    Hubs that conform to what is commonly referred to as the  "2008 version 1 USB 3.0 specification" are supported.


    Saturday a friend with a Toshiba laptop running Windows 7 and I got together to compare 6 hubs. Six drives were used. Each hub (with the 6 drives connected) was plugged in to each computer and the results were noted. In virtually every case the MacBook Pro Retina failed to mount one or more drives, or they mounted as USB 2.0. When each hub was plugged into the Toshiba there were no errors (save for one bad connection.) Our conclusion was that these hubs (that engineering says are the problem) worked like a dream on the Windows system.


    Note that this bench test only allowed for superficial testing because of time constraints. In my daily use the drive(s) regularly fail to mount; they mount as USB 1.1 (12 Mb/sec), USB 2.0 (480 Mb/sec.), or USB 3.0 (5 Gb/sec.);  or to disconnect spontaneously (during a data transfer this could be fatal. I lost my iTunes Library, and had a backup drive corrupted.)


    Bottom line: Terrible results are the norm for USB 3.0 on Apple computers. I wish I could suggest a hub that would meet your needs, but after 8 months I'm still looking. Unfortunately, Apple is putting all their attention and resources into iPhone s and iPads to the detriment of OS X systems and hardware.


    I too would welcome any suggestions for a reliable hub. I'd pay a premium after what I have invested thus far.

  • unfrostedpoptart Level 1 (10 points)

    I'm holding out hope that the Kanex DualRole USB 3.0 coming out in a couple of weeks will actually work right!  The catch is that since it's designed for laptops/portability, the upstream cable is hardwired and only a couple of inches long.  I just want 1GE without loosing a whole TB or USB port.

  • AWMarine Level 1 (5 points)

    The Kanex DualRole appears to have USB 3.0 ports in and out, despite what some have speculated. It's supposed to be available on the 28th and the initial reviews will be of great interest. It's specified for the new MacBook Pro so I'm hoping they comminicate, something that is currently lacking with new Macs. I'm now up to 15 hubs unsuccessfully tried.


    Last week I took a Uspeed USB 3.0 powered hub, and 3 portable drives, to the Apple Store and worked with a Genius. We hooked the hub and drives to a new 15" MacBook Pro and to a 27" iMac. Sporadic failures of the drives to mount on both Macs were documented. This has been typical of one of the 3 problems I've found with USB 3.0 problems with Macs. The other two are:


    • Spontaneous Ejects of the drive(s) (sometimes during data transfer), and


    • Drives mounting as USB 1.1, USB 2.0, or USB 3.0, although mostly as USB 3.0. A USB 3.0 drive mounting as USB 1.1 is clearly a major defect, and it's not an isolated example. In my mind this is clearly a bad chipset, firmware or OS in the Apple and it's time for them to fix it. 


    If you're having similar problems with USB 3.0 hubs when used on new Macs, do yourself and everyone else a favor by posting your experiences on this Discussion Board, or on Apples Feedback section. I have been assured that Apple's engineering department does monitor these comments to learn about what's not working. Unless it's brought up often enough, it's going to be seen as a minor problem not justiying the resources. Speak Up!

  • dsanc89 Level 1 (5 points)

    I just want to tell you AWMarine that all the research you're bringing to this discussion is nothing short of awesome. I cannot emphasize enough how greatly appreciative I am and how incredibly helpful all this information is.


    I started this super specific discussion because I was upset at all the fragmented details I found all over the place. Finally glad that there is someone here with a consolidated sense of responsibility.


    Here's to a solution eventually being found...



  • DavidClawson Level 1 (0 points)

    I have a handful of expensive USB 2.0 devices that have also become unrelable to the point of being unusable after upgrading to OSX 10.7.x or OSX 10.8.X


    It is the single most infuriating and discouraging thing about owning a MAC fo me right now.


    I blamed it on the USB device vendors until I realized that "all" of my USB 2.0 devices are now unstable.


    300 dollar USB mike, unusable, 250 dollar office phone with USB connection, unusable, 2 TB USB 2.0 external Drive, unusable.


    Perhaps Apple really did need to fire it's VP of Software. How many other ways can I say I'm unhappy?

  • djscoe Level 1 (5 points)

    I've been using an Anker Uspeed 4 port hub with my MacBook Pro 15" Retina and it works OK.  I have connected two WD My Book Essentials to it and they go in and out.  Usually, when I boot up the Mac, I have to unplug the drives from the hub and plug them back in again for the computer to see them.   They work for a while but then have to repeat the process as the Mac seems to lose them. 


    I just bought the 7 Port version and the Mac doesn't recognize the drives at all.  I went to Anker ( website and they have a firmware download that is supposed to improve it's performance with Mac.  The incredibly weird thing is, the upgrade is all Windows programs but the upgrade is to improve Mac performance.


    So, I tried upgrading the firmware using my wife's PC and it fails.  I have to try to call their tech support later to see if they can help me getting it upgraded.  I'll keep you all posted as to what happens.

  • djscoe Level 1 (5 points)

    Update:  Tech support helped me through and upgraded the firmware.  So far, it has been working great.  No problems or shutoffs whatsoever. 

  • AWMarine Level 1 (5 points)

    Now you have my attention! I hope you don't mind some questions, but I'm hungry for information after fighting the hub problem(s) since June. I suspect others are also.


    • Which tech support, and which Firmware? Apple or Uspeed?
    • Do you have any details on the Firmware upgrade that was used?
    • Uspeed had a Firmware upgrade that had to be installed from a Windows platform. Do they now have a version that will install from Mountain Lion?
    • Are you using the 4-port or 7-Port Uspeed hub currently?
    • How long have you been operating without problems or shutoffs? Still?


    Thanks for any information you can provide.

  • djscoe Level 1 (5 points)

    Sorry, I should have been more specific.


    It was USpeed ( tech support.

    It brought my firmware from 6.48 to 7.??.   Sorry I only saw the new number quickly but it was something like 7.11.

    No, it's really weird.  You have to install the firmware on a PC, they don't have a Mac package.  Also be careful, the instructions say to "run" a .bin file but what it means is move it from the unzipped package to the Bin Folder under the main upgrade program.

    I'm using both but all my 3.0 peripherals are on the 7 port and 2.0 peripherals are on the 4 port which I didn't attempt to upgrade the firmware.

    It's been 3 days now and it's still going strong.  No shutoffs and always sees the 3.0 hard drives.


    I hope this helps.

  • dsanc89 Level 1 (5 points)

    djscoe, thanks a bunch for that input. Really appreciate that info.


    I hate to say this out loud but, I'm very poor right now so I can't buy this hub or any at the moment. My question to the Apple Community as whole: Has anyone else managed to use the same USB 3.0 hub as djscoe here and gotten the same results? (Anker Uspeed 4 Hub -- I'm guessing this?: U).


    No offense meant at all to you djscoe. I just want to make sure that another person gets the same results as you did in using it to be sure of its reliability. The more success stories I hear about this particular model after your experience, then the more secure I'll be about looking into purchasing it as a potential candidate for my rMBP (as will other people I'm sure).


    Thanks again man.




  • djscoe Level 1 (5 points)

    No offense taken.  I've been around long enough to know that two different people can get two different experiences under what seems to be the same circumstances. 


    To clarify, I have the 4 port AND the 7 port ( 1_1?s=electronics&ie=UTF8&qid=1363102755&sr=1-1&keywords=uspeed+usb+3.0+7+port+h ub.  What I described in my upgrade process was the 7 port, which has all the USB 3.0 peripherals attached.  I still haven't attempted to upgrade the 4 port because I just have USB 2.0 peripherals attached to it and it's working fine.


    Just to update, the upgraded 7 port with the USB 3.0 peripherals is still working great.  No shutoffs, no lost drives.  I'm very happy with it.

  • AWMarine Level 1 (5 points)

    On Thursday I got together with a friend and his Toshiba and used Windows 7 to install the Firmware upgrade on a Uspeed 7-Port USB 3.0 hub. This is supposedly the one with the VIA chipset and a Firmware upgrade as installed during production.


    The new upgrade went smoothly and, although I've had one instance of a spontaneous disconnect yesterday (apparently all drives), it's been much more solid than before.


    A little more time is needed to prove itself, but so far I'm hopeful. I'm using 5 physical drives (2 Desktop and 3 Portable). These are partitioned into 6 logical drives total.


    I'll get a later message out with the link to the Firmware, as well as tips from Sunnie, the tech rep for LaptopMate/Anker who I've been working with since last summer. Apple's engineering appears to not to have been helpful in working with the vendor/manufacturer, to fix the failure to mount problem that also appeared on the new MacBook Pro Retina and the 27" iMac that I tested in an Apple Store with this hub and 3 portable drives.


    Apple claims this is a hub problem. How can this be the case when I've used several Uspeed iterations, as well as an Aluratek, IOGear, SIIG, Targus, TrendNet, D-Link, Belkin, Ultra-Aluminus, and an Inland? All were USB 3.0 powered hubs that exhibited similar problems — yet Apple says it's not their problem. When are they going to wake up?  Their USB 3.0 is broken.


    If anyone has other suggestions, tips, or warnings, please pass that information along. Also, has anyone found a better alternative to the Uspeed hub(s)?

  • DavidClawson Level 1 (0 points)

    I have become such a fanboy but this one has really tripped my trigger. I have this same problem without using a hub. Clearly Apple,s USB 3.0 support is not backward compatible with USB 2.0 and that is the end of the case. Literally none of my expensive USB 2.0 equipment can work reliably now and so i am going to have to replace my sound studio MAC with one of my older PC,s. Tisk.

  • AWMarine Level 1 (5 points)

    David, as I understand your situation, your USB 2.0 devices do not work when connected to the USB 3.0 port(s) on a 2012/2013 Mac? I don't have the fancy equipment you do, but my USB 2.0 gear has worked flawlessly. In fact, at times my USB 3.0 drives have mounted as USB 2.0, even though plugged into a Uspeed 7-Port hub. They worked without error as USB 2.0, but not as USB 3.0.


    I have a 7-Port USB 2.0 hub plugged into my 7-Port USB 3.0 hub and the devices on the USB 2.0 hub have worked fine. I've found the USB 2.0 backward compatibility to work on my MacBook Pro Retina and on my USB 3.0 hub. It's getting the USB 3.0 drives to work on a USB 3.0 hub that's been baffling me since June. Apple has blown it big on USB 3.0 and it's questionable if they're doing anything about it.


    I'm just getting to my mail today and found the below message from a Mac expert. The link likely doesn't fix our immediate problems, but it may help on some others. I'll try it later. Let us know if you do and have any successes.



    On Mar 16, 2013, at 10:57 AM, Chuck wrote:

    Not sure if you noticed this yet, but they have finally released a new SMC update. It doesn't mention USB, but that doesn't mean they didn't fix it. Check it out, let me know. - new SMC should be 2.3f35



    Good luck,


Previous 1 2 3 Next