Previous 1 2 3 Next 72 Replies Latest reply: Jun 10, 2015 6:08 PM by jérômefromnice
HappyBlackJack Level 1 Level 1



Recently I cannot run Java applications for my work. Where it worked before, it doesn't anymore.

It shows the message inactive Plug-in. When I click on it Mac start searching for updates but says everything is up-to-date, so that doesn't resolve anything.

I enabled all the options for Java in security preference in Safari. Also enabled applet Plug-in and Web start applications in Java preferences.

Mac OS X (10.6.8)
  • Matthew Knight Level 1 Level 1

    It sounds like the same problem that I am having today, only I am using Firefox. I've tried using Safari and get the same problem.


    I tried deleted the Java cache files and that didn't make any difference.


    Hope someone comes up with a solution, as I am going to have to resort to using my Windows 7 VM for now.

  • Shirkan79 Level 1 Level 1

    We had the same Problem in our Enterprise. Worldwide Macs weren't able to start any java applications from 10.6.8 to 10.8.x


    I found, that in

    /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.p list

    there is a "JavaWebComponentVersionMinimum" thats responsible for that behavior.


    After running a

    sudo /usr/libexec/PlistBuddy -c "Delete :JavaWebComponentVersionMinimum" /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta. plist


    in terminal all java apps are working again.


    Regards, Shirkan

  • crawlgsx Level 1 Level 1

    Great find! You are my hero this morning haha. I spent the last 2 hours trying to fix or find a solution to this with no luck. Our school uses a Student Information system that is Java based so no Java is not an option!


    Thank You!

  • rickkkk Level 1 Level 1

    Worked for me when many, many other attempts did not. Java changed this morning without notice for me, but after running the script, all is well.


    If you get a message saying "invalid arguments" after cutting and pasting that command line, try removing the space before "plist", as there shouldn't be a space there. Here it is with the space as above:


    /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta. plist


    Should be this without the space:

    /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.p list


    Thanks very much.

  • devoreb Level 1 Level 1

    We too are a large school district with a java based student information system.  This command fixed it, but we have thousands of machines that we have to run this.  At least we have Apple Remote Desktop.

    What happened?  Is Apple responsible for this?  Because everyone was working fine yesterday(1/30/13).

  • InstiGator Level 1 Level 1

    I have the exact same symptoms:

    - Worked fine yesterday

    - Today all java applets are inactive

    - Clicking to activate them causes software updates to open

    - Above fix resolved the issue

  • Joel Bruner1 Level 1 Level 1

    @devorb I'm guessing since Java 6 is End-of-Life February 2013, Apple are jumping the gun by a day and disabling it. Which is kinda crappy, since there is no mention of that in the Java 10.6 Update 11


    We use a Java web app for timesheets and guess what: all January time is due today!


    Thanks again Shirkan!

  • clacopo Level 1 Level 1

    Thanks very much, Shirkan. We were pulling our hair out trying to figure this out and your fix worked Do you happen to know if there are any reasons you should NOT delete the "JavaWebComponentVersionMinimum file". Security vulnerablities??

    Thanks again!


  • Klaus1 Level 8 Level 8

    The recently released Java 7 Update 11 has been blocked by Apple through its XProtect anti-malware feature in OS X.


    Oracle issued the latest update to Java earlier this month to fix a serious zero-day security flaw. The threat was so serious that the U.S. Department of Homeland Security had recommended that all Java 7 users disable or uninstall the software until a patch was issued.


    Apple took action on its own and quietly disabled the plugin through its OS X anti-malware system. And as noted by MacGeneration on Thursday, Apple has again updated its OS X XProtect list, this time to block Java 7 Update 11.


    Because Oracle has yet to issue a newer version of Java that addresses any outstanding issues, Mac users are prevented from running Java on their system.


    Over the last few years, Apple has moved to gradually remove Java from OS X. The Mac maker dropped the Java runtime from the default installation for OS X 10.7 Lion when the operating system update launched in 2010. Java vulnerabilities have been a common exploit used by malicious hackers looking to exploit the OS X platform.


    Most notably, the "Flashback" trojan that spread last year was said to have infected as many as 600,000 Macs worldwide at its peak. Apple addressed the issue by releasing a removal tool specifically tailored for the malware, and also disabled the Java runtime in its Safari web browser starting with version 5.1.7.



    Javascript should not be disabled (it has nothing to do with Java).

  • Shirkan79 Level 1 Level 1

    Sorry Guys and Girls, I think. that was only a temp solution


    After 24hours and restarting the client, the obove mentioned plist will be downloaded automaticly from apple again.


    Apple blocks now every (at this time currently official available) Java version.

    The latest official java version is 1.6.0_37-b06-434 for the web-plugin and for the runtime, that you could get from Orcacle:


    But Apple blocks all lower versions then 1.6.0_37-b06-435 for Webplugin and for rumtimes via their XProtect Anti-Malware System, whats came ith 10.6.


    Currently we have to workaround that, every 24hours after a reboot of the clients.

    In our Enterprise, we run a management platform, where i can configure logon-scripts to change the versions in the plist back to the current available, but in fact that means, Orcle or Apple have to release a Java-Update. And thats very quickly.

    We are in the position that we need java to run certain applications from 3rd party companies for our work in the company. This is the only way to get our users ready for work. Hard decision Apple...


    At the moment, no Mac-Computer worldwide is able to run any Java-Applicationwithout the temporary workaround before a newer Java Version will be released and installed.


    There is a newer Java Version out there, but its for developers only, and i have no developer account...


    Regards, Shirkan

  • SWS_SB Level 1 Level 1

    Java 7 Update 12 may not have the latest security updates that Java 7 Update 11 has, but can be found at

  • giora11411 Level 1 Level 1

    well so is there a way to get it working again i have OSX 10.6.8 and not sure what to do  ??  help

    Shirkan79 please explain in a simple way for a causual user what to do

    many thanks


  • Robb1068as Level 1 Level 1

    Shirkan, just so I'm understanding you correctly, you're saying that Apple has blocked even the 1.6.0 Java applet from running in Safari? I was aware that they were blocking certain builds of java 1.7, but thought that 1.6 was out of scope.

  • Joel Bruner1 Level 1 Level 1

    Well rather than delete the key you could set it to require the last Java release 37 that Apple put out, otherwise when you delete it you are allowing any Java version to run.


    This will set it to the last version Apple put out, Java SE 6 release 37:

    sudo /usr/libexec/PlistBuddy -c "set :JavaWebComponentVersionMinimum 1.6.0_37-b06-434" /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta. plist


    The version number I use is referenced from: 8-x/

Previous 1 2 3 Next