Previous 1 2 3 Next 34 Replies Latest reply: Feb 4, 2013 7:16 PM by davidabc
bigredlions Level 1 Level 1 (0 points)

Java in suddenly stopped working. Get "inactive plugin". Things were fine yesterday. Checked Java preference and everthing looks fine. Running os 10.6.8. Does anyone have a fix?

  • dimitrikoh Level 1 Level 1 (0 points)

    I have exactly the same issue.

    1) Plug-in is enabled in Java Preference.

    2) Plug-in is enable in Safari Preference Security tab.

     

    I supposed to get enable plugin dialog when I click on "inactive plugin" area,

    but my click starts Software Update dialog instead. But everything is updated.

     

    I have 10.6.8 on my MacBook Air.

    java version "1.6.0_37"

    Java(TM) SE Runtime Environment (build 1.6.0_37-b06-434-10M3909)

    Java HotSpot(TM) 64-Bit Server VM (build 20.12-b01-434, mixed mode)

     

    I even performed Repair Disk Permissions by DiskUtility.

    Thanks.

  • bigredlions Level 1 Level 1 (0 points)

    When I click on the "inactive plugin" I get Software Update too. Yet everything is updated.

    Sounds like we exactly the same problem.

    Hopefully someone has a fix.

     

    I have Java SE6  version 1.6.0_37-b06-434

  • Klaus1 Level 8 Level 8 (46,775 points)

    The recently released Java 7 Update 11 has been blocked by Apple through its XProtect anti-malware feature in OS X.

     

    Oracle issued the latest update to Java earlier this month to fix a serious zero-day security flaw. The threat was so serious that the U.S. Department of Homeland Security had recommended that all Java 7 users disable or uninstall the software until a patch was issued.

     

    Apple took action on its own and quietly disabled the plugin through its OS X anti-malware system. And as noted by MacGeneration on Thursday, Apple has again updated its OS X XProtect list, this time to block Java 7 Update 11.

     

    Because Oracle has yet to issue a newer version of Java that addresses any outstanding issues, Mac users are prevented from running Java on their system.

     

    Over the last few years, Apple has moved to gradually remove Java from OS X. The Mac maker dropped the Java runtime from the default installation for OS X 10.7 Lion when the operating system update launched in 2010. Java vulnerabilities have been a common exploit used by malicious hackers looking to exploit the OS X platform.

     

    Most notably, the "Flashback" trojan that spread last year was said to have infected as many as 600,000 Macs worldwide at its peak. Apple addressed the issue by releasing a removal tool specifically tailored for the malware, and also disabled the Java runtime in its Safari web browser starting with version 5.1.7.

     

     

    Javascript should not be disabled (it has nothing to do with Java).

  • davearre Level 1 Level 1 (0 points)

    I am having the same problem here. 800+ Macs running Snow Leopard no longer can run Java... and our gradebook program is a Java webapp... Grades are due Monday.

     

    Nice.

  • bigredlions Level 1 Level 1 (0 points)

    I'm not sure this applies to my problem as 10.6.8 doesn't run Java 7

  • bigredlions Level 1 Level 1 (0 points)

    Did this problem just start today for 10.6.8 users?

  • dimitrikoh Level 1 Level 1 (0 points)

    It seems so. Yesterday It worked. And doesn't seem I install any updates. Just stopped to work.

    I see no options just switch to Linux.

  • SWS_SB Level 1 Level 1 (25 points)

    The only 'fix' I think may work so far: Deleting the XProtect source file that lists the blacklisted Java.

     

    Using Finder, go to System - Library - CoreServices and righ-click on CoreTypes.bundle. Choose Show Contents and then go into the Resources folder in the new window that opens. Scrolling to the end will show Xprotect.meta.plist in the list, I deleted that file (right-click and Move to trash, need to enter password to approve) and then was able to run Java apps in 10.6.8.  Not sure how dangerous this is right now, or if it might get rebuilt by by OS X after a reboot.  Will update when I know more, but if you are desperate to try to get something working, worth a shot.

  • dimitrikoh Level 1 Level 1 (0 points)

    Oh, man, that worked. What a relieve! You saved me a lot of time.

    I really appreciate this. Thanks.

  • bigredlions Level 1 Level 1 (0 points)

    To SWS_SB, thanks for the info. I wonder how dangerous this is also. I appreciate it that you'll update us as your know more. Thanks again.

  • SWS_SB Level 1 Level 1 (25 points)

    Additional updates:  Yes, this fixes 10.6.8 for the time being.  However after a reboot the plist is re-built (and may occur at other times).  The file being deleted only contains blacklists for Flash and Java 6 and 7, so if you are a fairly safe web user should be OK. If you want to prevent the rebuild of the list, going into System Preferences and Security, clicking the lock icon to change settings (enter password) and unchecking the 'Automatically update safe downloads list' prevents the xprotect.meta.plist file from getting rebuilt upon reboot. This isn't the great for people who are not the safest of computer users, but should be OK short term, pending any updates.  Java 10.6, which can only run Apple's Java, may stay dead if Apple doesn't issue a 1.6 update.

     

    Updating to 10.8 and running Java 7 update 12 from http://jdk7.java.net/download.html may be the only sure-fire way to keep working right now, at least until Oracle offically releases 12 (and then who knows when Apple may decide to kill it again).

     

    Apple has really given a big middle finger to the Java community at large here - they have literally taken people's businesses offline.  Personally I still prefer a Windows system, where I CAN DECIDE what to run and not to run.

     

  • bigredlions Level 1 Level 1 (0 points)

    Thanks for all the information. It is a rather drastic measure for Apple to take. I only use a few sites that use java and should be allowed to permit java on these trusted sites. The real time stock ticker I use is a java app and I don't want to be forced to give it up. Thanks for helping me understand what's up and for providing a work around. I doubt Apple will provide an update for OS 10.6.8. What a pain it must be for the user that has 800+macs.

     

    Thanks again for the help

    BigRed

  • JeramyMT Level 1 Level 1 (0 points)

    I received this solution in an email from our administrator from another user having this issue (never met you but thanks Jeff!).  This may be a more elegant solution than deleting the file.  I have not tested this yet but thought I would put it up here.

     

    I've put it on two lines, but the entire command should be one one line. Run it in Terminal.


    sudo sed -ie 's/1.6.0_37-b06-435/1.6.0_37-b06-434/'

    /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.p list

  • alucasTHX Level 1 Level 1 (5 points)

    OK.  I have a fix for you all that seems to work especially if you need Java 6u37 working on any computer Apple disabled it on.  This will work best on 10.6 but can work on 10.7/10.8 as well.

    Do not attempt this if you do not know what you are doing.

    I will not be held responsible for your system if it stops working or you expose yourself to a virus.  If you are a novice user, you attempt to do this, and something goes wrong, remember you were warned.

    DO THIS AT YOUR OWN RISK:

     

     

    Using whatever editor you want at command line as root or using sudo, you will need to edit:

    /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.p list

     

    Change:


    <key>JavaWebComponentVersionMinimum</key>

    <string>1.6.0_37-b06-435</string>

     

    To:


    <key>JavaWebComponentVersionMinimum</key>

    <string>1.6.0_37-b06-434</string>

     

     

    Change:


    <key>MinimumPlugInBundleVersion</key>

    <string>1.7.11.22</string>

     

    To:


    <key>MinimumPlugInBundleVersion</key>

    <string>1.7.11.21</string>

     

     

    And best of all, change:


    <key>LastModification</key>

    <string>Thu, 31 Jan 2014 16:55:59 GMT</string>

     

    To any date in the future.  (Bad programming on Apple's part but repreive for those of us who have to support archaic Oracle based systems that won't work under Java 7+.)  It won't update again until after the date you put in there.

     

    DO NOT Delete any of the lines that have to do with version number because it will allow older versions of Java, which are not secure, to run.  I would also not recommend that you change the date too far ahead if you are on 10.7/10.8 and are running Java 7 because the security holes in Java 7 are horrible.

Previous 1 2 3 Next