Previous 1 2 3 Next 62 Replies Latest reply: Oct 25, 2013 5:46 PM by Fay Kelley
ConvertApple Level 1 Level 1

I had a lot of problems getting Apple_TV_3 + itunes to work 100% reliably. Eventually I built a totally new server, used static ip's and I DID get a stable system that ALWAYS worked as expected re itunes home sharing -> Apple_TV.


Home sharing to iphone/ipad was hopeless (via music/video apps), the circle spinner would go for 10+ mins without listing the media. I therefore ran TVersity on the server and using the AirPlayer app on iDevices can play media fine so no longer use the build in apps, unless for media local to the device.


Since updating to 5.2 all appeared to be working well, however if Apple_TV has not been used for a few hours and I run the remote app, I CAN initially use the control part of the app, BUT pressing computer says "turn on home sharing blah blah blah..." If I then hit the button to list the devices, the updated ATV device is NO longer shown. However my OTHER Apple_tv (still on 5.1) IS still there, even though it has been sleeping for days. Both were 100% reliable before this.


I've done a Reset on the updated Apple_TV and set it to sleep after 15 mins and will monitor progress. I've downloaded the 5.1 ipsw, I hope Apple are STILL signing it. I'll test for another day or two but it it happens again I'll downgrade. If YOU have a stable system I would advise NOT upgrading to 5.2.


Does someone know what ports to block on router to stop the ATV checking and therefore relentlessly prompting you to upgrade, that's the only reason I upgraded to stop the messages.



Lastly since buying into apple-technology 2.5 years ago for the sole reason of anticipated reliability as though I have the ability I do not have the time to endlessly jump through hoops to make devices work as intended I have become very disillusioned. Unfortunately Apple seem to be just as hopeless as everyone else, re reliability, do they test anything?

Apple TV, iOS 5.1.1
  • ConvertApple Level 1 Level 1

    Update: No after about 20 mins of no use (with sleep set to 15 mins) the ATV is no longer listed in the list of devices in the remote app. Luckily I have 2 ATV's and the old one works fine making it easy for me to contrast and compare. 5.2 is 100% definately BROKEN, the problem is easily reproduceable. I am now downgrading to 5.1


    I am running itunes on pc which has been solid for over a week.



    Apple devs = truly pathetic, you should be ashamed of such shoddy work

  • ConvertApple Level 1 Level 1

    I have downgraded back to 5.1.1 and it is again working 100% perfect!


    So for clarity to repro problem to lazy apple devs:-


    1) Set up Apple_TV on 5.2 with home sharing working + ATV set to sleep after 15 mins

    2) Set up a second Apple_TV on 5.1.1 with home sharing working + ATV set to sleep after 15 mins

    3) Run remote app on iphone, click 2 boxes icon at top left of screen, you should see Both ATV's visible

    4) Leave ATV's to got to sleep, but wait for 30 mins total (even though set to 15 mins)

    5) Run remote app on iphone, click 2 boxes icon at top left of screen, you should see the ATV_5.1.1but alas the ATV_5.2 has vanished

    6) Wake up the ATV_5.2 with silver remote, click Computers and it says "turn on home sharing etc etc" - the ONLY way to get it back is to restart the ATV

    7) Wake up the ATV_5.1.1 with silver remote (or remote app), click Computers and it works fine.


    Whoever does Apple's Beta testing would be in the dole queue if I were running the department. Probably the dev's as well - so easy to reproduce. This is the LAST firmware update from APPLE that I EVER trust, once I work out how to stop the nag screens by blocking the ports on my router I'm done! I've wasted days and days of my time since I bought these ATV's. Anyone thinking of buying an ATV, DON'T unless you are very techie with lots of free time (or don't use home sharing, remote-app etc).

  • KJILM123 Level 1 Level 1

    @ AppleConvert,


    I totally agree with your posts especially the last one. I have wasted tons of time with apple products. Both Apple TV as well IPad 3. Days and nights, I am sleep deprived and at Apple they don't give hoot except presentations from Tim Cook of how many millions they have sold to us. Next....

  • Berend de Meyer Level 1 Level 1

    Did you try to check/reset your settings in iTunes?

  • ConvertApple Level 1 Level 1

    Huh? Did you not read post #3 ?

    Latest iTunes 11 is working 100% fine as are BOTH my apple-tv's on 5.1.1.


    It's a very easily recreated bug with very clear steps on how to do so



    I have also now set both ATV's to manual network settings and set DNS to an unused address. No DNS = no prompts to update, also means no ATV Internet access but I rarely use it so. I'd prefer to block the ports but google didn't know and I've spent enough time on it so quickfix will suffice.

  • Winston Churchill Level 10 Level 10
    Mac OS X

    It's a very easily recreated bug with very clear steps on how to do so


    I can't recreate it.


    Your post is misleading, there is no bug, just because you have a problem with your set up, does mean there is a problem with the Apple TV and that others will encounter the same problems as you.

  • imagodoc Level 1 Level 1

    I am (was) using ATV 5.2 and it is CRAP. Here are the problems (so far):


    1. I can not launch anything on Apple TV (Movies, TV shows, Music, etc.) When I try, I get the spinny thing (fooling me into thinking my choice is being activated). Then it just dumps back to the original opening (home) screen.
    2. Leaving ATV open, it will intermittently go into the spinny screen and then back to the original opening (home) screen; I assume this is because it is trying to go into screen-saver mode and is crashing instead.


    I have tried Restart, Reset, disconnecting/reconnecting everything: No change.


    This is very frustrating, especially since I have a subscription to several TV shows on ATV that I can not get to now.


    So far the only solution I have read about is to downgrade to 5.1 (and then deal with constant reminders to upgrade, but I guess that's the price to be paid).


    Has anyone got any other ideas?

  • KJILM123 Level 1 Level 1

    @ All,


    I had the same problems even with two updates before which was 5.1. and I went back to 5.02 not 5.2. I could not update for months, so I restored it several times to 5.02 and just waited, until recently I just tried to see if it was the same thing with the new update which was the 5.1.1. And it finally did work out. I even sent emails to some guy that asked for my Router and settings, which I gave, never got a reply from it, while others had. So I just waited and waited and then when the 5.1.1 came out, I updated that one and all was well. Finally after 3-4 months.


    I had the same crap as Imagodoc, spinning, not activation, loosing connection and you name it with 5.1. Resetting modems, routers, Computers, IP pools, reinstallation, clear settings.... It was ****. It took me days to figure out that I was just wasting my time with it. So I just left it at some point.


    5.1.1 does work for me. But I have not reset it yet, which could still mean it goes back to the same situation as I had before, because that is what I do, I reset the Apple TV before I update and then fill in the settings again and try to reconnect and activate. Now I just did the update over the installation itselves and it has been good until yesterday because it had lost it IP address on wireless and went to a 169.XXX.XXX.XXX adress. Do not know why it had done this. Normally this is when it can't find an suitable IP address on DHCP router IP address that is available. I have 100 DHCP addresses available. So I restarted it and Apple TV took the old IP address again that I had put in my router in the Mac address Table which was assigned to Apple TV. This I also do this to all my devices so they always take the same IP address from the DHCP because they are forced to do it. I don't like Dynamic DHCP because when it takes all different IP addresses from the pool sometimes other computers and devices will have a conflict if it takes a IP address from another device that you has not been used for longer than a day because the time of the IP address refreshment is set to 1 day. I always use 1 day because it keeps the address pool healthy in DHCP like that.


    I have hardly problems with any other computer, laptops concerning that. But I have had now two major problems with iPad's 3 and Apple TV's which has caused me days and nights to get sorted and to restore. This is wearing me out that it takes days to recuperate from it. Which is very annoying because when I was working for Apple in the past, things just used to work. From the box to when  you decided to discard it. Always working. Hardly any problems. But with the continual updates rammed out at blowing their nose at Apple all the time and a cough is just terrible. As far as I can see they are just alpha and beta updates instead of an official one that is universal applicable that works. The stupid ways of 5.0. 5.01. 5.02, 5.1, 5.1.1, is just rediculous and no need for. Small increments of changes does not make sense to me. Do immediately from 5.0 to 5.1.1. test it properly in all kinds of settings then release it. Make sure you cram it all in instead of small changes that makes hardware jittery and not functional. Which is the case nowadays.


    But it is not uncommon with Apple alone, Microsoft is the worst offender with it. Their updates are abominable and farcical. Always because someone "who takes over your computer attacker updates" !!!! Make it proper fireproof then before you release it and they know very well that there are holes in it that huge trucks can go through it.  Yet still publish it it.  Does anyone remember Windows NT 4.0 !!!! Seven service packs !!!! Why ???


    Organizations like Apple and Microsoft are only geared on selling and making fast money and no more directed on the customer individuality and grieves. When the grieves Peter out and finally start to work nice, they give you a new product and the whole merry go round happens again to the agrivation of the customer. Year in year out.


    But I tell you what, if they carry on like this, I refuse to go to that shop anymore. I have enough of it myself. Thank you,

  • donkeyapel Level 1 Level 1

    The same thing is happening to me.  How do you downgrade back to the 5.1?

  • KJILM123 Level 1 Level 1

    Hi Donkeyapel,


    Dont use 5.1 use 5.02. Restore using Itunes and a micro usb cable. Put on the back of the Apple TV and in USB port of a computer and then power up the Apple TV with the Power cable. Then use Shift while clicking Restore and it will look for the Apple Firmware you download here first and put in a directory on Computer:




    Do not use the HDMI cable. Which means you carry your Apple TV to your Computer where Itunes is. Unless your computer is next to the TV unplug the HDMI cable from the TV,

  • whatheck Level 5 Level 5

    Try signing out of your iTunes account and then signing back in, as suggested by this Apple doc ->

    Apple TV: Unable to access Movies, TV Shows, or other iTunes features after updating



    After updating to Apple TV Software 5.2, attempting to use the following features may result in Apple TV unexpectedly returning to the main menu:


    • Movies
    • Music
    • TV Shows
    • Other iTunes Store features



    You can resolve this issue by signing out of your iTunes Store account, and then signing back in:


    1. Select Settings > iTunes Store
    2. Select your account, and then select Sign Out
    3. Select Add New Account
    4. Sign in to your account


    Verify that the issue is resolved by accessing Movies or TV Shows on your Apple TV.


    If you encounter an issue signing in or out of your iTunes Store account, try restarting your Apple TV.

  • ConvertApple Level 1 Level 1

    Except you didn't try and recreate it exactly as per instructions, you just wrote a post.

    I've been developing software day in day out since 1984 and its a bug.

    The ability to see problem, downgrade, see problem vanish is very clear.


    As stated my ATV's are BOTH working solid on 5.1.1 and WILL not be upgrading ever.

  • ConvertApple Level 1 Level 1

    So how does this explain 5.2 working fine UNTIL it sleeps for a while when only an ATV reboot reconnects. Yet the 5.1.1 ATV works flawlessly doing exact same thing?


    Anyone out there with 2 ATV's please try post #3 to the letter. Anyway I'm happy on 5.1.1 if you're happy on 5.2 good luck!

  • Winston Churchill Level 10 Level 10
    Mac OS X

    How many times do you want me to try this, I even left it overnight and tried it again, it works just fine everytime.

Previous 1 2 3 Next