Previous 1 2 Next 29 Replies Latest reply: Sep 24, 2013 12:50 PM by Mike .
Larry McJunkin Level 1 Level 1 (30 points)

I recently installed the most current, updated version of Evernote and noticed that its new Menu Bar Helper wasn't working.  I could click and open it, but nothing in it was clickable (voice notes, quick text note, screen capture, gear icon for setttings)...nothing.


So, for step one I booted into Safe Mode and then launched "only" Evernote.  This fixed it...the Menu Bar Helper worked just fine.  Then I manually launched every app I normally have automatically load at app at a time, and after each app loaded I checked to see if the Evernote Helper was working.  I finished loading all apps and the Evernote Helper was still working.


OK...I figured I'd try that process in reverse, so I did a normal boot, confirmed the Evernote Helper was not working, then one by one, I closed every open app, checking the Evernote Helper after each one.  When I was finished closing all the apps the Evernote Helper was still not running.


One of these two processes of elimination should have found the culprit causing the Evernote Helper to not function.  I also quit a few processes I knew were associated with apps, even though I'd closed the actual app.  If anyone else has a suggestion, I'd love to hear it.  Thanks!

MacBook Air, OS X Mountain Lion, + 24-inch LED Cinema Display
  • Niel Level 10 Level 10 (289,445 points)

    You didn't completely do the process in reverse; there are system-level differences in safe and normal boots.



  • Larry McJunkin Level 1 Level 1 (30 points)

    OK...while I appreciate this insight, any idea how to isolate which system level item might be causing this?  I just wanted to see if any of my installed apps could be causing it, and apparently they're not.


    Also, not sure if the "(78281)" means anything.  It doesn't seem to correlate to a KB article.  Thanks, Niel.

  • Larry McJunkin Level 1 Level 1 (30 points)

    @Niel: I tried adding another user and then installing worked just fine.  I suppose I'm going to have to wipe this machine and start over again.  Hate to waste the time installing over 60 apps and configuring everything again, but this may be the only solution.

  • Linc Davis Level 10 Level 10 (177,680 points)

    What are your login items?

  • Larry McJunkin Level 1 Level 1 (30 points)

    @Linc: I forgot to post that I've already checked the login items and disabled them...they're all app-related.  The problem still exists after disabling them.


    Any chance this will help:

  • Linc Davis Level 10 Level 10 (177,680 points)

    Any chance this will help


    No, because something in your home folder is causing the problem.


    Please read this whole message before doing anything.
    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.
    Third-party system modifications are a common cause of usability problems. By a “system modification,” I mean software that affects the operation of other software — potentially for the worse. The following procedure will help identify which such modifications you've installed. Don’t be alarmed by the complexity of these instructions — they’re easy to carry out and won’t change anything on your Mac.


    These steps are to be taken while booted in “normal” mode, not in safe mode. If you’re now running in safe mode, reboot as usual before continuing.


    Below are instructions to enter some UNIX shell commands. The commands are harmless, but they must be entered exactly as given in order to work. If you have doubts about the safety of the procedure suggested here, search this site for other discussions in which it’s been followed without any report of ill effects.


    Some of the commands will line-wrap or scroll in your browser, but each one is really just a single line, all of which must be selected. You can accomplish this easily by triple-clicking anywhere in the line. The whole line will highlight, and you can then copy it. The headings “Step 1” and so on are not part of the commands.


    Note: If you have more than one user account, Step 2 must be taken as an administrator. Ordinarily that would be the user created automatically when you booted the system for the first time. The other steps should be taken as the user who has the problem, if different. Most personal Macs have only one user, and in that case this paragraph doesn’t apply.


    Launch the Terminal application in any of the following ways:


    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)


    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.


    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.


    When you launch Terminal, a text window will open with a line already in it, ending either in a dollar sign (“$”) or a percent sign (“%”). If you get the percent sign, enter “sh” and press return. You should then get a new line ending in a dollar sign.


    Step 1


    Triple-click the line of text below to select it:
    kextstat -kl | awk '!/com\.apple/{printf "%s %s\n", $6, $7}'
    Copy the selected text to the Clipboard by pressing the key combination command-C. Then click anywhere in the Terminal window and paste (command-V). Post the lines of output (if any) that appear below what you just entered. You can do that by copying and pasting as well. Omit the final line ending in “$”. No typing is involved in this step.
    Step 2


    Repeat with this line:
    sudo launchctl list | sed 1d | awk '!/0x|com\.(apple|openssh|vix)|edu\.mit|org\.(amavis|apache|cups|isc|ntp|postfix|x)/{print $3}'
    This time you'll be prompted for your login password, which you do have to type. It won't be displayed when you type it. Type it carefully and then press return. You may get a one-time warning to be careful. Heed that warning, but don't post it. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator.


    Note: If you don’t have a login password, you’ll need to set one before taking this step. If that’s not possible, skip to the next step.


    Step 3
    launchctl list | sed 1d | awk '!/0x|com\.apple|edu\.mit|org\.(x|openbsd)/{print $3}'
    Step 4
    ls -1A /e*/mach* {,/}L*/{Ad,Compon,Ex,Fram,In,Keyb,La,Mail/Bu,P*P,Priv,Qu,Scripti,Servi,Spo,Sta}* L*/Fonts 2> /dev/null
    Important: If you formerly synchronized with a MobileMe account, your email address may appear in the output of the above command. If so, anonymize it before posting.


    Step 5
    osascript -e 'tell application "System Events" to get name of every login item' 2> /dev/null
    Remember, steps 1-5 are all copy-and-paste — no typing, except your password. Also remember to post the output.


    You can then quit Terminal.

  • Larry McJunkin Level 1 Level 1 (30 points)

    Thanks, Linc.  I probably should also have told you I'm a retired developer and tech biz owner, so I'm very familiar with my computer...but appreciate your words of reassurement that none of this will harm anything.  I suspect most folks needing help here don't even have a clue what Terminal is.  Even if we don't isolate the offending app here, I usually nuke my Mac every couple of years or so and start over...not for any real reason other than maybe a throwback from the old Windows days...I know it's not necessary, especially since I uninstall all unused apps with a good uninstaller.  So there's always a complete reinstall as a last resort.


    Anyway, I have a lot on my plate today...but will try to do this later today or this evening and post the results.  And I sincerely appreciate your help.

  • Larry McJunkin Level 1 Level 1 (30 points) are the results of the five steps.  I notice two items referenced that are no longer on my system (Microsoft Office & doubleTwist).  Let me know if you need anything else.


    Step 1 results:


    foo.tun (1.0)

    foo.tap (1.0)


    Step 2 results:







    Step 3 results:
















    Step 4 results:


    /Library/Address Book Plug-Ins:

    DYMO Address Book Addin.bundle


















    /Library/Input Methods:


    /Library/Internet Plug-Ins:

    DYMO NPAPI Addin.plugin

    DYMO Safari Addin.plugin

    Flash Player.plugin

    Flip4Mac WMV Plugin.plugin


    Quartz Composer.webplugin

    QuickTime Plugin.plugin








    /Library/Keyboard Layouts:

















    Box Sync.prefPane

    Flash Player.prefPane

    Flip4Mac WMV.prefPane




    Google Drive Icon Helper










    Flip4Mac WMV Advanced.component

    Flip4Mac WMV Export.component

    Flip4Mac WMV Import.component






    Microsoft Office.mdimporter














    Library/Address Book Plug-Ins:






    Library/Input Methods:



    Library/Internet Plug-Ins:




    Library/Keyboard Layouts:




    com.adobe.ARM.202f4087f2bbde52e3ac2df389f53a4f123223c9cc56a8fd83a6f7ae.plist 0121D018D.plist











    Step 5 results:


    BoxSyncHelper, PopClip, Bartender, Garmin Lifetime Map Updater, iTunesHelper, MUMenu, Skype, Dropbox, Fantastical, Google Drive, Wunderlist, TransmitMenu, Tweetbot, Google Notifier, TextExpander

  • Linc Davis Level 10 Level 10 (177,680 points)

    Please read this whole message carefully, especially the warnings, before doing anything.

    1. The changes to your configuration suggested here should be considered provisional; they may not solve your problem, or they may remove functionality that you find useful. If a third-party system modification that you want to keep is causing the problem, seek help from its developer.

    2. WARNING: Back up all data now if you haven’t already done so. Before proceeding, you must be sure you can restore your system to its present state, even if it becomes unbootable. If you’re not sure you can do that, STOP — DON’T CHANGE ANYTHING. If you’re dissatisfied with the results of the procedure suggested below, restore from your backup. I will not be responsible for the consequences, and I will not be able to help, if you ignore this warning.

    3. You should either remove or update the following system modification(s), if an update is available from the developer:


    and definitely remove at least the following:


    4. Whatever you remove must be removed completely, and (unless otherwise specified in this message) the only way to do that is to use the uninstallation tool, if any, provided by the third-party developers, or to follow their instructions. If the software has been incompletely removed, you may have to re-download or even reinstall it in order to finish the job. I can't be more specific, because I don't install such things myself. Please do your own research.

    Here are some general guidelines to get you started. Suppose you want to remove something called “BrickYourMac.” First, consult the product's Help menu, if there is one, for instructions. Finding none there, look on the developer's website, say (That may not be the actual name of the site; if necessary, search the web for the product name.) If you don’t find anything on the website or in your search, contact the developer. While you're waiting for a response, download BrickYourMac.dmg and open it. There may be an application in there such as “Uninstall BrickYourMac.” If not, open “BrickYourMac.pkg” and look for an Uninstall button.

    Again, please don't ask me to do this research for you. You can do it better than I can, because I haven't installed the product and I may not even know what it is.

    If you can’t remove software in any other way, you’ll have to erase your boot volume and perform a clean reinstallation of OS X. Never install any third-party software unless you're sure you know how to uninstall it; otherwise you may create problems that are very hard to solve.

    WARNING: Trying to remove complex system modifications by hunting for files by name often will not work and may make the problem worse. The same goes for "utilities" that purport to remove software.

    5. I recommend that you never reinstall the modifications marked with a dagger (†) above, if any. If your problem is resolved after uninstalling all the above modifications and rebooting, but you still want to use some of those not marked with a dagger, you can experiment with putting them back, one at a time, testing carefully after each step. Keep in mind that system modifications may be incompatible with each other or with future OS X updates, so it may not be clear which one is at fault.

    6. If you still have problems after making the suggested changes and rebooting, post again. Remember: if you don’t like the results of this procedure, you can undo it by restoring from the last backup you made before you started.

  • Larry McJunkin Level 1 Level 1 (30 points)

    Linc...I "completely" uninstalled the one application you recommended (Bartender)...and rebooted.  The problem still exists.  I am posting a screenshot of the Evernote Menu Bar Helper window which is the problem.  Each icon at the top of this window should display it's name when mousing over it, and each should be clickable.  Nothing happens a all...the actual window is just as static as the image I'm posting.


    Screen Shot 2013-03-08 at 10.08.20 AM.png


    I hope this helps.  Let me know if you need anything else.

  • Linc Davis Level 10 Level 10 (177,680 points)

    If I understand you correctly, your problem is entirely specific to "Evernote." Everything else is working. The only question that isn't specific to "Evernote" is why it works only in safe mode. Possibly some system modification that doesn't load in safe mode is interfering with it.


    The only other likely culprits I see are the so-called "utilities" you've chosen to install, such as "Cocktail" and "MemoryClean." They're worse than useless, like all "utilities," so you'd lose nothing by getting rid of them permanenly, even if they aren't causing this problem. If that doesn't help, you'd have to refer to the Evernote developer for support. I don't use the product.

  • Larry McJunkin Level 1 Level 1 (30 points)

    Correct, Linc.  Everything else works just fine.  Even the Evernote Menu Bar Helper works fine in Safe Mode and also if I add a new user and install nothing but Evernote.  It is only NOT working under my account (admin).  The developer doesn't have a clue...their opinion is if it works for a new user and in safe has to be a problem on my end...and I have to agree with them.  BTW, I rarely use Cocktail, except for an occasional disk check or permissions repair, and I didn't even realize I still had Memory Clean still on the system.  It actually does get good reviews, but as you say, it's pretty much useless.


    I'll try a few more things...but ultimately, I'm sure I'll end up wiping the system and starting over again.  I'm OK with that...I've done it many times over the years, but it's just a waste of time configuring everything again.  Oh, well :-(  Thanks for trying.

  • Linc Davis Level 10 Level 10 (177,680 points)

    Maybe I wasn't clear or I haven't understood you. Does Evernote in fact work in your account in safe mode?

  • Larry McJunkin Level 1 Level 1 (30 points) I previously posted, there is no problem with Evernote if I boot into the Safe Mode in my account.  And if I create a new user, then install Evernote as the only additional app, Evernote also works fine.

Previous 1 2 Next