Previous 1 2 Next 23 Replies Latest reply: May 3, 2014 4:39 AM by Lyn Murdock
thisisfred Level 1 Level 1 (0 points)

Hi everybody,

 

today I purchased the professional version of IBMs SPSS Statistics. The installation process went smooth with no problem but I absolutely can't start the application.

 

Here's the exact process:

 

  • I launch SPSSStatistics from my applications folder
  • The startup window pops up
  • After approximately one minute I get an error message saying: "Generic network error inet:local computer:0"
  • The only option is to click "OK" which leads me to a window with the heading "server log in: local computer" where I can select a server "local computer" or add a new one.
  • When playing around with these options I get the message that the application can't connect to the local host.

 

I have absolutely no idea what to do. The application runs smoothly on my Windows via bootcamp.

 

I am running OS X 10.8 on my 2009 MacBook.

 

Any help is appreciated. Thank you.


SPSS 21, OS X Mountain Lion (10.8.2), Mid-2009 MacBook
  • HSG-HK Level 1 Level 1 (10 points)

    Hi Fred,

     

    I am having exactly the same problem. Running OSX 10.8.2 on Early 2011 MBP. Running latest Java too. Have IBM tech support been of any assistance?

  • thisisfred Level 1 Level 1 (0 points)

    Hi,

     

    I called the IBM tech support. But since I "only" own a student license they can't offer me telephone support and send me a link to a website. I tried sending a support request but the website won't let me.

     

    I also contacted my university's tech support but they weren't able to help either and need to contact IBM. Maybe they find an answer.

  • HSG-HK Level 1 Level 1 (10 points)

    That's an awful predicament to be in! Let me know if you get any resolution. I will do the same. HSG

  • thisisfred Level 1 Level 1 (0 points)

    I surely will. Let's hope we can solve this problem sooner than later as my licence runs out on Aug. 1st!

  • HSG-HK Level 1 Level 1 (10 points)

    Fred, can you make a new user profile with Administrator rights (System Preferences -> Users & Groups -> Click the padlock, enter your password, then press the + button). Once created, log out of your usual username entirely. Log into the new user. Try to open SPSS, let me know if it works.

  • thisisfred Level 1 Level 1 (0 points)

    Wow. This works. This is strange since my usual user is markes as "admin" …

     

    Thanks a lot!

  • HSG-HK Level 1 Level 1 (10 points)

    Did you migrate all of your files from the original user? If so, what approach did you take and did it corrupt the new user?

  • HSG-HK Level 1 Level 1 (10 points)

    Fred,

     

    Did you manage to fix the problem on the original user account? Or are you using two different accounts so that you can use SPSS?

  • gasano Level 1 Level 1 (0 points)

    Hi Fred, I am having the same problem you outlined. SPSS 21 (27" iMac mid-2011, Lion 10.8.3, latest Java). Install is trying to find some local host, then stops responding. I have been working with IBM support. We tried the new account strategy and SPSS 21 did run. But... it is a pain to switch back and forth. So I would be grateful if you could provide an update on your status? Are you switching between accounts? Did you migrate? Any info would be helpful.

     

    P.S. I also tried a re-build of my user admin account (original one, not the special one set up for SPSS) refer to URL below:

     

     

    http://reviews.cnet.com/8301-13727_7-57437548-263/how-to-rebuild-a-user-account- in-os-x/

     

     

    The solution looked promising but I am still getting the same error after the re-build. I am frustrated...

  • thisisfred Level 1 Level 1 (0 points)

    Hi,

     

    until buying my new Retina MacBook Pro I used SPSS 21 with two accounts since I knew that I would get a new laptop soon. So I avoided the stress to migrate all files from the standard user to my SPSS one. Switching back and forth is very annoying, especially when you do not have all your reference journals on the SPSS user.

     

    To mimimalize the effects of having two users I created a shared folder between the two in which I saved all my SPSS outputs and stored all the guides, journals and data I needed to work with SPSS.

     

    In your situation I would recommend to migrate all your data to your new user. It surely isn't the most convenient solution but the only one known to us right now. Here is a small guide to transfer all your data.

     

    http://reviews.cnet.com/8301-13727_7-10386342-263.html

     

    In case you are interested: SPSS runs perfectly on my brand new MacBook Pro. I assume the error is triggered by some action while using the mac.

     

    Hope this helps.

  • gasano Level 1 Level 1 (0 points)

    Thanks for the information. Needless to say I’m jealous... (SPSS working AND Retina MBP).../Grateful.

  • furjo Level 1 Level 1 (0 points)

    I have the same problem, but (thanks to a Dutch site, http://www.onemorething.nl/community/topic/spss-21-opstarten-tip/) I have discovered that SPSS starts normally using Terminal and sudo:

     

    sudo /Applications/IBM/SPSS/Statistics/21/SPSSStatistics.app/Contents/MacOS/stats

     

    (it will ask for your password)

     

    So I suspect it is a problem of permissions. If I find a definitive solution, I will post it here.

  • DanAnderzon Level 1 Level 1 (0 points)

    I had the same problem exactly. I had installed SPSS 21 on a user profile with another local admin account

    I log out and log in with my admin account and installed SPSS 21. There after the user logged in and start SPSS without error localhost.

     

     

    Otherwise, try to only install SPSS version 21.0.0.0 is a subsequent 21.0.0.1 might be the problem?

  • whimsimonical Level 1 Level 1 (0 points)

    I'm having a same problem here, and keep wondering whether I've done something wrong with my current user account since it was fine when i first installed it, and it works good on my new account now. but nothing changes on the side of my original account. i've literally reinstalled SPSS 20 & 21 several times already...

     

    but yea starting SPSS from the terminal is by far the best way to get around with this issue, thanks furjo for this! but please be sure to let us know when there's a final solution!

Previous 1 2 Next