Previous 1 2 3 4 5 6 7 Next 89 Replies Latest reply: Mar 23, 2014 7:36 PM by AndrewC1970 Go to original post
  • Wattonski Level 1 Level 1 (0 points)

    Tried them all - greyed out every time.

  • Csound1 Level 8 Level 8 (44,275 points)

    Then a trip to the Store is the next thing to do.

  • MJbroken Level 1 Level 1 (0 points)

    Not to completely threadjack or anything, but I was experiencing the identical problem earlier. Scanning over the thread I didn't see this suggestion. An alternative solution to 'regain' this space is to relaunch boot camp assistant (as though starting over again), and have it create a 20GB windows partition, as the assistant will have no prior knowledge since the partitioning never completed. After allowing the partition process to seemingly spin its gears for an hour or so, it will ask if you want to 'continue', at this point, cancel the install. Upon re-launching the assistant for a 3rd time, you will have an option to remove your boot camp partition, thus re-gaining all your free space. Anyhow, this saved me a dreadful 1TB+ time machine restore. Good luck.

  • Raymond Jones1 Level 1 Level 1 (25 points)

    My update:

     

    I had another call with Apple support this time, they emailed me a small program that did some sort of diagnostics. It created a file that I emailed back to them. The guy I've been talking to then sent it to the Apple engineers to analyze. I have another scheduled call with them to review tomorrow. I'll keep everyone posted.

  • Gregalawnjee Level 1 Level 1 (0 points)

    Just to directly address the issue of your hard drive showing "1.98 TB" of space:

     

    This apparently happens as soon as you begin partitioning your hard drive in boot camp. I suspect it's because the software is designed only to work with hard drives under 2TB in size, and this is some way to trick your system into thinking it fits that requirement (remember, this was a patch released as a part of the 10.8.3 update).

     

    THE SOLUTION:

     

    Open Disk Utility.

    Select "Macintosh HD" (the full disk, not the partition that appears below it).

         You'll know you've selected the right one because it should show your full 3.12TB capacity on the bottom.

    Click "Repair Disk"

     

    That should solve your problem and bring your displayed storage space back to its full 3.12TB amount.

     

    Hope this helps!

  • Raymond Jones1 Level 1 Level 1 (25 points)

    No I'm sorry "Repair Disc" does nothing. I've spent a total of close to 8 hours on the phone with Apple support. This is the 2nd fusion drive I've been through with the same issue. The first was a 1TB fusion, this one is a 3TB fusion drive.

     

    We could not recover the part of the drive that was partitioned as "Free Space". They even forwarded my situation to the Apple Engineers. They came back with a manual command to type in Terminal to recover that portion of the drive and it failed. It started as "discutil cs bootVolume......." or something close to that. (That was from memory). And it failed.

     

    Long story short they're ordering me a new hard drive as a replacement. We're going to walk through bootcamp when it comes in. The engineers are using me as a guinea pig.

  • Finnatic Level 1 Level 1 (10 points)

    Raymond,

     

    I'm using the late 2012 i7 iMac 27" with a 3 TB Fusion. You are not going crazy. What's happened to you is what happened to me. I tried to do Bootcamp Assistant for the first time, and it froze on the partitioning phase. I literally let the software run for 20 hours trying to wait it out, just to be on the safe side. Eventually, I quit the task, and that's when I noticed the issue with two logical partitions. I had a separate 800.2 gb partition that I could not re-merge with the first partition, no matter what. No option was available in Disk Utility that would work. As Greglawnjee suggests above, repairing the top-level Macintosh HD did nothing. Rebooting with CMD-R and repeating this process did nothing, either.

     

    Then, I tried what another user suggested which was to reboot into the Windows install and manually delete the offending partition (it's hard to decide which, as the sizes in Windows vary from what is reported in OSX, and I wish someone would screenshot what to keep and what to delete). Anyway, after this, I knew that I'd have a messed-up Mac install that I'd have to recover from Time Machine.

     

    At this point, OS X had to do an internet recovery in order to get working again. OS X correctly stated that I had a 3.12 TB partition in Disk Utility. I ran Bootcamp Assistant and let it do its magic. I chose a 520 gb partition (same annoying slider issue as someone else mentioned, I really wanted to put in 512 gb but the slider would not land on that size).

     

    At this point, after installing Windows 8 and doing a Time Machine recovery from the CMD-R screen, I ran Disk Utility and had 3 partitions, the original Macintosh HD partition, a Bootcamp partition, and another Macintosh HD partition. However, the difference this time is that my Finder window reports one logical Mac partition of about 2.5 TB, so OSX is doing some kind of magic behind the scenes to link those two disparate partitions together.

     

    This does bother me, and I do wish that Apple would correct the Bootcamp Assistant to resolve the hang issue and to help users recover from these fragmented partitions when this does occur.

     

    Still, my best bet is to reiterate what someone else already said, and that is to use your Windows installer to remove that annoying partition which OSX is seemingly incapable of removing itself. Then, when you do your system restore from Time Machine, it will logically read as 3 TB only to be split in half physically by the Bootcamp partition.

     

    I hope some of this makes sense. I'm sort of confusing myself here the more I read what happened to me.

  • Raymond Jones1 Level 1 Level 1 (25 points)

    Finnatic,

     

    You captured my situation exactly! I was able to use Windows 8 installer to delete the unwanted partition. You are absolutely correct in that all partitions are labeled differently and of course they all have different file sizes than what disc utility states they have. Why wouldn't they? UGH!

     

    I went and deleted that unwanted partition. The only problem is that it then labels that partition and all it's space as a format type: "Free Space". That Free Space is now unformatable... so you basically have lost a large chunk of your hard drive. It's the most annoying thing on the planet and Apple doesn't know how to fix it. At least no one I've spoken to at Apple care.

     

    They've ordered me a new 3TB fusion drive and I should have it back tomorrow. They're going to walk me through the install process. I don't even care if I get back to the original problem of having three partions like so listed in Disc Utility:

     

    Macintosh HD

    Bootcamp

    Macintosh HD

     

    At least then I still had all of my drive space available to me.

  • rellimie Level 1 Level 1 (0 points)

    I had the same issue that everyone is talking about here.   I have a 27" iMac with the 3TB fusion drive.  I attempted to use the bootcamp assistant to install Windows 8.   The partition phase locked up and I lost 1TB of drive space (I was attempting to make a 500GB windows partition).  Nothing I did seemed to fix the problem.

     

    Finally, I made a disk image of my drive, then I formatted the entire drive and created a new "Macintosh HD" partition with the full 3TB.   I then reimaged using my recent copy and it fixed teh issue.

     

    Now I'm trying the bootcamp assistant once again.  It hasn't locked up yet and based on what I am reading here I need to let this thing go for at least an hour.  Worse case the same thing happens then I will just throw my image back on a formatted hard drive.

     

    Also of note, I tried creating the partition by hand using the Disk Utility.  I kept getting an error that Windows coudln't be installed due to it being a "GDT Partition".  Anyone know what that means?

  • Csound1 Level 8 Level 8 (44,275 points)

    Raymond Jones1 wrote:

     

    No I'm sorry "Repair Disc" does nothing.

    What were you booted from when you tried the repair? Recovery or the normal partition?

  • Raymond Jones1 Level 1 Level 1 (25 points)

    We tried repairing the disc from normal OS X, recovery mode and internet recovery mode. We tried erasing the disc multiple times, reinstalling OS X. Nothing recovers that greyed out "Free Space" partition.

     

    I brought it to the Apple store. They said they were going to replace the hard drive. They were able to repair it instead. I spent some time talking with the guy at the genius bar and he couldn't explain to me how they fixed it. He said they had to call in an expert to "unlock" that space on the drive. When I asked him what he did, he said that the guy "went through roughly 10 pages of code" to fix the problem, but he couldn't give me a specific or technical description of the problem or the solution.

     

    So, good news is my hard drive has one partition and it's a full 3 TB of space. Bad news is I can't share the solution for others with this problem.

  • Finnatic Level 1 Level 1 (10 points)

    Rellimie,

     

    Just wanted to follow-up to see how your Bootcamp install turned out. Did you find that you ended up with 3 partitions again, the exception being that this time, OS X reports the space as one logical partition even though there are 2 separate physical partitions separated by the Bootcamp partition?

     

    Really bugs me that I still have this weirdness. I'm contemplating buying Disk Warrior to see if that will fix this.

     

    Is there any good guide around to what to keep and what to delete when you do a full reformat of a Mac drive? All those small "invisible" partitions are a bit confusing in recovery mode.

     

    Thanks.

  • Finnatic Level 1 Level 1 (10 points)

    Hey Steve.

     

    In Disk Utility on the partitions tab, you are only showing a 1 OS X partition and 1 Bootcamp partition? I did something similar to you and wound up with 1 OS X partition, 1 Bootcamp partition and then a 2nd OS X partition. OS X reports the same total amount of space, so I didn't lose anything, it just looks weird.

     

    Thanks.

  • Steve Howells Level 1 Level 1 (0 points)

    This is exactly what I hvae post installation. Disk Utiility shows OS X Partition - Boot Camp - OS X Partition, but OS X acts as if there's only one OS X Partition.

  • Raymond Jones1 Level 1 Level 1 (25 points)

    All,

     

    This is what your disk utility will show with a 200MB partition for Bootcamp on a 3TB Fusion drive using Bootcamp assistant to create a partition.

     

    photo.JPG