Previous 1 2 Next 19 Replies Latest reply: Feb 6, 2016 2:31 AM by Thailand Amulets
SamsaDX Level 1 (0 points)

Some links don't work in Safari.  For example the top grey buttons on apple.com don't work unless I option click and select "open in new tab", in fact I had to do this for five links to get to this page, what is wrong?

  • SamsaDX Level 1 (0 points)

    Ok, have been researching the issue more, and have found that when I disable javascript the top grey buttons/links work, but then other links stop working.  I'm not sure if the issue is directly related to javascript or if this is just kind of a coincidence, but it really isn't valid anyway because if won't even work around my problem.  There seem to be a lot of posts on this topic, and they date back pretty far, but I cannot seem to find any solid fixes.

  • andyBall_uk Level 7 (20,490 points)

    any Safari extensions active ?

    tested in a Guest, or new user account ?

  • SamsaDX Level 1 (0 points)

    I already had disabled extensions with no luck.  Haven't been home to test a different user acct.  will check that out tonight.

  • SamsaDX Level 1 (0 points)

    sorry for takin so long to report back, been swamped, anyway, tried a new user acct and safari seems to work fine.  I even went back into my regular acct, and again Safari seems to work fine.  Its strange though, I dont think my problem is solved, I have had it work properly a few times since this problem came up.  Gonna spend a couple of days testing, then i'll post back.

  • SamsaDX Level 1 (0 points)

    Ok, so it's been a couple of days, and the problem still persists.  This didn't start until 8.2, so i'm just out out of ideas as to what could be causing an intermittent problem like this.

  • lcIII_User Level 1 (0 points)

    Ditto, same issues.  Upgrading to Safari 6.0.4 and OSX 10.8.3 does not fixt this issue.

     

    Lots of comments about this issue, none have found any solutions..... grrr.

     

    I should have a new CLEAN mac book pro comming intoday.  I am intrested to see if it has the same issues out of the box, and if it is just apple's web site top grey buttons.  Is there something wrong with the JavaScript that is served up from apple.com?  Cant imagen that the Apple OS, Apple Browser, and Apple Web Site are all incompatable with each other?

  • lcIII_User Level 1 (0 points)

    Of forgot to add, all the links on apple.com top bar are working in safari, just not with the default left click.  If I use the right click action and choose open in new window or tab, they all work, just not the default JavaScript left click.

     

    Also if I disable JavaScript in the Safari prefrences, then all the links work but the JavaScript layout for the Apple.com website is broken, all the links are layed out in list fasion.

     

    Links worky, Safari JavaScript no-worky!

  • andyBall_uk Level 7 (20,490 points)

    SamsaDX - somehow I missed your response, sorry.

    Did you resolve this - if not, does it still work in a new/guest account ?

     

    I'd suppose some ad-blocking/security/proxy software altering/blocking the page code due to the link-tracking javascript used, but that would likely mean  that other links than the top grey don't work on apple.com - the bottom text-links, for example. Do you or lcIII_User use anything like that ?

    any other example sites/links ?

  • lcIII_User Level 1 (0 points)

    So I just cracked the box and opened up a brand new Mac book pro shipped direct from apple.  Just arrived in my hot and greedy hands today via UPS.

     

    OSX 10.8.3 and Safari 6.0.3 (as it came from apple) and the apple web page issues with JavaScript are the same on this Mac as the other home Mac mini.

     

    One other bit of info.  After resetting Safari, quitting and then reopening, the first apple.com web page I land on, the top grey buttons work but only one time.  I can click on the button in the apple page for "mac" and it takes me to the mac page.  Then I cannot clik on any other grey top buttons from their.  Also the mac modle select option that appear just below this bar do not work with standard click, only secondary click on the touchpad.  I just noticed this same behavior on the

     

    On this MacBook Pro no ad-block or web filters yet installed.  I did have these on the Mac mini, bur removed all plugins, including ad-block and Flash.  Same problem on all user logins, even the admin account both Macs.

     

    Someone save me, tell me I am not crazy!!!

  • lcIII_User Level 1 (0 points)

    FOUND IT....  I think....

     

    I am using a NetGear router with the OpenDNS parental controls turned on.

     

    Turning off the parental controls immediately fixed the issues with the JavaScript not working on the top grey buttons of Apple.com website.  By turning off the parental controls, I am no longer using OpenDNS for my network DNS, but rather my ISP provided DNS.  The NetGear router forces all DNS queries to use the OpenDNS service, regardless of manually configured IP addressing.

     

    Interesting enough just turning it off for a second to click on the link and then turning it back on and the links continue to work.

     

    I am no Safari debug wizard, but when this was not working I was seeing a "fail to load" warning in the debug console and it was referencing some type of name for a tracking url.

     

    Could it be that Apple.com is using some type of JavaScript click tracker that calls to another web domain that is blocked by OpenDNS entrees???  Once I click I then identified and let the JavaScript tracking begin on the apple website?

     

    It cannot be solely cookie based either because this fix persist even after I clear my history and use the option to Reset Safari.

     

    Can anyone expand on my findings?

  • andyBall_uk Level 7 (20,490 points)

    >>Could it be that Apple.com is using some type of JavaScript click tracker that calls to another web domain that is blocked by OpenDNS entrees?

     

    Yes -"some ad-blocking/security/proxy software altering/blocking the page code due to the link-tracking javascript used" (they use a system from omniture (now adobe)

    or possibly opendns blocking it ?

     

    tested here & opendns doesn't cause that problem, but if you use one of their optional services, then certain content could be blocked. It's often recommended here though, so there would have been complaints already if it were common, perhaps.

  • lcIII_User Level 1 (0 points)

    The url that appears to be tripping up due to OpenDNS running on the router is:

     

    metrics.apple.com

     

    The Safari error console reported the following for metrics.apple.com:

    "Failed to load resource: the server responded with a status of 403 (Forbidden)"

     

     

    What is odd about this OpenDNS error with metrics.apple.com is that I do not have the same problem in any other browsers on Windows XP or Windows 7 machines using FireFox.  You would think that since this an issue with my router providing DNS redirection on the whole LAN, that this error would follow across multiple browsers and operating systems.  It appears to be only limited to computers running OSX and Safari.

  • andyBall_uk Level 7 (20,490 points)

    while the metrics.apple may well be blocked, that shouldn't itself trouble the page code & operation. The metrics one is usually a long url sending  info on browser, resolution, installed plug-ins,OS etc. On these discussions and the https version of apple they use securemetrics.apple.com...

     

    again, opendns doesn't block/affect those here - are you using a business or other paid-for/extended option with them ?

  • lcIII_User Level 1 (0 points)

    andyBall - Thank you so much for the dialog on this issue.  I think we have narrowed this down to my router and the openDNS parental control service.

     

    NetGear partners with openDNS.  You get a paid OpenDNS account, then the NetGear router downloads a custom generated blacklist/whitelist into the router.  You manage the list on the OpenDNS website, then your router pulls down the list and runs the known blacklist/whitelist locally, and then DNS queries go through OpenDNS.

     

    I whitelisted metrics.apple.com and apple.com and everything works in Safari.  Remove the whitelist, and it does not work again.  OpenDNS also has a bypass application that you can run on the local machine to register your Mac/IP address, and get direct access to the ISP’s DNS bypassing the Netgear routers’s OpenDNS.

     

    It’s funny that all the iOS device in the house work fine on apple.com, all the Firefox installs on PC work fine on apple.com.  I even tried changing my Safari user agent settings and still the website version I get from apple.com has these long obscure urls in the default click, but if you right click or turn off JavaScript everything is fine.

     

    I can only assume Apple is serving up some form of website JavaScript to help with website tracking for guest to their website that is specialized for safari.  It is most likely that this url link is soooo long it is breaking on my router when it is checking it’s black list, causing the router url check buffer to fail on the router???

Previous 1 2 Next