Previous 1 2 Next 20 Replies Latest reply: Jul 24, 2014 11:42 PM by Peter St.
Xavi Comes Level 1 (0 points)

Hi everybody!

 

After few days trying to solve this issue, I've finally solved it!

 

My problem was that after installing the Windows 7 64bits on a bootcamp partition, windows didn't boot, and only a black screen with a blinking cursos is shown on the iMac screen.

Finally I've found 3 commands that have solved the boot problem.

 

Turn on the iMac with the Windows 7 Installation Disc on SuperDrive or Windows 7 installation on the USB.

 

Press the Alt until the boot selector is shown.

 

Select the DVD/USB windows installation

 

Select your language and time bla bla bla.. click next.

 

After that, select Repair.

 

Then select the windows installation and click next,

 

After click on the last option from the menu to open a Prompt window.

 

Write and press enter after each sentence:

1- c:/Bootrec.exe /FixMbr

 

2- c:/Bootrec.exe /FixBoot

 

3- c:/Bootrec.exe /RebuildBcd

 

Each command return a successfull message.

 

Close, and reboot!!

 

GOOD LUCK!


iMac, OS X Mountain Lion (10.8.2)
  • The hatter Level 9 (60,930 points)

    Apple has had a tech note on this already, no?

     

    http://www.apple.com/support/bootcamp

     

    http://support.apple.com/kb/TS3173

  • Xavi Comes Level 1 (0 points)

    Yes, but it is not the good solution for me. It didn't work in my case.

     

    The only thing that worked Is the one that I posted.

     

    It was freaking me out and I was very happy on the solution, so I've posted it!

     

    Thanks for your answer, and sorry for my bad english!

  • Xavi Comes Level 1 (0 points)

    Finally I've discovered that the only way to boot windows normally, without any problems is with the original DVD installation disk inside the SuperDrive, only need to be inside. Doesn't need to be running, or enter the recovery menu or whatelse... Then, the windows bootcamp partition loads perfect!!

     

    Well, thanks for help!

     

    Have fun!

  • Midship Level 1 (5 points)

    Hola Xavi,

    I am running into the same issue, the Apple support call center has been unable to help.

    I have tried to follow your suggestion, however at no time can I find the "Repair" option when booting on the USB.

    After the language and time and blabla as you put it, there are options to install and that's it...

    I would be very grateful if you could give me an additional helping hand.

    Many thanks in advance!

  • Xavi Comes Level 1 (0 points)

    Hi! What's up?

     

    First of all, I have to ask you if you are running an original Windows 7 SP1 installation iso?

     

    I've read in some threads that with new bootcamp versions you must use an original installation disk/iso.

     

    After that, when you boot from your USB drive, first screen after the black "Windows is loading files..." screen, is the one that asks you to choose your installation language, hour and currency setting and keyboard layout. Then hit Next.

                        IMG_0004.jpg

    The next screen shows a big center button with the Install text, BUT in the left bottom corner you will see the Repair action text. Press there with the mouse, or move with the keyboard cursor keys.

                       IMG_0005.jpg

    The screen below ask you to choose the windows installation partition (C:bootcamp).

                       IMG_0006.jpg

    And the final screen let you choose too many options. The last one is the correct one. Command Prompt.

     

    There you have to follow the command lines that i said on my prevoius thread.

     

    I wish this help!

     

    Please, ask if you need something else!

  • Midship Level 1 (5 points)

    Hola Xavi,

     

    Very nice of you to have answered so fast and done this painstaking work of taking print screens, very much appreciated!

     

    I have an original OEM Windows 7 install disk. I generated the ISO file from it to create the USB boot key. However, the strange thing is that I do not get your second screen at all, at any time in the process.

     

    I have no idea what to do next, now... Would you have a suggestion?

     

    Saludos cordiales,

     

    François

  • Xavi Comes Level 1 (0 points)

    Hola!

     

    Well, I have installed too many windows 7 in diferent machines, PC's, Mac's.. And the second screen always have appeared.. It is strange that you don't have this step... I can't imagine the reason...

     

    Try to only hit one the buttons, I mean, be patient. Probably you hit twice the mouse or the keyboard¿?

     

    I'm sorry but this situation is uncontrolled for me!!

     

    Well, tell me anything!

     

    Sorry for my bad english.

     

    Saludos

  • Midship Level 1 (5 points)

    Maybe because it's an OEM disk?

  • Xavi Comes Level 1 (0 points)

    Possible.

     

    Could you try another installation disk? Only to know if this is your issue...

     

    I don't know other ways to solve it, sorry.

     

    See you!

  • Midship Level 1 (5 points)

    Muchas gracias Xavi.

  • Xavi Comes Level 1 (0 points)

    De nada!

     

    You are wellcome!!

  • Midship Level 1 (5 points)

    Another quick question for you: which Windows 7 version have you installed? For my part it's the Home Premium.

  • Xavi Comes Level 1 (0 points)

    Ahhhh!!! I think you have solved yourself!!! Hahaha! I've read on bootcamp documentation that the windows 7 has to be Professional or Ultimate edition only!

     

    Try with an original microsoft copy from their servers, only for a test and if that works then think on a purchase.

     

    This is my opìnion

     

    Good luck!

  • Midship Level 1 (5 points)

    Super Xavi, many thanks for your kind support!

     

    I will try that.

     

    Wish you well in your current endeavours.

Previous 1 2 Next