Previous 1 2 Next 17 Replies Latest reply: Sep 25, 2015 11:28 AM by jdesign77
ClaraSophieP Level 1 Level 1 (0 points)



so for a few months I can't move / remove / add dock icons anymore.

I've tried everything.

I've moved and on my desktop, logged in and out and then my dock was completely new but I STILL can't move anything.

Do you have ANY idea what else could be wrong with my dock?

Thanks for trying to help me!

Mac Pro, MAC OS X 10.6.8
  • ClaraSophieP Level 1 Level 1 (0 points)

    Tried this, too. Nothing changed. :/

    But thanks!

  • Eric Ross Level 6 Level 6 (11,660 points)

    Did you try repairing your permissions and hard drive with disk utility?

  • Eric Root Level 8 Level 8 (41,345 points)

    For removing, have you tried control - clicking the icon, selecting Options, and then unchecking Keep in Dock.


    Are any of the applications in your login items in System Preferences/Users & Groups?

  • ClaraSophieP Level 1 Level 1 (0 points)

    I'm not really good with all that stuff, I don't know what you mean by this, sorry. Do you think I should ask a mac expert/specialist to help me?

  • Eric Ross Level 6 Level 6 (11,660 points)

    It's not difficult to check your  hard drive and repair permissions, Take a look at this link,  to Repair Permissions,

  • ClaraSophieP Level 1 Level 1 (0 points)

    @eric root: yes I did that, that's the only thing that worked so i finally could remove some icons but they still wont move.


    Thank you for trying to help me but I'm not english so I got a few problems understanding this text about repairing the permissions. I'll give that text another try later!

  • Eric Root Level 8 Level 8 (41,345 points)

    Go to Applications/Utilities/Disk Utility and open the program:

    Screen Shot 2013-04-16 at 4.37.00 PM.png


    When the program opens, it will look like this. Select your hard drive at the left. I have two drives because I have two partitions.


    Screen Shot 2013-04-16 at 4.38.47 PM.png

    With the hard drive selected, the program will look like this. Check the top tab to make sure it reads First Aid. Click the button shown by the bottom arrow to repair permissions. You may need to run Repair more than once to get everything fixed.


    Screen Shot 2013-04-16 at 4.40.34 PM.png


    After Repairing Permissions, Verify the disk by using the button on the right.


    Screen Shot 2013-04-16 at 4.54.36 PM.png

  • Linc Davis Level 10 Level 10 (177,590 points)

    Please read this whole message before doing anything.


    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.


    Step 1


    The purpose of this step is to determine whether the problem is localized to your user account.


    Enable guest logins* and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up guest users” (without the quotes) in the search box. Don't use the Safari-only “Guest User” login created by “Find My Mac.”


    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.


    Test while logged in as Guest. Same problem?


    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.


    *Note: If you’ve activated “Find My Mac” or FileVault, then you can’t enable the Guest account. The “Guest User” login created by “Find My Mac” is not the same. Create a new account in which to test, and delete it, including its home folder, after testing.


    Step 2


    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login, or by a peripheral device.


    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode* and log in to the account with the problem. The instructions provided by Apple are as follows:


    • Shut down your computer, wait 30 seconds, and then hold down the shift key while pressing the power button.
    • When you see the gray Apple logo, release the shift key.
    • If you are prompted to log in, type your password, and then hold down the shift key again as you click Log in.


    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on certain Macs.  The next normal boot may also be somewhat slow.


    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.


    *Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t boot in safe mode.


    Test while in safe mode. Same problem?


    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of steps 1 and 2.

  • Abkhazian Level 1 Level 1 (0 points)

    Hi ClaraSophieP
    Since I have spent all this time and somehow solved this problem I think it is best I share it with you and everyone else. First I want to inform everyone I am sort of illiterate about computers. However, I am pretty good about resolving my problems through extensive googling. Bear with me since this is my first-ever post.

    I noticed the same problem you are having about an hour ago. I tried to move Photoshop application on the dock and realized I was unable to do it. I followed a few different steps. I am not sure which one caused it to be fixed so I am going to lay them all out. Excuse my overdetailing but I hate it when people assume you know everything and jump and skip steps so I will be assuming you are 90 and explain it accordingly.


    1st Step
    Go to the finder(little magnifier on the top right corner of your screen) and type Terminal. When you see the Terminal option highlighted underneath, click on it or hit enter. A strange little window will show up. Copy and paste the following


    killall Dock


    And hit enter. This is somehow supposed to erase your dock settings I suppose. You have to restart your computer after that and then try to move an application item to the dock. See if it works. If it doesn't, which it didn't for me, move to the second step.


    2nd Step

    Go to the finder(again the little magnifier on the top right corner of your screen) and type Terminal. When you see the Terminal option highlighted underneath, click on it or hit enter. A strange little window will show up. Copy and paste the following


    defaults write contents-immutable -bool no


    And hit enter. This is somehow supposed to take your dock settings back to defaults. Again you have to restart your computer after that and then try to move an application item to the dock. See if it works. If it doesn't, which this also didn't for me, move to the third step.

    3rd Step

    Open your applications grab and drag the application to the dock, drop it specifically between the documents and the trash(or right next to the last icon-in my case it was the trash- in your dock). You may realize that it allows you to do that. Initially you cannot put it anywhere else but "right next to the trash" for some reason.

    Proceed by moving the app from there to anywhere you like on the dock.


    So my story is that once I did that suddenly it allowed me to move it from there to any other place in the dock since that seems to have suddenly unlocked all the dock. I don't know how but this or the combination of this and all the above broke this strange spell. Now I can move, relocate or remove any application I want.


    This process might certainly not help you. I hope it does, though. If not you at least I hope someone out there saves some time by following these steps.


    Good luck.

  • CassidyDJ Level 1 Level 1 (0 points)

    I just talked to Apple Support.  The reason the applications can't be undocked is because they are not "closed".  When you close an application using the red - button it doesn't fully close it; you have to click on the application's name in the upper left hand corner and "quit" the program for it fully be considered close.  After that you can remove the application from the Dock

  • LittleSho Level 1 Level 1 (0 points)

    Thanks so much CassidyDJ!  I tried everything and nothing was working, but I did as you suggest and closed them properly...after that: poof! and they were gone!  Thanks!

  • indiafromgb Level 1 Level 1 (0 points)

    I have the same problem in safe mod. However when in guest user mode I don't, can't figure it out, so confused

  • Afroturk Level 1 Level 1 (0 points)

    I see that the OP didn't reply with any information on what your test revealed. I have the same problem, and have been searching the community looking for a solution. I realise it's over a year ago now, but hope you can help me if I pick up the thread....


    First off, I am running a MBA with Yosemite (10.9.5). But I am also having the same problem on an iMac running the same OS. To be clear - I can add items to the dock, or remove them using the contextual (right-click) menu. What I cannot do is drag items off the dock (to disappear in a puff of dust) or drag items from one place in the dock to another. I assume this is a bug, rather than a design choice with Yosemite.


    Here is a list of everything I have tried so far, with no success:

    • I have repaired all permissions using disk utility.
    • I have tried the bit of terminal code that is supposed to unlock the dock:  defaults write contents-immutable -bool false;killall Dock
    • I have deleted and from the Preferences folder in my Library
    • I have logged on as a guest user - same issue
    • I have started up in safeboot mode and logged on as myself - same issue.


    I'm not sure what else I should try.


    One note: since deleting the two files from my Preferences, I see that the .plist file has reappeared, but the .lockfile has not. Is that significant? Also, there is a "byhost" folder in my Preferences which also appears to contain dock-related files (although these have a long "serial number" included in the file title). Should I be deleting these too?

Previous 1 2 Next