Previous 1 2 Next 20 Replies Latest reply: Apr 21, 2013 4:18 PM by etresoft
Daz1761 Level 1 (0 points)

I'm having problems with a tutorial I am watching on the UINavigationController and TableView. 


The link is here:


Everybody seems to be saying, great, thanks, worked perfectly, etc.  But everytime I try to implement about the first 10 mins of the video I get an unrecognised selector sent to instance 0x71788a0 to the UIViewController tableView: numberOfRowsInSection, which there clearly isn't a problem with as I've tried a new projects following the same proceedures.


I've tried relinking the table to files owner, all the usual troubleshootng tecniques and the same error is outputted.  The only thing differerent to all my other practice/tutorial projects is the way the ViewController and UINavigationController get loaded into the UIWindow:



#import "AppDelegate.h"

#import "ViewController.h"



@implementation AppDelegate


- (BOOL)application:(UIApplication *)application didFinishLaunchingWithOptions:(NSDictionary *)launchOptions


    self.window = [[UIWindow alloc] initWithFrame:[[UIScreen mainScreen] bounds]];

    // Override point for customization after application launch.

    UIViewController *viewController = [[UIViewController alloc] initWithNibName:@"ViewController" bundle:nil];

    UINavigationController *navController = [[UINavigationController alloc]initWithRootViewController:viewController];

    self.window.backgroundColor = [UIColor whiteColor];

    self.window.rootViewController = navController;

    [self.window makeKeyAndVisible];

    return YES;


Previous 1 2 Next