Previous 1 2 3 Next 36 Replies Latest reply: Jan 12, 2016 2:55 AM by ValyaMalishka Go to original post Branched to a new discussion.
  • Robert Griffiths Level 1 (0 points)

    Steps 1 - 4 worked perfectly. Thanks!

  • nirmals44 Level 1 (0 points)

    Hi Ojjo8,

     

    Let me know if your problem is resolved. If not let me know your errors, i will try to help you.  Besides if my steps helped you, let me know.

     

    Regards

    Nirmal

  • Thueholm Level 1 (0 points)

    When Is Apple going to fix this I am so sick and tried of all the time to delete my preferred networks. Does any body know if there is fix commin soon.

  • Harvey Wallbanger Level 1 (0 points)

    After trying all the recommended restarts on the MBA and router, I simply deleted all my preferred networks, restarted the MBA, and I could connect just like always.

     

    I recall having to do this once on awhile on Windows as well.

  • nirmals44 Level 1 (0 points)

    Harvey,

     

    Refer to my troubleshooting steps that i posted earlier on the same discussion topic. Try to go over the steps and let me know if your issue resolved.

     

    Regards

    Nirmal

  • Harvey Wallbanger Level 1 (0 points)

    Hi there, if you re-read what I just wrote, I'm saying that this worked for me.

  • renatagames Level 1 (0 points)

    I'm having the same problem. Nirmals44's (thanks!) steps 1-4 worked just fine, but everytime my computer goes to sleep it starts all over again. I'm getting pretty tired of having to trash preferences everytime. If anyone is experiencing the same, please let me know. Pretty ****** at this, to be honest...

  • LisKit Level 1 (0 points)

    This is not just a MacBook Air problem. This is my third MacBook since 2011, a retina, none were Airs, every one of my MacBooks had annoying issues with wifi, particularly not reconnecting after a drop, and all of them sometimes had this issue. I could see all the neighbors and other devices could connect to my wifi but my mac refused to acknowledge its existence.

    Yesterday, I switched my ADSL modem to a 4G modem and this new Retina MacBook was not happy about it. In near proximity were 3 other computers, 2 tablets, 2 phones and a few other odd devices and all were able to connect easily. Included there was a 2011 MacBook and an iPad. This new MacBook finally connected after swinging it Tarzan-style from the ceiling in front of the modem while the cats hypnotized the MacBook with their snake-charming abilities. It worked just fine for 24hrs, then a new tablet walked into the house and the MacBook gave the modem the cold shoulder again. Tarzan was of no use, this time. The iPad, on the other hand, hasn't had any trouble with this at all.

    I don't really think it was the new device that caused this, since I've had this problem on and off on all MacBooks, but deleting the other preferred networks according to nirmals44 suggestion instantly fixed the connection. I wish it was the iPad that was the problem, I'd throw it out the window, because as others have said, that will be annoying to have to repeat. I will install another operating system on my MacBook, if I have to do this again, Apple, please fix this, iWiFi is ridiculously buggy.

  • LisKit Level 1 (0 points)

    Update: it worked perfectly for 10 minutes. Now the MacBook shows it is still connected to the wifi, but it's not getting any data. All other devices are still working as normally.

  • Precious61 Level 1 (0 points)

    Hi thanks for the help but 1-4 didn't work I don't understand the next steps 5 do you mean log on from another device?

  • markalava Level 1 (0 points)

    Worked for me! Thx :-)

  • brunolaturner Level 1 (0 points)

    Since this thread is the first google result for this kind of problem, I will kind of resurrect it and post the solution for my problem, but first of all, a small explanation:

     

    Wi-Fi networks currently at many frequencies, or bands, 2.4 GHz, 5 GHz, and some very special versions in others. I will talk about the most common one: 2.4 GHz.

     

    2.4 GHz networks work with very specific ranges, what we call "channels", they go from channel 1 (2.412 GHz) to channel 14 (2.484 GHz).

     

    Now the important information: USA networks only go from channel 1 to channel 11. Your Mac will only search these ranges. Your Wi-Fi router/access point could be a foreign one, and is staying at channels 12, 13 or 14, outside of your search range.

     

    What you need to do is to enter your router/AP configuration page, and change it to a channel between 1 and 11. Ask a more tech minded person to do it for you. Just by doing it, saving the configuration, restarting the equipment, you should see the network in a minute or two.

     

    By the way, while you or that person is changing the configuration, ask him/her to change the Wi-Fi password, if you never did it before. You will also need to update the password in all your other PCs, videogames, etc that use that network.

     

     

    PS: As an extra, the best channels to use are 1, 6 or 11, due to interference other channels may have with them (please read http://en.wikipedia.org/wiki/List_of_WLAN_channels). You may find the best one by pressing the Alt/Option key in your keyboard, and at the same time click the Wi-Fi symbol. There you should find an item "Open Wireless Diagnostics...". Clicking it, a new window will show up. Do not press Continue. Go to the Window menu and select Scan (hotkey Command-4).


    Please do not use channels other than 1, 6 and 11 (at 2.4 GHz that is), even if the wireless diagnostics tool tells you otherwise. It's a good network neighborhood conduct rule to live by. Hopefully others around you will do the same.

  • Jaishankar M. Talreja Level 1 (0 points)

    The only practicable solution I have come across (MacBook Pro Can't find home wireless network)  is changing modem channel settings from auto to a specific number <11). I have been ignoring it for too long as when I restart my Mac, at times the problem solves or I end up using my iPhone portable hotspot in the interim. Today I decided to do what it takes, searched & came across your solution.

     

    Of course, in my case, I had to call the helpline (1504 / 12540) of my ISP (MTNL Mumbai) who guided me step by step on changing the channel i.e. connect the LAN chord to a PC (which was detecting the connection), log in to 192.168.1.1 & then change the channel from auto to a specific number <11 (I selected Channel 1) under the Interface Setup > Wireless.

  • John Scott1 Level 2 (310 points)

    Yea long history of WiFi issues myself. Have 2013 Macbook Air, did extensive testing for Apple care on this issue and at one point they even wanted my router to test. Then a update to Yosemite came out that fixed it, but it seems the last update has brought the problems back? My fix is that I have to turn WiFi off then on again and my connection works again. When its not working the option WiFi stats indicate the Internet is unreachable even though it shows a local connection to router? Exactly what was happening before and yet here we are again. I definitely think this is a router vs Macbook issue which for some reason some routers don't like the connection or the Macbook does not like the router? My fix won't be buying a Airport Extreme just to solve this issue. I really expect my Macbook Air to work with any properly configured router. Believe me I went through all kinds of potential fixes and nothing worked 100%. Except to simply turn WiFi off and back on. Occasionally I have to delete connection and reconnect, but not very often. I have multiple devices that never have connection issues with my router. Only the Macbook Air and so I really think this is a Apple issues but to define if its a Yosemite problem, a hardware issues or other is beyond my expertise.

  • tim0409 Level 1 (0 points)

    I've been having lots of issues with my Macbook since Yosemite was introduced, specifically it not recognising my home network when I wake from sleep. I have to reboot which is annoying, and even then I have intermittent issues. Apple don't seem interested in the issue which is disappointing given it really is ruining my experience. I could buy an airport but don't see why I should.