Previous 1 2 Next 28 Replies Latest reply: Nov 19, 2013 10:31 AM by Karen Lewis
Karen Lewis Level 1 Level 1 (5 points)

Recently installed 10.6.8 Snow Leopard in my 2006 mac pro tower: 2x2.66 GHz Dual-Core Intel Xeon

 

iTunes will not launch at all. I get an error message: 'iTunes quit unexpectedly' - and an error report.

 

Have tried uninstalling and reinstalling the latest version of iTunes, but that hasn't worked.


Mac Pro, Mac OS X (10.6.8)
  • léonie Level 9 Level 9 (75,290 points)

    and an error report

    What does the error log say? Please post the first 50 lines.

  • Karen Lewis Level 1 Level 1 (5 points)
    Process:     iTunes [915]
    Path:        /Applications/iTunes.app/Contents/MacOS/iTunes
    Identifier:  com.apple.iTunes
    Version:     11.0.3 (11.0.3)
    Build Info:  iTunes-1103042001000000~1
    Code Type:   X86 (Native)

    Parent Process:  launchd [113]

     

    Date/Time:   2013-05-27 07:48:01.260 -0700
    OS Version:  Mac OS X 10.6.8 (10K549)

    Report Version:  6

     

    Interval Since Last Report:      132875 sec
    Crashes Since Last Report:       17

    Per-App Interval Since Last Report:  11 sec

    Per-App Crashes Since Last Report:   8

    Anonymous UUID:                  F473E531-0380-4FD5-861C-A418D9F820C1

     

    Exception Type:  EXC_CRASH (SIGABRT)

    Exception Codes: 0x0000000000000000, 0x0000000000000000

    Crashed Thread:  0  Dispatch queue: com.apple.main-thread

     

    Application Specific Information:

    abort() called

     

    Thread 0 Crashed:  Dispatch queue: com.apple.main-thread

    0   libSystem.B.dylib         0x9321dc5a __kill + 10
    1   libSystem.B.dylib         0x9321dc4c kill$UNIX2003 + 32
    2   libSystem.B.dylib         0x932b05a5 raise + 26
    3   libSystem.B.dylib         0x932c66e4 abort + 93
    4   libSystem.B.dylib         0x931c3575 free + 129
    5   ...ple.CoreServices.CarbonCore0x91ea801d DisposePtr + 37
    6   com.apple.DesktopVideoOut 0x027f96cc DVOClockClose + 121
    7   ...ple.CoreServices.CarbonCore0x91ef2dcc CallComponentFunctionCommonWithStorage(char**, ComponentParameters*, long (*)(), unsigned long) + 54
    8   com.apple.DesktopVideoOut 0x027f9206 DVOClockComponentDispatch + 98
    9   ...ple.CoreServices.CarbonCore0x91eeb51f CallComponentDispatch + 29
    10  ...ple.CoreServices.CarbonCore0x91eeb8a8 CallComponentClose + 43
    11  ...ple.CoreServices.CarbonCore0x91eeb7d1 CloseComponentInternal(ComponentInstanceRecord*) + 101
    12  ...ple.CoreServices.CarbonCore0x91eeb752 CloseComponent + 46
    13  ...ple.CoreServices.CarbonCore0x91ee9814 OpenAComponent + 493
    14  ...ple.CoreServices.CarbonCore0x91eef149 OpenComponent + 24
    15  ...ple.CoreServices.CarbonCore0x91eeb5cc CallComponent + 171
    16  ...ple.CoreServices.CarbonCore0x91eeb51f CallComponentDispatch + 29
    17  ...ple.CoreServices.CarbonCore0x91f79e15 CallComponentVersion + 37
    18  ...ple.CoreServices.CarbonCore0x91f1a440 getComponentVersion(RegisteredComponent*) + 213
    19  ...ple.CoreServices.CarbonCore0x91ee3ede DestroyOlder(RegisteredComponent*, long) + 126
    20  ...ple.CoreServices.CarbonCore0x91ee39bc RegisterComponentResourcePtr + 709
    21  ...ple.CoreServices.CarbonCore0x91ee2fa1 registerSystemComponents + 244
    22  ...ple.CoreServices.CarbonCore0x91ee2dd1 FindNextComponentInternal(ComponentRecord*, ComponentDescription*, unsigned long) + 86
    23  ...ple.CoreServices.CarbonCore0x91ee2d64 FindNextComponent + 61
    24  com.apple.QuickTime       0x9a41ff8d EnterMovies_priv + 411
    25  com.apple.QuickTime       0x9a41faca EnterMovies + 16
    26  com.apple.iTunes          0x00ac7e82 0x1000 + 11300482
    27  com.apple.iTunes          0x0017f5b5 0x1000 + 1566133
    28  com.apple.iTunes          0x0017f511 0x1000 + 1565969
    29  com.apple.iTunes          0x0017f4b2 0x1000 + 1565874
    30  com.apple.Foundation      0x9144adb3 _nsnote_callback + 176
    31  com.apple.CoreFoundation  0x95242763 __CFXNotificationPost + 947
    32  com.apple.CoreFoundation  0x9524216a _CFXNotificationPostNotification + 186
    33  com.apple.Foundation      0x9143fc50 -[NSNotificationCenter postNotificationName:object:userInfo:] + 128
    34  com.apple.Foundation      0x9144d05d -[NSNotificationCenter postNotificationName:object:] + 56
    35  com.apple.AppKit          0x928b7511 -[NSApplication finishLaunching] + 493
    36  com.apple.AppKit          0x928b6f0d -[NSApplication run] + 79
    37  com.apple.iTunes          0x0017d0bf 0x1000 + 1556671
    38  com.apple.iTunes          0x0017cf39 0x1000 + 1556281
  • léonie Level 9 Level 9 (75,290 points)

    Sorry, Karen,

    the crash report did not tell me much.

    It is crashing in the system core services, when trying to register components, in the QuickTime component. This suggests, that there may be a corruption or bug in your system, or you have incompatible audio or video components installed. Are you using third party audio or video software, maybe from a video camera?

     

    I'd check, if you can launch iTunes when working from a different user account.

    Does iTunes launch properly, when you sign in as a different user?

    See: Isolating an issue by using another user account

     

    Léonie

  • Karen Lewis Level 1 Level 1 (5 points)

    iTunes will boot from an alternate admin account.

     

    Tried to boot from Safe mode, but have only a wireless keyboard, and I don't seem to be able to do it. Have tried holding shift key 'after the restart chime' several times to no avail. Bother.

  • léonie Level 9 Level 9 (75,290 points)

    iTunes will boot from an alternate admin account.

    But that is a good sign. Something in your regular account must be problematic.

     

    Either your iTunes Library, or your preferences, or start-upitems.

     

    I'd start with repairing the permissions on your iTunes library. Where is it located? On an internal or external drive? You can try to check and repair the permissions with Disk Utiliy.

     

    Too bad, you cannot boot into Safe mode. To check for incompatible start-up items open your System preferences and look at the User account settings. Disable all non-apple start-up items you are seeing there, also have a look at preference panels in the "Other" group at the bottom of the panel.

     

    If none of the above does help, I'd sacrifice the iTunes preferences. Move the file

    ~/Library/Preferences/com.apple.iTunes.plist

    from the Preferences folder in your User Library to the Desktop, but do not trash it.

     

    After that, you will have to enter all iTunes Preferences settings again.

     

    Can you now launch iTunes?

  • Karen Lewis Level 1 Level 1 (5 points)

    Thanks for your help, Leonie

     

    "Disable all non-apple start-up items you are seeing there, also have a look at preference panels in the "Other" group at the bottom of the panel."

     

    Have disabled start-up items - don't see an "Other" group at the bottom of my account settings panel. What are the prefence panels you are referring to? Are they accessed in another way?Screen shot 2013-05-27 at 12.07.47 PM.png

  • Karen Lewis Level 1 Level 1 (5 points)

    Permissions have been repaired on the hard drive (all on one hard drive).

     

    Moving ~/Library/Preferences/com.apple.iTunes.plist did not help.

  • léonie Level 9 Level 9 (75,290 points)

    I meant the "other" setting in the System Preferences panel of your user account.

     

    I don't remember how that part was called in MacOS 10.6.8. In my Preferences panel MacOS 10.8.3 it looks like this:

    Screen Shot 2013-05-27 at 21.19.53MESZ.PNG

    At the bottom of the panel are the preferences for third party helpers, like haxies, video codecs, Firewalls, etc.

    If they are easy to disable, turn them off.

  • Karen Lewis Level 1 Level 1 (5 points)

    Thanks! Found the panel. Made sure non-apple 'others' are turned off.

     

    Was able to boot in 'safe' mode using terminal:

     

    IN SAFE MODE: iTunes won't launch in safe mode in my primary (admin) account, but it launches fine in an alternative admin account.

  • léonie Level 9 Level 9 (75,290 points)

    karen,

    it must be something in your account that is crashing iTunes, since it works in other accounts.

     

    It is not your preferences, and repairing permissions in your iTunes Library did not work.

     

    Have you tried to launch itunes on a new, empty library?

     

    • Hold down the ⌥(option)-key while you launch iTunes.
    • Click Create Library and import a few songs.

    Does that work?

     

    If yes, then restore an earlier version of your iTunes library from your backup or recreate your library:

     

    See: How to re-create your iTunes library: http://support.apple.com/kb/HT1451

  • Karen Lewis Level 1 Level 1 (5 points)

    Holding down the option key didn't work.

     

    :-P

     

    Any other hints on where to troubleshoot the account?

  • léonie Level 9 Level 9 (75,290 points)

    Holding down the option key didn't work.

    In what way? Does it also crash immediately?

  • Karen Lewis Level 1 Level 1 (5 points)

    Yes - same result. Immediate crash with an error message.

  • léonie Level 9 Level 9 (75,290 points)

    If you cannot even get iTunes to create a new iTunes Library, try to recreate your iTunes library and clear iTunes caches.

     

    But make sure, your backup of your library and system is current.

     

    To recreate your iTunes Library see: http://support.apple.com/kb/HT1451

     

    And for iTunes Caches, look in your user library:

     

    ~/Library/Caches/com.apple.iTunes/

Previous 1 2 Next