Previous 1 2 3 4 5 Next 66 Replies Latest reply: Jan 11, 2016 4:15 AM by ThePoopMaster Go to original post
  • Lemon Sand Level 1 (0 points)

    I tried the solution suggested, but the drivers downloaded from Apple seem to be outdated and would not be inserted in the installation process. I was able to download drivers from Intel. Those did work as far as getting them into the installation. But when I got through the install, I still had no mouse or keyboard response. Any thoughts?

  • GIjbop Level 1 (0 points)

    Painfully frustrating problem at first.


    After spending the good part of a whole day try and reading this post , I finally got it to work!!!


    I just bought a MacBook Air mid 2013 version this week.

    I also bought the Mac SuperDrive this week.

    I have an old 1gb USB key.

    I have an old genuine copy of Windows 7 64 bit professional CD disk (i did not use a Windows 7 USB key)


    This is how i finally did it.


    Step 1. Updated Mac software - straight forward


    Step 2. I connected the USB superdrive to the RIGHT USB port (right side when facing the MAcbook Air)


    Step 3. I connect my USB 1GB stick into the LEFT USB port


    - here is where my problem was i was not doing this precisely.


    - u need to ERASE and FORMAT the USB KEY exactly by going through DISK UTILITY folder. Then you have to select the USB drive at the TOP-LEVEL listing. Then click ERASE, and select the MS-DOS (FAT) format.


    (i think my problem was that i had done everything i will have listed here now but i was erasing the USB key by just dragging old contents into the garbage bin...not good enough!!!)


    (explained in detail by Apple here....see link here step 9


    Step 4. Leaving the USB key still in the LEFT USB port, I then used Bootcamp Assistant. After running Bootcamp set up, I then checked the option to Download Latest Windows Support Software from Apple. This downloaded automatically into the USB 2.0 key.


    - leave the USB key in the left USB port


    Step 5. Use Bootcamp Assistant to now choose the "Install Windows 7", and click continue.

    - rest is straightfoward as per Bootcamp Manual. USB left in place until all installed.



    (I did not need to select and LOAD DRIVER at the Partition described above. I did try that earlier but it didnt work for me after several attempts in differing orders)


    Hope that helps..i wish did it exactly like this from the begining. Overall took me around 60 minutes once i did it like this with my Window 7 prof 64 bit.

  • FiftyKnight Level 1 (0 points)

    Thank you!


    This worked for me on my MacBook Air 2013.


    Just one thing (and I guess this should be obvious) but don't store the drivers on a USB 3 stick.  I moved them to a USB 2 stick using a different computer and then I could access them on the MacBook Air!

  • c00kiemon5ter Level 1 (0 points)

    Lifesaver. I downloaded the USB drivers (intel) and stuck them on the usb stick after doing the following:

    (mine is a Macbook air 13 2013 model)


    1. Plug USB stick in left USB port

    2. USB external dvd drive in right usb port with Windows 7 in it

    3. Used boot camp to download latest drivers to USB stick

    4. Used boot camp to install Windows 7

    5. During install clicked on load drivers as per JerryLundegaard post above (after downloading them)

    6. Installed windows after formatting the partition

    7. Keyboard and mouse working fine


    So thank you all for the help !


    oh and some help from this thread:

  • arturoimaz Level 1 (0 points)

    This discussion worked for me.

  • paolofromflumicino Level 1 (0 points)

    Can you please link the article you were talking about?



  • Wes Sonnenreich Level 1 (0 points)

    For those with a 2013 MBA having trouble with keyboard and mouse at the first Windows Install screen, this might help:


    I had this problem using an image created from my Win 7 Ultimate install CD - which was the ORIGINAL CD, not the Service Pack 1 updated CD. If you have install media that predates service pack 1, you might find that even the Apple drivers that BootCamp assistant downloads don't work...


    The solution is to download the official ISO from DigitalRiver (I used a version from this page: and then use BootCamp assistant with that iso - tick all boxes.


    One more thing: you'll have wireless problems first time you boot into windows. Shut down your computer (power off). Then hit alt/option and select Windows to boot from. Apparently this is essential at the moment to get wireless to activate properly (you'll need to get into windows from power off every time you want wireless, apparently).


    This worked for me... now bootcamp seems to be happy and windows 7 is installed with mouse/keyboard performance and wireless.

  • ftballpack Level 1 (0 points)

    Wes you are absoultely corrent about needing to use the Windows 7 disc installer with SP1!


    I tried over and over again to install Windows 7 on my wife's new MacBook Air using the original Windows 7 disc (Original Windows 7 x64 RTM) that was released on MSDN right before the general release of Windows 7 to the public. (I attempted to use the installer without SP1 as that is what I had on hand, from doing prior Windows 7 installations in the past, so it never occured to me to wasted 2 hours over dsl to get the new iso)  I tried over and over again using both the disc install method using an external dvd/cd burned I have and I tried copying the iso to the desktop and using a 8gb usb 2.0 drive install using the bootcamp method with absolutely no luck.  It would freeze for me at 54% of extracting files every time.


    Once I downloaded the Windows 7 SP1 Pro iso from digital river, using the link that you posted, the install worked like a dream using the 8gb usb 2.0 flash drive install.  The key that I had was able to be installed and activated without issue using the digital river iso after the install was completed.


    This has to be one of the most frustrating Windows 7 installations that I have ever done.  Apple needs to add to their documentation that a Windows 7 x64 SP1 install disc or iso must be used inorder to complete the installation.


    Using the Windows 7 x64 SP1 iso with the bootcamp usb 2.0 flash drive method could not have been easier, but getting to that point, man, that was frustrating........

  • TheGreatDane49 Level 1 (0 points)

    Hi all...FINALY got the easy solution...

    step one: go in win 8 to device manager.


    Delete bluetooth 3.0


    install as admin the boot camp driver "bluetooth"


    When is says that its a bad idea, just pres yes.


    i promise you ... it works.

  • Arthurart85 Level 1 (0 points)




    I come across a bit late on this thread to expose my opinion.



    I think the pb is simply a kind of incompatibility between last bootcamp drivers and mba 2013.



    Because i tried to install both windows 7 x64 ultimate and windows 8 pro x64 entreprise with bootcamp drivers and they both have no responses from keyboard and mouse after approximately 5 min logged into the first session and directly at boot for the next ones.



    Actually for my win 7 attempt i created and installed it with dongle plugged into right port but i don't think it can be the cause since i did the opposite for win 8 and have the same problems.



    Then i tried a simple install of win 8 without bootcamp drivers and from now it seems that i have no pb.



    So it will be highly probable that if i tried a win 7 install with no bootcamp drivers it will succeed too.



    Nevertheless i advise for all people concerning about this topic to install windows 8 because it fully implements EFI boot mode whereas it seems to be more complicated on 7.

  • BarnCleave Level 1 (0 points)

    OK the below link lets you install Win 8 on the hard disk



    However you then get blocked at actually installing Win 8 as it doesn't support USB 3.0 keyboard & mouse



    So I'm going to call it a night and hope Apple comes up with a solution soon. So very tired and I've wasted about 7 hours doing this with the hope I'd be ready for Monday morning


    This is not an Apple experience I was hoping for.

  • Phoinix2 Level 1 (0 points)

    I have the same problem on MBPr 13" late 2013. Please post back what Apple has to say about it.

  • Phoinix2 Level 1 (0 points)

    I just completed windows 8.1 installation. It worked, but only from the left USB port.

  • agregory23 Level 1 (10 points)

    I have tried this every different way I can think of.  I have a new 15" MBP that does not have an optical drive.  I have tried installing on a bootcamp partition with Windows 7 and Windows 7 SP1 (with an ISO from digitalriver).  Each time the system reboots, boots from SD and gets to the language screen.  No keyboard or mouse.  I have tried unplugging my external keyboard, and oddly enough when I plug it back in it doesn't get power.  I am at a loss. 


    I have tried running the three bootcamp steps together and I have tried each one separately (always downloading the drivers/updates from Apple).  I have read the thread on making sure that the USB stick is in the left side.  I have tried starting over at least 5-6 times in different ways.


    If anyone has any insight on how to get Win7 Pro 64Bit SP1 installed on a new MacBook Pro I am open to suggestions.

  • Monty1982 Level 1 (0 points)

    I have the same problem with my new iMac (Late 2013). I tried to install windows 7 64 bit from a usb stick using an iso from digitalriver. I tried different iso's with SP1 and without. Every time no keyboard or mouse. I also tried USB-Keyboard and mouse which didn't work as well.


    As all the USB-Ports are alligned on the back of the right side of the iMac I can't even determine which of these would equal the left or right port of an MBA or MB.


    I could use some more insight, too.


    Maybe something with the usb stick? The one I used is USB 3.0. Unfortunately I don't have a large enough 2.0 to try.