Previous 1 2 3 Next 34 Replies Latest reply: Jan 15, 2015 9:44 AM by léonie
Khromosrick Level 1 Level 1 (0 points)

My iPhoto is not working. I open it and it loads for about a minute and then it closes abruptly. I sent the report and tried to restart my Mac, but still have the problem. Any ideas?


MacBook Pro, iOS 6.1.2, It's a brand new computer. 2 weeks
  • léonie Level 9 Level 9 (72,170 points)

    Tell us more. So it is hard to guess what might begoing an.

    • What is your iPhoto version, and what is the MacOS X version?
    • What were you doing, when this started? Importing photos? Did you install or upgrade software?
    • Is this a new installation, or has iPhoto worked before?
    • Where is your iPhoto library located? On an external drive? In your home folder?
    • All other details you might consider relevant.

     

    I sent the report and tried to restart my Mac

    What was the error message in the report? Post the first 50 lines of the crash log here, but not all of the report.

     

    Regards

    Léonie

  • Khromosrick Level 1 Level 1 (0 points)

    iPhoto Version is the latest I guess.

    OS X 10.8.4

    I opened the application and it starts loading my library, but it won't load my library. I also plugged in my iPad and it automatically opens iPhoto but the same problem.

    iPhoto worked fine before. I do the updates whenever they appear.

    My library is in my hard drive. Although I do use TIME MACHINE to back up everything. Should I try open iPhoto with the external hard drive plugged in?

  • léonie Level 9 Level 9 (72,170 points)

    then it closes abruptly. I sent the report

    Start it once more and copy and paste the reort from the window that you see when the crash occurs here into your next answer - the first 50 or so lines.

  • Khromosrick Level 1 Level 1 (0 points)

    Process:         iPhoto [443]

    Path:            /Applications/iPhoto.app/Contents/MacOS/iPhoto

    Identifier:      com.apple.iPhoto

    Version:         9.4.3 (9.4.3)

    Build Info:      iPhotoProject-720091000000000~1

    App Item ID:     408981381

    App External ID: 15017489

    Code Type:       X86 (Native)

    Parent Process:  launchd [140]

    User ID:         501

     

     

    Date/Time:       2013-07-21 17:27:17.174 -0600

    OS Version:      Mac OS X 10.8.4 (12E55)

    Report Version:  10

     

     

    Interval Since Last Report:          45982 sec

    Crashes Since Last Report:           4

    Per-App Interval Since Last Report:  181 sec

    Per-App Crashes Since Last Report:   4

    Anonymous UUID:                      EB42F82A-CDBB-5307-63AE-F7B37ED1ED26

     

     

    Crashed Thread:  0  Dispatch queue: com.apple.main-thread

     

     

    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)

    Exception Codes: KERN_PROTECTION_FAILURE at 0x00000000bf74bffc

     

     

    VM Regions Near 0xbf74bffc:

        Stack                  00000000b1825000-00000000b1835000 [   64K] rw-/rwx SM=COW 

    --> Stack                  00000000bbf4c000-00000000bf74c000 [ 56.0M] ---/rwx SM=NUL 

        Stack                  00000000bf74c000-00000000bff4c000 [ 8192K] rw-/rwx SM=COW 

  • léonie Level 9 Level 9 (72,170 points)

    That is a data error. You  may have imported images that cannot be processed, your iPhoto Library may have a corruption, your preferences file may be broken, or more.

    To check, f your library may have a problem, launch iPhoto while holding down the alt/options key and use the other/new option to craete a new iPhoto libray. does that work, and can you import photos into the new library?

  • Khromosrick Level 1 Level 1 (0 points)

    It didn't work. It created a new library but I had the same problem.

  • Old Toad Level 10 Level 10 (125,665 points)

    Log into another user account and try importing into iPhoto there.  Can you?

     

    OT

  • léonie Level 9 Level 9 (72,170 points)
  • Khromosrick Level 1 Level 1 (0 points)

    i only have one user in my mac. If it's an update error, how do I get it back?

  • léonie Level 9 Level 9 (72,170 points)

    Use the "System Preferences" > "Users&Group" panel and add another user account.

     

    Click the padlock icon, enter your admin password, then press the "+" or select the guest user account and enable it.

    Then use the -menu to log off and log in as guest user. Launch iPhoto and test.

  • Khromosrick Level 1 Level 1 (0 points)

    IS there any other way?

  • Old Toad Level 10 Level 10 (125,665 points)

    Having a second, non-administrative user account is an excellent tool for troubleshooting issues like this.  Takes up very little space on the HD.

  • léonie Level 9 Level 9 (72,170 points)

    The test in another user account is to check, if you have a system wide problem or a problem in your user account.

    • If the crashes appear in all user account - asystem wide problem - you would have to reinstall iPhoto, or reinstall Mac OS X, or try to find incompatible kernel extension, and other add ons, or take your computer to Apple because of hardware trouble.
    • If the crashes appear only in your user account, we will know, that the system software is fine, and only settings or startup items  in your own user account need to be fixed.

     

    So the test will help to decide what to do next.

  • Khromosrick Level 1 Level 1 (0 points)

    How can this be a hardware problem? The computer works perfectly, iPhoto is the only problem.

Previous 1 2 3 Next