Previous 1 2 3 4 Next 49 Replies Latest reply: Nov 11, 2015 11:12 PM by grlundrrepair Go to original post
  • Ocean20 Level 6 (13,570 points)

    The OP said his phone number does not work.... I wonder how he will send an SMS for imessage activation?

  • Noahwhite2014 Level 1 (50 points)

    He said his phone number does not work for iMessage overseas which is why I asked if he could make phone calls, but i recieved no response from him yet.

     

    If he can make phone calls he can send SMS.
    If he has AT&T or Verizon, he can send internation SMS.
    If he can send international SMS he can activate iMessage overseas.

     

    The idea behind airplane mode is to turn off his 4g (HPSA+), 3g(HPSA), or EDGE antennas. When wifi is turned back on, it will force his phone to activate imessage with his email accounts, and when airplane mode goes off it will activate the network used for calling first, which is also what SMS uses. Theoretically it should send the SMS on that network since it is the first available to use for his phone.

  • gjn6595 Level 1 (0 points)

    I can not make phonecalls. I tried what you said to do and it's still only letting me check off my apple id/e-mail

  • nezzyjr Level 1 (0 points)

    since i updated to ios7 imessage is bein run off my email adrres.. how do i get it to work thru my number?? please help

  • nanfc Level 1 (0 points)

    I managed to make it work

     

    1. turned off Facetime and iMessages

    2. turned off and on phone

    3. turned on iMessages (still had the phone number faded)

    4. opened the Facetime app, it asked me to log in with my apple ID

    5. when back to settings for iMessages and suddenly got the phone number selected

     

    Let me know if it works for you!

  • fcubitt Level 1 (0 points)

    Thank you.Very simple and worked at once.

  • z3r0k001 Level 1 (0 points)

    This worked for me Noahwhite2014... Thank you

  • 808me Level 1 (0 points)

    Hi I have a problem with my iPhone and iPad when I'm out of country too. I can receive text from androids at anytime but only able to receive text from iPhone when I have wifi.  I can send text to everyone, android and iPhone at anytime. Please help

  • Noahwhite2014 Level 1 (50 points)

    This is probably due to your network limiting your data connection (or yourself turning your 3g, 4g, or LTE off). In order to recieve iMessages you need data (3g, 4g, LTE, or wifi). If youre out of country your network (att, t mobile, verizon, sprint, etc.) may not offer data in the area you are in or the account owner could have opted to disable your data while out of country.


    Hope this helps.

  • HappyHanh Level 1 (0 points)

    Thanks a lot! I've tried many ways but haven't worked until I tried yours!!!

  • jinxius Level 1 (0 points)

    That worked for me! 

  • chasefromlagunabeach Level 1 (0 points)

    I had a similar problem and your solution worked. Thanks!

  • JimE-rot13 Level 1 (0 points)

    Thanks nanfc,

     

    This worked for me.

     

    Just noticed that I had the same issue selecting "Send & Receive" using only my phone number.

     

    All is right now.

  • CammyFleming Level 1 (0 points)

    Hello, i have tried all of the above solutions and none of them have worked, my number still appears faded and i cannot sent or receive imesseges on my number, i NEED to be able to do this ASAP do any help would be great, can you please also tell me roughly how long it will take for my number to become solid instead of faded after following the steps you have provided? Thank you

  • Sarge10709 Level 1 (5 points)

    Are you using your phone on airplane mode? Then this may help.

    This problem occured to me from yesterday and still not finding the real solution for it, but temporary, this works for me. I was fine using iMessages for 6 weeks before this happened.

     

    I'm using on airplane mode right now. So what I do is to disable airplane mode. Wait to get connect to the local roaming phone provider. Once it connected completely (I'd wait a minute or so since it connects and disconnects a couple of times), enable airplane mode and turn on wifi. Wait for a little. Double click the home bottun and close message app completely. Then open.

    This fixed my problem temporary. Because after while, it deselect my phone number to send&receive imessages.

    Hope this helps.