Previous 1 2 Next 28 Replies Latest reply: Mar 16, 2015 2:29 AM by Rehktous
Starspy Level 1 Level 1 (0 points)

I am trying to pair my iPhone remote app with my iTunes library however I cannot seem to find the 'necessary' Remote button on iTunes client. I have looked all over and no where can I see any mention of where exactly it is supossed to be found. The App on my phone says that I need to enter a 4 digit code on my computer but I cant locate where I need

 

I am also trying to set this up on my college Wifi network which apparently blocks home sharing as well.

 

Let me know!

Thanks

Will

  • sterling r Community Specialists Community Specialists (5,740 points)

    Hello Starspy,

     

    Thank you for using Apple Support Communities!

    Once you tap Add an iTunes Library in the remote app, and you see the passcode, the phone should appear as a device in the sidebar on the left of iTunes if you have it showing.

    iTunes 11: Frequently used features

    http://support.apple.com/kb/HT5649

    Show or hide the Status Bar and Sidebar

    In iTunes 11 you have the option to turn the Sidebar and the Status Bar on or off; they are off by default. To do this in the menus, go to:

    • Show Sidebar - Choose View > Show Sidebar (this feature will display iTunes features on the left side of the application including Library, Store, Shared, Genius, and Playlists).
    • Show Status Bar - Choose View > Show Status Bar (this feature will conveniently display the number of items and playback time for a category, for example, music or movies).

    HT5649_01-iTunes-status_bar_options-001-en.png

     

    If needed, here is also an article to help troubleshoot the App and Home Sharing connectivity:

    Remote app for iPhone, iPad, or iPod touch can't connect to iTunes or Apple TV

    http://support.apple.com/kb/TS1741

     

    Regards,

    Sterling

  • Starspy Level 1 Level 1 (0 points)

    Ok thank you for helping me show the sidebar - however I still cannot locate either the "Remote" button on my iTunes client nor an area where I would need to enter the passcode. My device does show up in the sidebar, but neither of the aformentioned items appear.

  • christohper Level 1 Level 1 (0 points)

    I have this same exact problem and am baffled.

  • Kaltor Level 1 Level 1 (0 points)

    Same problem here, I deleted all itunes and apple softwares ( like suggested) and I won't see my remote in itunes, I have 4 devices that were paired before, and now, none are working (ipad4, ipod touch 5, iphone 5 and iphone 4s, have you had a solution since???

  • wowaustin Level 1 Level 1 (0 points)

    This worked for me, from another user:

    I have an Airport Extreme with two networks: A closed home network, and a guest network for guests with guest network priviledges. For whatever reason, my iOS devices will sometimes switch to the guest network, which does not allow for Remote use. I'll troubleshoot the heck out of not being able to see my iTunes library until I eventually stumble onto the fact that I am on the wrong network. Make sure you check that your wireless connection is on the network associated with the iTunes/Home Sharing setup as a part of your troubleshooting.

  • L ping Level 1 Level 1 (0 points)

    Check the Network of windows 7

    A general rule to fix the network problem is to restart your home network router. If the problem remains, you can try switch IP4 to IP6. To do so: Open Control Panel > Choose Network and Internet > Select the View network status and tasks under the Network and Sharing Center section > Choose your active network connection > Click the Properties button > If Internet Protocol Version 6 (TCP/IPv6) is checked, uncheck it, then click OK > Restart iTunes and check if iTunes Home Sharing will work.

  • Jairuu Level 1 Level 1 (0 points)

    I HAVE THE SOLUTION TO THIS!


    I think this will work, it worked for me!

    Just go to Preferences in iTunes, wherever it is, then go to Sharing, and check Share my library on local network. I also checked Home Sharing computers and devices update play counts. Also, make sure that you go to settings on your iPhone or iPod, go to Music, scroll down and sign into Homesharing. And make sure you turn on Homesharing on your iTunes. This should work!!

  • Jojok1 Level 1 Level 1 (0 points)

    I'm so glad I found this,I was going crazy trying to get the remote app working. Thanks loads

  • classicdiane Level 1 Level 1 (0 points)

    Thanks Jairuu!! I never did find the so-called remote button lol, but your solution totally worked!

  • SH1982 Level 1 Level 1 (0 points)

    I'm stumped. All home sharing is turned on. Phone and MacBook. Connected to the same network. There is no place to punch in a the code to add the iTunes library, there is no remote icon, and the library is not appearing within the app via home sharing.

  • Rich_GB Level 1 Level 1 (0 points)

    Forget the 4-digit code. Its a left over from the past, and superceeded by 'Home Sharing'. Check Jairu's post above. This worked for me with iphone 5 and MBP running 10.9.

  • Feeza Level 1 Level 1 (0 points)
    Mar 2, 2014 4:38 AM

     

     

    I did a geeky thing: The problem is NOT with your Windows Firewall. The problem is with the firewall settings on your router (wireless router settings that you have to sign into as administrator online).  *WARNING: If you are scared to mess with settings, let someone else do it for you.

     

    Step 1: Log on to your router from the provider's online page (for example Sky or BT router settings)

    Step 2: Look for a button that lets you set up wireless access to your devices. (For example, in Sky, it's called "Wireless Station Access List" and has a blue button next to it called "Setup Access List".

     

    Step 3: Click that button and you will see a list of wireless devices that are detected, for example iPhone, iPad etc. *NOTE: You can only allow one at a time, so you have to select one and let it be accepted, then go back and do any others individually.

     

    Step 4: Click "Apply" or "Save" or whatever your router tells you to do and you're done!

     

    When you go to your device, it will ask if you want to trust that computer (meaning your own PC)..say yes. By magic, the "Remote" app will show your iTunes library and you're ready to roll!

     

    I am not good at IT but it took me months to find a solution by trial and error and now it works! Yaaay!

     

    Feezafee

    iPhone 4, iPad

     

  • Feeza Level 1 Level 1 (0 points)
    Mar 2, 2014 4:38 AM

     

     

    I did a geeky thing: The problem is NOT with your Windows Firewall. The problem is with the firewall settings on your router (wireless router settings that you have to sign into as administrator online).  *WARNING: If you are scared to mess with settings, let someone else do it for you.

     

    Step 1: Log on to your router from the provider's online page (for example Sky or BT router settings)

    Step 2: Look for a button that lets you set up wireless access to your devices. (For example, in Sky, it's called "Wireless Station Access List" and has a blue button next to it called "Setup Access List".

     

    Step 3: Click that button and you will see a list of wireless devices that are detected, for example iPhone, iPad etc. *NOTE: You can only allow one at a time, so you have to select one and let it be accepted, then go back and do any others individually.

     

    Step 4: Click "Apply" or "Save" or whatever your router tells you to do and you're done!

     

    When you go to your device, it will ask if you want to trust that computer (meaning your own PC)..say yes. By magic, the "Remote" app will show your iTunes library and you're ready to roll!

     

    I am not good at IT but it took me months to find a solution by trial and error and now it works! Yaaay!

     

    Feezafee

    iPhone 4, iPad

     

  • jamiejade Level 1 Level 1 (0 points)

    Thanks L Ping, Finally! After weeks months of troubleshooting, you have made my day! Thanks so much! I tried reinstalling, router settings, firewall settings and just couldn't get it. I was just about to give up. This is the solution!

Previous 1 2 Next