Previous 1 2 Next 17 Replies Latest reply: Nov 6, 2015 7:59 AM by angryapplestorrs
Hans L Level 1 Level 1

I have installed iCloud on my PC (Win 7). I have the latest FF, set as default (although I am not entirely sure if I have set that correctly).

 

Now, when I click on the iCloud icon in the tray, it shows

 

Open iCloud Control Panel

Go to iCloud.com

iClound Help

 

If I click on "Go to iCloud.com", iCloud.com opens in IE. I have tried, but I cannot get it to open in Firefox.

 

Any help would be appreciated.

 

Regards,/Hans L

Reply by edgalonzo on Nov 28, 2013 11:43 PM Helpful

Just turn off Internet Explorer, if you don't use it anyway, from Programs and Features. Icloud Control Panel Programs..ie..Find My Iphone, should open up with whatever default browser you have set.

All replies

Previous 1 2 Next