Previous 1 2 3 4 Next 56 Replies Latest reply: Mar 31, 2014 4:06 PM by George.iD Go to original post
  • brandonfromalbuquerque Level 1 Level 1 (0 points)

    Apparently Comast works using POP on ios7 (except the the unread nessages error).  All you need is your comcast email address and password and the phone figures out the rest.  At least it did for me.  I deleted and re-added my comcast email to the phone several times trying to get the faulty unread message notifications to go away.

  • bj5411 Level 1 Level 1 (0 points)

    This is how I solved the problem on my IOS7 iPad:


    1- select the mailbox where the problem exist

    2- click Edit (at the top)

    3- click Mark All (at the bottom)

    4- click Mark as Read


    If the problem still appears, do this:


    1- select the mailbox where the problem exist

    2- click Edit (at the top)

    3- click Mark All (at the bottom)

    4- click Mark as Unread (a blue point will appear in front of each mail)

    5- click Mark All (again)

    6- click Mark as Read


    That should solve your problem

  • Polskaczar Level 1 Level 1 (0 points)

    I have been having the same issues with my Yahoo! account, finally found how to fix it.


    Step 1: Delete your email account on the ipad/iphone

    Step 2: Log into that email account on a computer (probably can be done on the ipad/phone too)

    Step 3: Mark all emails in your inbox as unread

    Step 4: Create that email account on your ipad/iphone

    Step 5: Open that email account (all your emails should appear and they should all be "unread")

    Step 6: Mark all as read


    This worked for me.

  • jnanson Level 1 Level 1 (5 points)

    The best solution I found was to restore my iPhone BACK to OS 6.1.4.  Apple support states you can't do this, but this is a blatant lie.  I just did it & am thrilled to get rid of iOS 7 until they get it working properly.  Here is a link on instructions on how to do this:


  • Hoogirl Level 1 Level 1 (0 points)


    Re: Email problem with ios 7


       Sep 19, 2013 1:00 PM    (in response to doughboy44

    Here is how I resolved the unread messages error for my comcast email on ios7 iphone5.  I had to download all the messages in my inbox on comcast's server (read or unread) to the phone.  Then I marked them unread on the phone.  It was very tedious to download all the messages to the phone.  I had to reputedly scroll past the bottom of the iphone inbox which would cause 250 messages to download each time.  Then I marked all unread. 


    Now I have 13000 e-mail messages on my iphone, but they do not show up as unread.  The email messages I have received today after I got things straightened out show up unread but normally becomes read once I open them.  It seems to be working noramlly now.


    Perhaps if you have a ton of messages in your inbox on comcast's server you could move most of them to a different folder and then only the messages you want on the iphone will be downloaded?  It would be much quicker and easier than what I did and you would not have thousands of messages on your phone. I wish I would have thought of this before I downloaded so many messages to the phone...

    Thank you this worked!!  It was very tedious, but did the job.  I went into my Comcast server and moved a bunch of old emails to another folder out of my inbox (took a while). Then these emails were no longer on my phone. I had to scroll through a bunch of pages to mark all as read, but I finally reached the end!

  • Tnnisace Level 1 Level 1 (0 points)

    BTW it is working on my ipad and I tried mimicking the same settings back onto my luck.

  • Tnnisace Level 1 Level 1 (0 points)

    But how do I get all my folders back on? All i get when I sign into my comcast account is an inbox? 


    EDIT: On like the 10th try it's working now!  Weird.

  • bmagyar Level 1 Level 1 (0 points)

    The problem is most people dont use their account holders actually website for looking at their emails.  They use their phone or a built in service such as outlook on their pc.  On your iphone, go to (settings), then (mail, contacts, calendars), select your main account or accounts and then turn them off at the top.  Turn each one off.  Then go to your mail account holders website and look at your mail there.  For instance, outlook showed mine as all read but on Centurylinks site showed 5834 unread, exactly what the phone was showing.  Show on centurylink's site, my mail account holder, I marked them all as read, then went back and turn on each acount.  They now read correctly.


    Thanks, hope this helps



  • M N B Level 1 Level 1 (0 points)

    Disabling the account(s), force quitting mail, power cycling the phone, re-enabling the account(s) and launching mail doesn't work for me.  Tried it half a dozen times.  Even when using my providers web mail to mark all several thousand emails unread and then read.


    You can try marking mail read in Mail in iOS.  Of course, that only works for the mail chunk that is loaded, not ALL the mail in that mailbox.  You can scroll to get it to load more.  So if you have lots of memory and lots of time, that MIGHT work.

  • williamfromhillsborough Level 1 Level 1 (0 points)

    Tried this last night and it worked like a charm. Thanks for the tip.

  • M N B Level 1 Level 1 (0 points)

    I had better luck deleting the accounts, quitting mail, power cycling, launching mail and readding the accounts.  It worked well for the IMAP accounts since they save read/unread state.  But my POP account showed all unread because POP doesn't have that feature (it's an older protocol).  Fortunately, that account is the smallest one I have and I used the phone to mark the 2200 emails read in chunks of 250 at a time.


    Most people I know haven't had this problem.

  • HorizonsChris Level 1 Level 1 (0 points)

    Tried everything here, but nothing works. Until Comcast/Apple fixes this I've found one work-around. It doesnt fix the badging issue, but it at least helps collect all the real new mail. I went in the native mail app, selected EDIT, then turned on the "Unread" folder option. The only email in that folder are legitimate new ones. (even though it says there should be 3395 of them, it's empty once I go into it.) And only new ones drop into there.


    Hope this helps out.

  • Tnnisace Level 1 Level 1 (0 points)

    I keep getting the following message sporadically: "The connection to the server has failed.  The mail server is not responding.  Verify you have entered the correct account info. in the Mail settings."


    Sometimes my mail works fine and it loads and I haven't changed any settings and sometimes it doesn't. What gives?

  • Amhvillage Level 1 Level 1 (5 points)

    I too have Comcast email and have been trying everyting to fix these phantom unread emails - here is what finally fixed my problem. I cant tell you what the perfect sequence is as I have tried everyting from deactivating and rebooting, marking all as read (nice new feature) and even deleting the old email account and setting up a new one. You have to have a sense of humor here because the unread number sometimes gets worse before it gets better.  What made the mose sense to me is that the new unread email count is somehow reading items from comacast that I am not being able to download. What should work would be to go into your comcast account and mark all of your email as read and then set-up a new account on your iphone. That may not be what you want to do if you leave unread items as I do for follow up. So I went into my email setting on IOS7, selected the account I was having problems with, went into advanced setting and under deleted messages selected the "NEVER" option (i belive the default is "after one week". After doing this I found a bunch of undread messages suddenly appearing on my phone. I then used the new feature in IOS 7 to mark them all as read. (while viewing your inbox - select the EDIT link top right, after select the MARK ALL link bottom left, and then the Mark All as READ feature. This was my final fix - GOOD LUCK!!!

  • pianowez Level 1 Level 1 (0 points)

    I had the same problem. I deleted the account (after changing settings to not delete messages from the server) and then re-added it. All the messages were there and were unread.