Previous 1 2 3 4 5 Next 70 Replies Latest reply: Apr 22, 2014 11:24 PM by TPisaric Go to original post
  • Toddhitch Level 1 Level 1 (0 points)

    Same problem here for me...I have over 12k messages from my business account.  Over 6k of the old emails are unread as I used Outlook in the past and didn't delete the emails from the mail server. Am I really going to need to scroll and download them 250 at a time and then have to mark them as read? #annoyed

  • Elicoleman Level 1 Level 1 (0 points)

    Go to tour inbox. Select edit at the top, "Mark All" at the bottom then "mark as read". Then go through the same thing again and mark all as unread. Worked for me.

  • ShaneTAT Level 1 Level 1 (0 points)

    Thanks, this worked for me for that annoying hotmail pop account.  Delete it, and go through Exchange put in your email and password and click next.

  • proall Level 1 Level 1 (0 points)

    This is crazy. What I decided to do is not to use Apple's email app at all! I check on my emails on the server directly from now on using webmail (hosted godaddy email). This is ridiculous.  I will have to wait and see if they improve this in the future. Perhaps I can start using the standard email again down the road.

  • Howardsweb Level 1 Level 1 (5 points)

    What's your problem ? Haven't you read the thread ? All you have to do is delete the acocunt and add it again through Exchange as advised above. Get a grip.

  • jayant93 Level 1 Level 1 (0 points)

    This seems to have fixed the problem for me.

    1. Log into your Hotmail account at outlook.com
    2. Set up an alias that ends in @outlook.com
    3. Now delete your Hotmail account through iOS 7 settings
    4. Set up an new account on iOS 7 and choose Outlook
    5. Sign in using your @outlook.com alias for your Hotmail account
    6. The problem of showing thousands of unread mail should now be resolved. However, this does not sync your read/unread labels across devices or between your actual account online like IMAP would.
  • mikeinbangkok Level 1 Level 1 (0 points)

    Thanks so much for this. Problem solved!

  • ellenks Level 1 Level 1 (0 points)

    This worked for me. Thanks!

  • nobyko Level 1 Level 1 (0 points)

    I have the same problem and it is not a hotmail account. One of the accounts on my iPhone and one on my iPad (not the same accounts) are both showing up with messages unread. It's driving me nuts too. I already marked all as unread and marked them as all read again and that didn't work. They are both email accounts from hosting with godaddy (secureserver.net). I checked the server and there are no unread messages there either.

     

    I certainly hope they find a fix for this soon. I really hate it.

  • crulshuz Level 1 Level 1 (0 points)

    Perfect! Thank you!

  • 1BlindSquirrel Level 1 Level 1 (0 points)

    I have a slightly different problem. My notes in outlook email contacts are no longer displaying with new iOS 7 installed. This feature worked fine in iOS 6. This iOS 7 huge negative surprise makes me feel like an idiot for trusting this "Apple Upgrade." I have been meticulously adding to my notes on individuals in my contacts list for more than 5 years. It is my way of keeping track of, close at hand, all those little individual details that makes life interesting. I need help, any ideas?

  • Gamper_DK Level 1 Level 1 (0 points)

    thanks guys - I solved the problem as well, by creating a new outlook account.

    I noticed something special though, that at the outlook account I don't have the setting to say "do not delete messages from server"..

    I would like a new message I have read and/or deleted on the phone, still to be a unread message on the server. It was possible with the old hotmail account.

    Anyone else experiene this problem?

  • cONScIENcE Level 1 Level 1 (0 points)

    The solution should NOT be to roll all of your POP accounts into an outlook.com exchange account. I have multiple email accounts for multiple specific business reasons and no desire/ability to connect them into an exchange account....   Removing "mail days to sync" from POP accounts makes absolutely no sense whatsoever. Does anybody have a legitimate business reason technical or otherwise why Apple would restrict this feature from POP accounts... including iCloud... or is this just a design oversight to be remedied later? It is quite a bummer to look upon this beautiful new home screen and see the gobbledy gook representing my 26,000 unreads floating in red atop my mail app icon.

  • mrvlegov Level 1 Level 1 (0 points)

    So frustrated! I do not have a hotmail account it is another POP email. I have over 12k. I talked to applecare and they said there is nothng we can do except individually delete each one after loading them 250 at a time to the phone. They suggested restoring to an old backup but that didn't work.

  • noflipping Level 1 Level 1 (0 points)

    Hey... Same problem here with ATT and other POP accounts. If you try to mark each account as read, they'll tend to keep reading their ugly heads. But, what I found works and may require some attention be paid to the newest email, is to edit "ALL INBOXES" as read at the same time.  That seemed to work here for me so far. Seemed like there might be a bug in the database of read emails. Hope that helps...