Previous 1 3 4 5 6 7 Next 611 Replies Latest reply: Sep 18, 2015 8:05 PM by Ruadh2 Go to original post Branched to a new discussion.
  • LeoGecko Level 1 Level 1 (0 points)


    I too thought that having the "first synch" work meant that all following syncs would work.  The syncs worked a few times and then went back to the same issue even if I had changed no music or apps or anything on the phone.


    For me it seems turning anything to do with iCloud off, rebooting the phone and then transferring purchases manually prior to the sync works most of the time.

  • RockTheGlobe Level 1 Level 1 (0 points)

    Nothing so far has fixed this issue for me...  full factory reset and restore, power-cycling before each sync, manually synching -- none of it.  When I tried to resync my iPhone after the factory reset, it didn't even transfer over all of my music.  About 2/3 of my library was synched, then I manually tried to bring the rest over and it brought over all but 350 random tracks, then I had to manually bring over those 350 tracks. 


    None of this happened until iOS 7.0.3 and iTunes 11.1.2.  There's got to be bugs in the system somewhere.

  • RobertSch6 Level 1 Level 1 (0 points)

    I've tried a few of the "fixes" too, but nothing has worked so far for me either. The first sync this morning worked fine, but now I keep getting stuck on the "waiting for changes to be applied." I stopped tracks that were automatically downloading from iTunes. (I don't know why they were downloading in the first place, as I had purchased them a couple weeks ago, and they were already on my iPhone.) I turned off my iCloud settings and turned of Find My iPhone. Nothing is working.


    I would think that Apple has people that thoroughly test out the upgrades before they release them, but maybe we are those people and we didn't know it.


    While I was writing this, the sync finished. But I was missing about 5GB of music, so I thought I'd try syncing it again to see if those would load. Well, that was a big mistake. Now I'm stuck again on "waiting for changes to be applied."


    I really don't have time for this.

  • RobertSch6 Level 1 Level 1 (0 points)

    I have to update this. It looks like I actually am missing about 32GB of music. I have a 64GB iPhone. As you can see in the picture, the colored portions of the bar show that I would have about 9 or 10 GB free, but the text says I have 32.48GB free. The latter is more accurate, as I have found that - although my music shows up on my iPhone, when I try to play it, I get an error saying that it can't be found.


    iTunes Bar.PNG

  • RockTheGlobe Level 1 Level 1 (0 points)

    I had the same thing happen to me.  64GB iPhone said it synched all of my music (when I moused over the blue section, it gave the correct number of tracks and memory allocation), but said I had several more GB free than usual.  When I tried to play songs off my iPhone, they weren't greyed out but did have the red "stop" icon in a circle and skipped through the track.

  • mediahound Level 1 Level 1 (15 points)

    This sounds like some sort of iOS7 file system bug or something. I recommend you reboot your iPhone to see if it clears up after the restart.

  • RobertSch6 Level 1 Level 1 (0 points)

    I've tried rebooting my iPhone twice, but it didn't fix it.

  • thedangercometh Level 1 Level 1 (0 points)

    I would like to echo the experience of many users in this thread and others like it. From a troubleshooting standpoint, I performed the methods suggested on the first place (including idisk/iexplorer3 to remove voice memo, disabling find my iphone, cold reboot, etc). If I do not attempt to sync any media (that is, empty out music, tv, and movies) the sync proceeds to completion. If I manually try to add any music/video (media that has previously done this without trouble) then it is a no go. I am able to transfer media to an ipod (third generation) without problems; mavericks/early 2011 MBP/iphone 4s on ios7.

  • SouthLake1 Level 1 Level 1 (0 points)

    cpaulPHL wrote:


    After countless hours this past weekend with this same problem (iTunes stuck on "waiting for changes to be applied..." I finally have resolved it without having to completely rebuild my iTunes library (and losing my metadata in the process). For background, I updated my iPhone 4s while I was traveling, and when I returned home, I was no longer to update music in iTunes (it would hang).


    The problem, it seems, is related to several factors:

    1) you have enabled "Find My iPhone" in the iCloud settings on your iPhone

    2) you have initiated a download of music through iTunes on your iPhone, and the downloads have not completed

    3) you have a corrupted Voice Memo, causing duplication on each sync


    Here's what I ended up doing:

    on your iPhone / iPod / iOS device:

    1) disabled "Find My iPhone" on the iCloud settings of my iPhone

    2) gone to the "Downloads" section of the iPhone "iTunes" app and deleted every in-progress download

    3) go to Voice Memos app and see if there are recordings in the list that may have been duplicated

         you can also check the "Voice Memos" playlist on your iTunes library

              - delete any duplicate Voice Memos; if some memos are gray and can't be deleted see below

    4) do a cold reboot (hold down top bottom, power off, then on again) but do not dock your iPhone yet


    on your iTunes:

    5) change your iTunes -> Devices preference to "Prevent iPods, iPhones, iPads from syncing automatically"

         you can now dock / connect your iPhone to iTunes

    6) select "Manually manage music and videos" in the Summary tab for your iPhone within iTunes

    7) go to the Music tab for your iPhone within iTunes

         - you may see a list of music at the bottom called "manually added music"

              if present, select all items in this list and Delete to remove them

    8) uncheck "Sync Music" at the top of the Music tab and "Apply"

         - this will remove all music from your iPhone

    9) if the iTunes sync completes properly, perform a Local Backup of your iPhone (you may need this later)

    10) re-enable "Sync Music" but uncheck "Voice Memos" and "Apply"

         - if this fails, you have a corrupted memo - see below

    11) if this sync completes, change your iTunes -> Devices preference to disable "Prevent iPods, iPhones, iPads from syncing automatically"


    possibly optional steps needed:

    a) make sure you have a backup of all of your Voice Memos (check iTunes)

         you may want to copy off these files and then remove them from iTunes, especially if there are duplicates

    b) if your Voice Memos database is corrupted, you may need to clear out the iPhone internal database

         there are third party utilities (I used "iPhone Disk") that let you access the directory even on a non-jailbroken phone

    b) remove all files from the "Recordings" directory

    c) cold-boot your iPhone

    d) repeat steps above


    Again, this sounds painful (it was!) but after many tries, this is what finally allowed my iPhone 4s with iOS 7 to once again sync properly with iTunes 11.1. This process will preserve your iPhone settings, voicemails, Messages, etc. And, it will let you retain your iTunes library without rebuilding.

    i had this problem.. this fixed it. thank you

  • woodmeister50 Level 5 Level 5 (4,450 points)

    Updating what I have found as a solution in my case,

    wait, wait, and wait some more.  After letting iTunes

    sit and spin its wheels for about 20 minutes, it finally

    decided sync ~500 of my 1800+ songs.  Why it thought

    it needed to do this I have no idea as they were all items

    that were on the phone for a long time.  It also, seemed to

    be a random mix of purchased and ripped CDs scattered

    along the length of the alphabetical order of things.


    Whatever, all seems back to normal at this point .

  • Mattkirby84 Level 1 Level 1 (0 points)

    Thank you. I had the same problem and took your advice and did a full restore. Extremely frustrated and disappointed with apple! Thanks again!

  • jmcfayden Level 1 Level 1 (0 points)

    I am totally ****** right now. I lost all my songs on my phone searching for a solution. Since iOS7 everything has been fine, then they update it and everything is messed. You'd think an update would HELP.....

    Now permanently stuck on "Waiting for Changes to be appleid" I have no music for the ride home, except Ed Sheeran "The A Team" I song I don't even remember downloading....


    Apple is the new Blackberry! hashtag it!


    Please fix this ASAP Apple!!!!

  • nurmipau Level 1 Level 1 (0 points)

    This just happened to me again for the second time in about a month.  This time, I restarted my phone, and deselected wifi sync, and deselected Sync Tones.  Then tried syncing again... it took ~5 min to sync, and for some reason resynced all the music on my phone, but it worked.  Apple... if you are reading these... fix this already... you are quickly destroying the only advantage you hold in my mind over a Samsung.  Make your music work seamlessly, or I might as well not bother with you.

  • thedangercometh Level 1 Level 1 (0 points)

    in follow-up, what finally worked for me:


    1) restore iphone

    2) restore backup


    somehow also freed up approx 2gb of storage too

  • aaroncurtisneil Level 1 Level 1 (0 points)

    Thought I'd solved this some time back, and it was loading properly again. Then iOS7 had an update. So I foolishly thought "Maybe I can use iCloud again now" and allowed it to turn on.


    That's been the problem for me so far. Any time I have iCloud on for even a second, it won't load properly after that.

Previous 1 3 4 5 6 7 Next