Previous 1 2 3 Next 30 Replies Latest reply: Apr 27, 2014 5:39 PM by mikeindc
Brian Bradley1 Level 1 Level 1

I just upgraded my apple tv software last night. I started watching a movie and wanted to finish it today. However I exited out of the movie to show a friend my photo stream. Then I went back to play the movie. Apple TV doesn't give me an option to continue watching the movie. Normally in the pervious AppleTV IOS you would see the movies you have currently rented over to the left  but that's no longer the case. I tired re-renting the movie to see if it would just let me continue where I left off, didn't work either. I'm provided with a message when I try to re-rent it "You have already rented this item but it hasn't been downloaded. To download it, go ti the Settings menu, select Downloads, then Check for Downloads" When I go to settings I don't see an option for downloads. Also I did try going to settings and my iTunes account and selcting Check Rented Movies but the circle icon

 

What do I do?

Solved by Winston Churchill on Sep 24, 2013 9:45 AM Solved

No, your purchase history is your purchase history wherever you view it.

Reply by tnero on Sep 24, 2013 10:34 AM Helpful

there seems to be an issues with rentals disappearing after the latest update.  what has worked for many is going into to settings and itunes store > sign out of account and sign back in.  the rental has come back for a lot of people after doing that.  hope this helps.  also if you missed time on the rental i would be asking for a refund,.

All replies

Previous 1 2 3 Next