Previous 1 2 3 4 Next 92 Replies Latest reply: Apr 13, 2016 9:49 AM by ZITRO68 Go to original post
  • Dr. Trisha Level 1 Level 1

    I am having the same issue with the new iOS 7.  I can not get my Logitech keyboard to connect to the Bluetooth.  Tried to reset, repair, and go to default settings.  This really *****!  They better come up with a solution!  Like now!

  • w7hpw Level 1 Level 1

    I my case it will pair after a forget but nothing works, the i Pad seem to not even recognize that it has a bluetooth keyboard attached. ie. the onscreen keyboard is activated.

  • bedardjr8 Level 1 Level 1

    Actually I'm typing on my Belkin Ultimate Keyboard case right now.  Funny thing is that I have the same issue, but it seems to be localized to certain programs.  I can type in my browser and web pages, but when I use the email application I can't get the keyboard to register anything except to pop up the virtual keyboard.  Very frustrating. 

  • Trojan101 Level 1 Level 1

    I'm having problems with my Elecom Foldable Bluetooth Keyboard. The backspace button no longer functions in iOS 7. Also, there is a delay between keystrokes and the appearance of the character.

    This applies to every app.

  • eefbee Level 1 Level 1

    I just read this in another thread and it worked for my Logitech Keyboard!


    Delete the Bluetooth profile (if still there) and try repairing after you have forced the keyboard back into discoverable mode.


    My Logitech Tablet keyboard works fine with iOS 7.0.2 but I did have to re-pair in after the original iOS 7 update.  On the tablet keyboard, there is a key on the underside, near the side with the on/off switch, that you press and hold for a second or two to force the keyboard back to discoverable mode.  Your keyboard might be a different Logitech model, but just check its manual for how to force it back into discoverable mode.



  • pkoss Level 1 Level 1

    FWIW I don't know that the problem with wifi login is tied to a bluetooth keyboard.  I "forgot" my Logitech BT keyboard, then went to login to the public SSID at work. 


    This time (as with other times when I had the BT keyboard turned off) there was no virtual screen keyboard.  I switched back and forth between the userid and password fields multiple times and then finally the keyboard appears for no apparent reason. 


    Curious too that the screen it displays appears to have two segments to it, separated by a vertical line.  I don't get that on other devices (my iPhone works just fine into the same public SSID).


    I can't make it repeat at this point since the login is persistent for 24 hours.  I'll track my workaround and see if I can document the process.

  • carlafromswisher Level 1 Level 1

    I have the Logitech Ultrathin Keyboard/cover and after upgrading my Ipad did not recognize my keyboard at all. When I went into settings there was no Bluetooth profile to delete and it was just stuck on SEARCHING for a device.


    After finall trying a number of things I remembered there is another small button on the side of the keyboard to try to force a connection. It is beside the On/Off switch. I pressed that a couple of times and everything synched up and is working perfectly now.

  • bedardjr8 Level 1 Level 1

    Well, after a few resets my keyboard is finally working in all applications.  Not sure what the issue was, but happy that I can now use my keyboard again for emails. 

  • stoopskc Level 1 Level 1

    Turn off the keyboard and the bluetooth in settings, forget the device, go to general and reset settings, no data is lost, then allowing ipad to restart, turn on the keyboard and pair.

  • DrBennett68 Level 1 Level 1

    I have a Belkin Ultimate Keyboard and after upgrading to IOS 7.0.2 it stopped working as well.  I finally got it working again by doing the following:
    1) In the bluetooth settings - Select the keyboard - Forget the Device

    2) Turn off Bluetooth
    3) Reboot the iPad
    4) Re-enable Bluetooth
    5) Re-pair the keyboard


    This process seemed to fix the issue and the keyboard works great now.

  • bonnierunner Level 1 Level 1

    I have an Ipad2 and a Zagg Keyboard. Even with the IOS 7.0.2, it will no longer pair. I have tried charging the keyboard, turning off both the ipad and keyboard and nothing works. I think Apple needs an IOS 7.0.3

  • Lawson Culver Level 2 Level 2

    I have a third generation iPad and Zagg's ZAGGKEYS Profolio + (it's a keyboard case).  It pairs without issue in 7.0.2.


    However, I'm having the same up/down arrow problems that a previous poster mentioned.  Works in some apps, not in others.

  • MelodyfromNV Level 1 Level 1

    Thank you, stoopskc.  I did what you suggested, but I did not go into general and reset settings. Figured I'd try this first and if it didn't work, I'd go through the process again and do the reset.


    I turned off my Logitech keyboard, went into Bluetooth settings on my iPad, chose "Forget this device", turned the keyboard back on, then pushed the bluetooth button on the keyboard to force it into discoverable mode and it reconnected.

  • tangentially Level 1 Level 1

    I have an issue with my Brydge keyboard on my iPad with ios 7 (all flavors).


    My keyboard works fine until I pull down the spotlight search. At that point it quits working but no software keyboard will appear. It won't start working again until I cycle bluetooth on my iPad and power on the Brydge.


    It works perfectly otherwise.

  • tangentially Level 1 Level 1

    Deleting all of my Bluetooth devices, force rebooting the iPad and readding the Brydge (one I remembered ctrl-k for pairing) solved my problem

Previous 1 2 3 4 Next