Skip navigation

Itunes 11.1 and IOS 7 suddenly not home sharing

16772 Views 32 Replies Latest reply: Mar 29, 2014 1:26 PM by Vands RSS
1 2 3 Previous Next
Dungondude Calculating status...
Currently Being Moderated
Sep 25, 2013 1:34 PM

Ya so i updated to ios 7 on my ipod 5th gen and updated itunes to version 11.1. For a wile home sharing was working fine between the two, but suddenly last night it stopped. My laptop can share with my ipod, but for some reason my desktop wont work with my ipod or my laptop.

iPod touch (5th generation), iOS 7
  • WildFireBall Calculating status...
    Currently Being Moderated
    Sep 26, 2013 10:19 PM (in response to Dungondude)

    I have same problem between iTunes 11.1 and apple TV.

    I guess iTunes 11.1 has bugs...

  • tilemakerman Level 1 Level 1 (40 points)
    Currently Being Moderated
    Sep 29, 2013 9:04 PM (in response to Dungondude)

    winston suggested right along the lines of what to do. the support articles are there to TS this and part of that is going thru all the steps to make sure everything is right. normally something like this is user error or something that is not set up correct. one of the main steps to always try and turn off or sign out of home sharing with all devices and computers and then turn the main hub on (computer with all the music). then turn one at a time back on. with ios 7, you have to go into MORE in the music app and choose sharing to connect to the shared library on the wifi network. Also, all devices have to have home sharing signed into the same account (apple id). home sharing is enabled on the apple devices in Settings>Music>home sharing at the bottom.

  • aussiedee77 Calculating status...
    Currently Being Moderated
    Sep 30, 2013 4:11 AM (in response to tilemakerman)

    They don't SOLVE the problem. It's an issue between 11.1 and Apple tv and the updates. There's a glitch because WAY too many people are reporting it.

     

    I'm another!

  • tilemakerman Level 1 Level 1 (40 points)
    Currently Being Moderated
    Sep 30, 2013 6:58 AM (in response to aussiedee77)

    So I have a Mac mini 2010, asus mini with win 7, iPad mini, iPhone 5, Apple TV all on the latest apple SW and my home sharing works just fine. So it would serve to think that even if SO many people are reporting a problem (not user error) than it would be the environment. Part of those articles include firewall and security SW settings. Perhaps..just perhaps, since Norton is so common, that a program such as that, could be the culprit? Assuming that since others report it means it's a glitch doesn't mean it really is. If it was, it wouldn't work for me either. I hope you get it to work! :)

  • Winston Churchill Level 10 Level 10 (81,650 points)
    Currently Being Moderated
    Sep 30, 2013 7:37 AM (in response to tilemakerman)

    ausiedee77 discovered their problem was with their firewall settings in the router.

  • nanonanu Calculating status...
    Currently Being Moderated
    Oct 6, 2013 8:15 AM (in response to Dungondude)

    Same problem here, although Home Sharing has always been buggy - it's just now much more so.

     

    Upgraded iPhone 4 to iOS 7, and running iTunes 11.0 (on both my Mac mini running OS X 10.6.8 and my PC running Windows 7 Pro x64), and while they FINALLY fixed the "hang Music app on reconnect" bug, as well as the "disconnect after 30 minutes of playback" bug, they introduced a new one: hang on initial connection to library.

     

    With iTunes 11.0, it would usually connect.  However, every once in awhile the progress circle would get to the halfway mark and just hang.  If I then canceled, or selected "iPhone", and then tried to reconnect to the remote library, I would get the message "Unable to turn on Home Sharing".  Once that happened with one library - either Mac or PC - it would happen to the other one, as well, upon the first connection attempt.

     

    iTunes 11.1 has made that occurence much more regular - it has indeed gotten worse.

     

    I've signed in and out of my Home Sharing account on everything several times, restarted, blah-blah-blah, i.e. done all the things that I as an end user of an Apple product shouldn't even have to think about doing...and no, it is not a network problem because:

     

    1) The Remote app - which doesn't use Home Sharing but does use Bonjour - can ALWAYS connect.

    2) I can ALWAYS connect to my Airport Express for AirPlay streaming - again, no Home Sharing, but uses Bonjour

     

    and most of all...

     

    3) The Video app - which DOES use Home Sharing - can ALWAYS connect to my libraries, always on the first attempt.

     

    TL;DR: Home Sharing is still broken, iOS 7 fixed a couple bugs but introduced a new one, and iTunes 11.1 has made it worse.

  • nanonanu Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 12, 2013 6:18 PM (in response to nanonanu)

    Update:

     

    Just got my 5s (32GB, Space Gray, Verizon), updated to 7.0.2, and things have improved marginally in one area, gotten worse in another.

     

    Better: Connecting to my iTunes libraries is a little bit better - the 5s connects successfully more often, and when it does, it's lightning fast: 1-3 seconds.  However, it still does occasionally do the exact same thing as my 4: hangs at the halfway point, and then I get the "Unable to turn on Home Sharing" message, while the Videos app successfully connects every time, just like on my 4.

     

    Worse: Album art (and lock screen in general) while using Home Sharing.  Album art will usually show up the very first time I use Home Sharing after rebooting the iPhone, but then at some point it will stop showing up, and when that happens, the lock screen will freeze on the album art, artist/album/title, *and* playback position of whatever track was playing before album art went away.  It will stay that way until the iPhone is rebooted - however, transport controls and volume always work, as does logging in, either fingerprint or keypad.

     

    Sigh...

  • skarilla Calculating status...
    Currently Being Moderated
    Oct 28, 2013 3:19 PM (in response to nanonanu)

    nanonanu,

     

    I am having the same issue with the upload halting half way.  Did you ever come up with a solution?  My ipad syncs over wifi, I can transfer music to ipad ok, and i have resigned into home shareing on both devices several times.  The only thing that does not work is music sharing.  Thanks.

  • Cutter2906 Calculating status...
    Currently Being Moderated
    Oct 28, 2013 4:20 PM (in response to tilemakerman)

    Please - this nonsense of checking and re-checking the user's network environment is just a way to distract people from the real issue.  There are bugs in iTunes.  It doesn't work and this has been going on for months.  Frankly, I'm a bit tired of it.  If there were a competing product available I'd switch from Apple right now!

     

    Apple let's get with the program and focus on getting this resolved.

  • kiefferp Calculating status...
    Currently Being Moderated
    Oct 28, 2013 10:40 PM (in response to Dungondude)

    Exact Same Problem here...  Certainly a bug iPhone 5, 3rd Generation Apple TV, 2013 Macbook AIr, running Mavericks All updates performed.  Signed out/in up down left right blah blah blah...  No luck cannot see my library no matter what is preformed.  yes everything is synced same id's same everything.....  Just a bug that has completely crashed my system.  500 movies completely useless....

  • tilemakerman Level 1 Level 1 (40 points)
    Currently Being Moderated
    Oct 29, 2013 1:07 AM (in response to kiefferp)

    I'll share what I have:

    2010 Mac mini on Mavericks

    Asus mini netbook Windows 7 starter SP1 I think (sharing separate library from there works too)

    iPhone 5 verizon 7.0.2

    iPhone 4S verizon (iPod) 7.0

    iPad mini 7.0.3 (wifi)

    Apple TV 3 x2 on previous update before most recent

    iTunes 11.1.1 on Mac iTunes 11.0.1 on win.

     

    Home sharing on, signed in under settings and music (did not need to sign in under movies)

    Apple TV signed into computer icon.

     

    Home sharing displays 6k songs and 300 movies without issues and I use it every day. So where's the failure for those that share this? I really can't tell you but...for those that says its a bug, don't blame a specific product for this, it is the environment. Ie: MacBook Pro vs Mac mini maybe? I work for Apple and have had some people call me about their home sharing not working and everything I have tested shows it's not the devices that's failing specifically, rather the mix somehow. Ie: guy with two windows computers with different libraries- HS on for one: all devices see it and works on that Apple ID. Off and turned on other win PC, does not show at all on anything. So, there are internal firewalls set for not just the computers but also they modem and router. This might be (some have checked this on other discussions) a cause to check.

     

    I hate to hear those that struggle with this because there seems that it might be a different fix for each person and no definite answer to everyone. Sadly, I could probably sit down in front of each persons computer and get it working quickly but I've set home sharing up maybe 50 times in the past month on three separate networks without concern. I really hope maybe my "non" issue gives hope to those out there losing it. Not everyone has this issue, only those that have posted. :)

  • ithriveoutside Level 1 Level 1 (0 points)

    I'm having the same issue.  Home Sharing worked flawlessly for years until the latest round of updates.  Router settings have not changed.

  • jasnstu Level 1 Level 1 (20 points)

    My problem is that It's just not appearing on some of my devices.  I have an iPhone 4S, an iPhone 5S and the first gen Retina iPad.  The sharing always shows on the 4S, never shows on the 5S and is 50/50 if it appears on the iPad.  All the settings are the same on all the devices, there should be no reason that they are showing diffrent things in the same network environment.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.