Previous 1 2 3 4 Next 45 Replies Latest reply: May 2, 2015 12:07 AM by Natelake
DJbestmaster Level 1 Level 1 (0 points)

All purchased movies / tv-shows wont play after the last update. Can anyone help?


Apple TV
  • Winston Churchill Level 10 Level 10 (90,125 points)

    Welcome to the Apple community DJbestmaster.

    Check your account details are correct, check that you are using the correct details for Location, Region and Time Zone. You may want to change these settings and then change them back to see if that helps.

     

    You might also try logging out of and then back into your iTunes account and restarting your router.

  • DJbestmaster Level 1 Level 1 (0 points)

    I have done that.

     

    I have never had problems streaming purchased movies, shows, or music before.

     

    Now I can see all that has been purchased and even select them.  However, when a movie or show is played, it shows the spinning wheel for a couple seconds and reverts back to the movie/show details screen.  When music is attempted to be played, a "content not found" error occurs when a song is selected.

     

    Interestingly, movie previews can still be watched just fine.

     

    Also, if I restore or reset the Apple TV I can immediately watch one move or show video, but the second time this is attempted it reverts back to the original error.

     

    This means that I have to spend 4 minutes resetting the Apple TV just to watch something.

     

    Apple support was not able to resolve this.

     

    Netflix and other apps work just fine.

     

    This also just happened a couple days ago...

  • Winston Churchill Level 10 Level 10 (90,125 points)

    A fair proportion of users with this issue are finding that it's account related, have you checked that your payment details are exactly right.

  • renpas04 Level 1 Level 1 (0 points)

    I've been having issues as well and I'm convinced that is an account problem, not a problem with the Apple TV itself.

     

    I went and rechecked all of my account details and there is no problem. I can still buy things on iTunes and the content shows up on the ATV, but it just won't play it. Content plays fine on my Mac and iPad.

  • Winston Churchill Level 10 Level 10 (90,125 points)

    If you are reading this message either in the online community or in an email notification you have received, please be aware it is a temporary post.

     

    The support community is currently undergoing some minor problems which can occasionally result in newer posts being rendered invisible. One method of working around this issue and revealing the hidden posts is to add a further post of one’s own.

     

    However because it’s not possible to see what one is replying to, it’s not possible to make a valid post in terms of the question(s) being asked, but once it has been posted and the invisible posts become visible again, one can then edit the post accordingly.

     

    If you are seeing this in an email notification, unfortunately you won’t be notified of any subsequent edit and as such should return to the message in the online community to see any changes made to it.

     

    On the other hand, if I have nothing worthwhile to say, it might remain as it is.

  • BenB Level 6 Level 6 (8,620 points)

    It is a bug, lots of us are having trouble with rented movies not playing.  Mine plain don't show up anywhere.  Major Apple bug they need to acknowlege and fix ASAP.  I've got two movies rented several days ago, still won't show up.  It never took more than a few minutes for a movie to be available for viewing before.  Very messed up...

  • stuckincube Level 1 Level 1 (0 points)

    Same here, can't play rented movie.  ***!?

  • tiffany01216 Level 1 Level 1 (0 points)

    get a micro usb cord and hook your apple tv up to your computer and restore it from there. you might need to open and close itunes a few times to get it to read the apple tv device... if you have a 2nd gen, you wont be needing the power source but if you have a 3rd gen, you will be needing it. once it's connected you'll see a link on the top right of itunes... click on it and restore your device. i just restored mine after an hour of messing around with it. get it together apple.... i buy your products for one reason only and it's RELIABILITY. smh.

  • BenB Level 6 Level 6 (8,620 points)

    ATV is embeded in to a larger entertainment system, pulling it out is major work.  That solution is not acceptable.  Apple needs an update ASAP to fix this.

     

    I have a friend who did this.  Worked.  Rented movies a few days later, had to plug it in to the Mac and reset again.  That is not an acceptable solution.

     

    I finally tried it, it did not work for me.

  • Tlow9090 Level 1 Level 1 (0 points)

    Same issue here. After update no movies previously purchased will play. Please fix ASAP! Tried logging out/in with same account. Also tried changing time zones and rebooting, no luck. It appears making a new rental works but no luck on previous purchases.

  • Coqui2k Level 1 Level 1 (0 points)

    I'm having the same problem

  • kckiem Level 1 Level 1 (0 points)

    I am having the exact same issue, this is unacceptable - come on apple! Get it together... very frustrating...

  • Coqui2k Level 1 Level 1 (0 points)

    I called them and they have no clue as to why is happening.

  • Chubbyboy1 Level 1 Level 1 (0 points)

    I'm also having the same problem . All i can do is reset the settings it will let me watch 1 episode of something and then won't play anything else until I rest the settings AGAIN .... It was absolutely fine up until last night.. Frustrating as **** tried absolutely everything aswell... Come on apple, it isn't too much to ask

Previous 1 2 3 4 Next