Previous 1 2 3 4 5 Next 69 Replies Latest reply: Sep 5, 2014 10:25 AM by tts_tontech Go to original post
  • Sébastien Shaikh Level 1 Level 1 (10 points)

    Wow now that you mention this, Bootcamp broke on my Mac when i upgraded to ML last year and i remember changing my partition sizes. So i had to re-install Windows 7 and Bootcamp on my Mac but I never changed the partition sizes and I just upgraded to Mavericks and now bootcamp is still working fine

  • AndiRudi Level 1 Level 1 (0 points)

    Yes, here is a picture of the desaster originally my bootcamp partition was most of the drive...



  • AndiRudi Level 1 Level 1 (0 points)

    Just a quick note: I tried wondershare data recovery and it found the partition and all files. So if anyone needs data this tool can be usefull (among other tools).

  • armysldr Level 1 Level 1 (0 points)

    I upgraded to OS X Mavericks last night, and my BootCamp running Windows 8.1 is just fine. What I did was download the upgrade off the app store, then instead of installing after the download I restarted my computer and held the Option key at the startup. I chose recovery drive. I then erased the OS X Partition and then chose "Install OS X" from the menu. During the install, you have the option to migrate your data from another Mac or from a Time Machine Backup, After my TMB finished installing. Both of my partitions boot perfectly. Not sure if this will help anyone, but this is the route I took when upgrading to ML and my BootCamp partition was untouched then as well.

    Also, I went with the install imediately after downloading option first, and after Mavericks installed, I was no longer the administrator for my computer and I wasn't able to boot into Single User Mode to fix it, then I remembered how I did it last year and just started over. Hope this helps!


    btw, I have a mid 2010 Macbook Pro, 16GB RAM, 1TB Hybrid SSHD

  • schafdiggs Level 1 Level 1 (0 points)

    It sounds like I have a very similar problem to yours. How exactly did you restore the old partition? I have a program called Data Rescue but its for Mac, any idea if that will that work at all?

  • 68K Level 1 Level 1 (0 points)

    Have you tried holding down Command on boot/reboot? My default boot into Windows had disappeared after the Mavericks update, but manual boot partition selection with Command, followed by a new system selection in Boot Camp Control Panel in Windows fixed that.

  • armysldr Level 1 Level 1 (0 points)

    I'm not saying i have a problem, i'm just stating my possible work around. You could try downloading and installing rEFit and that could give you your Windows option back....

  • schafdiggs Level 1 Level 1 (0 points)

    HHow would rEFit work? What exactly does it do? When I put in a windows install disc and hold down option on startup, an EFI boot option pops up also. Do you think that does something similar. Oh and to answer my own question: Data Rescue for Mac didn't help at all.

  • HuaLoon Level 1 Level 1 (0 points)

    Can everyone list down which Bootcamp version are they using and what version of Windows they using?


    I guess this does affect how upgrading to Mavericks affects the bootcamp right?

  • Sébastien Shaikh Level 1 Level 1 (10 points)

    I installed refit last year after upgrading to mountain lion and i recently upgraded to Mavericks. Maybe refit is the reason my Bootcamp partition is still fully operational.

  • Sébastien Shaikh Level 1 Level 1 (10 points)

    That *****. I hope you backed everything up? It will be a hassle to re-download all your software if you use plenty of apps like i do. But i think the fact i use refit had an impact on my bootcamp partition still being fukky operational. Maybe install refit for future Mac OS upgrades.

  • Sébastien Shaikh Level 1 Level 1 (10 points)

    I use refit on my mac, i dont have to hold down alt button for refit to pop and give le the option between Windows and Mac os, it just does it automatically.

  • -ctr- Level 1 Level 1 (0 points)

    I also lost my Bootcamp partition when upgrading to Mavericks but that may just be because I'm triple booting (which is not supported by Bootcamp).


    Usually if you still see the Bootcamp partition but can't boot of it then it's just the (hybrid) MBR that is broken.

    Follow the gdisk procedure here:

    or use reFIT (gptsync) to repair the hybrid MBR and you should be all set.


    This will *not* work if (for whatever reason) the parition is gone (i.e. you can't see it in diskutils anymore).

  • bridgetower Level 1 Level 1 (0 points)

    I updated to mavericks hours ago, now my bootcamp windows 7 had been disapeared. HELP~~~~~~~~~~~~~~~~~


    any one can help me ? re-install windows 7 and all my steam game take 20+ hours......... including windows update, pls help me,


    mavericks did kill my windows 7

  • armysldr Level 1 Level 1 (0 points)

    Is your BootCamp partition showing up in disk utility?