Previous 1 2 3 Next 114 Replies Latest reply: Nov 2, 2014 3:16 AM by hedgert
Troy Sturgill Level 1 Level 1 (0 points)

Just upgraded to 10.9 Mavericks and can no longer connect to our SMB file share on the network.  Several of us have tried connecting to it on this machine and all we get is


There was a problem connecting to the server "".

You do not have permission to access this server.


Anyone else having this problem? 

OS X Mavericks (10.9)
  • Pascal Laplante Level 2 Level 2 (150 points)



    I have the same problem.  With Mountain Lion I was connecting to Windows 2008 R2 share without any problem.

    Now I doesn't work after upgrading to Maverick.


    My credential is an administrator so I have all rights on the share.

    I tried 3 differents Windows Server without any success.


    I tried to delete the "saved" password in Keychain, but it wont change anything.


    I tried to log with DOMAIN\username instead of just username without any luck.


    The Windows Event Viewer (secure log) looks fine, no credential error found.


    In OS X console I see this message every time I try to connect :



    2013-10-22 20:36:32,138 NetAuthSysAgent[4648]: smb_mount: mount failed to, syserr = Authentication error


    2013-10-22 20:37:07,000 kernel[0]: smb2fs_smb_cmpd_query: Second close failed 9

  • kendemaria Level 1 Level 1 (0 points)

    I've narrowed this down connections to Windows Server 2008, prior to R2.  I can connect to freenas, 2008 R2 shares, other macintoshes, but not Server 2008.

  • titust Level 1 Level 1 (0 points)

    I have the same problem, I have NAS that I connect to through smb, it was working 5 minutes before the upgrade, not working after. . .  This is ridiculous. Hey Apple you are doing nice things but this is ugly. Common Apple you are not Microsoft

  • Reinfire Level 1 Level 1 (20 points)

    It appears that the new SMB2 implemenation has compatibility problems with a number of NAS storage systems out there.  I've written a quick workaround that defaults you back down to SMB1 which may resolve the connectivity issue for you.  Please try it out and let me know.


  • MegaAnt Level 1 Level 1 (0 points)

    I have the same problem, but connecting to Server 2012. When I try to access smb shares it crashes the network connections to Server 2012 and I can no longer remote access the server. I will try the work around Reinfire suggeted and report back.

  • MegaAnt Level 1 Level 1 (0 points)

    Using fixed the problem by forcing the connction to SMBv1.

  • Greyeye77 Level 1 Level 1 (0 points)

    just to add to the problem

    I have shared folder on my win8 PC.

    i got no problem connecting to it, but without disabling SMB2, I am not unable to browse to JUNCTION (sym links)


    apple may need fix this ?!

  • Pascal Laplante Level 2 Level 2 (150 points)

    I have some news based on new tests.


    Still on the same Windows 2008 R2 server, I noticed that the connection to SMB share actually worked when I am on the same subnet.


    Previous tests was made across VPN (OpenVPN) and it failed.


    Maybe this is a VPN issue or more likely some kind of SMB2 bug with share accross 2 subnets.


    I'll try to do more tests (without involving VPN) across 2 subnets to see if it's the bug...

  • Troy Sturgill Level 1 Level 1 (0 points)

    Reinfire's workaround solved the problem for me.  Many thanks to you, sir. 

  • kendemaria Level 1 Level 1 (0 points)

    I just discovered that I can mount any smb share I want using the CLI. 



  • j0sh1130 Level 1 Level 1 (0 points)

    I have been searching high and low since yesterday afternoon for an answer to this.  My problem is not connecting to an SMB share (well, it was, as the old Cmd+K to connect to the SMB share would close quickly) but instead of the old Mac way of using Cmd+K and the IP address, I simply clicked on the available NAS SMB share under Shared and it is a massively fast connection.  The old SMB connection would take minutes to open the next folder. So, connecting as you would under Windows helped fix that problem, BUT...


    1.  The NAS SMB share times out regularly and you have to eject & reconnect.  Annoying.

    2.  Worse than this is I can not open any documents on the share, only navigate it.  I have to copy paste the documents to my local ssd, manipulate, copy back.  Any new file I copy on, or edit and copy on, the NAS SMB share I can navigate to and open.  But if I try to click a pre-Mavericks existing file, I get "Can not open 'excel/word/' with the -36" error.  Total BS. 

    3.  Even more weird, if I click spacebar on ANY file on the SMB Share it will pop up in preview.  Double click to open and error message.

    4.  If I copy a document attached to an email (Outlook 2011) to the server it is corrupt.  If I copy the file to local ssd, then to the NAS SMB, the same file works perfectly fine. 


    This is completely ridiculous and needs a fix immediately.  I'm going to try using Reinfire's link right now and see if that helps. 


    My NAS is a Netgear ReadyNAS 516 (linux/unix OS) I use in my office.  Computer is MBPr March 2013.    

  • NHC2365 Level 1 Level 1 (20 points)

    Yep I've had this problem connecting to our SMB and https shares on our SBS2008 server since the first beta. I have logged a bug in the devloper portal and they have asked me to run several tests. The latest version seems to work a little better allowing me to connect to both resources, albiet for a few minutes before crashing finder completey, requiring a system restart. Also my connection to the server via Outlook drops out and can be rectified by restart the network coonnection, whether it be WiFi or Ethernet. This is 100% reporducable and I have no problems what so ever with 10.8 as I have been going back to it when Mavericks annoys me too much.

  • NHC2365 Level 1 Level 1 (20 points)

    Hi Reinfire will this wordaround also fix the https:// share connection and force SMB1?

  • NHC2365 Level 1 Level 1 (20 points)

    Just tried the workaround. Back to the other problem again...I can connect to the SMB shares on the SBS2008 box now. However when I'm connected I can no longer access the Intranet which is also hosted on the same box. It is hosted on https:// port 987. I cant access it via any browser or trying to mount it.


    Restarted and now can connect to everything, though it was very slow to connect to the https share and the Intranet took a few mintues before I got access. Will see how it goes. Thanks for the tip!


    Message was edited by: NHC2365

Previous 1 2 3 Next