Previous 1 2 3 Next 113 Replies Latest reply: Mar 5, 2015 1:11 PM by InspiredLife
jmfinn9 Level 1 Level 1

After upgrading to Mavericks, my smart mailboxes' unread counts are all wrong. I've tried restarting mail and rebuilding mailboxes and recreating the smart mailboxes, but still they are wrong.


Mail, OS X Mavericks (10.9)
  • MikeNBD Level 1 Level 1

    Smart mailboxes aren't working in Mavericks for me either (using Mail with a GMail account).  My smart mailboxes are set to show emails in mailbox X, and "not in mailbox" Y, but all of the emails I've excluded are appearing in the smart mailbox.  So the count is wrong, and the filters are wrong.

  • mrtimp Level 1 Level 1

    I can confirm that I'm having the exact same issue.  Doesn't seem to matter what smart mailbox setup I use.

     

    I have also disabled all plugins for what its worth.

  • mrtimp Level 1 Level 1

    I've noticed that the smart mailbox don't filter existing mail but any new email coming in seems to be filtered as expected.

  • Roger.Cavanagh Level 1 Level 1

    Same problem with smart mailboxes and also flags are not recognised. I can't get any smart mailbox to show any content at all.

     

    Only plugin was Mailtags that was disabled automatically by Mail.

  • mrtimp Level 1 Level 1

    If you show/hide a message you can see the smart mailbox counter being updated but as soon as you click on the smart mailbox its empty.  Very, very odd

  • mrtimp Level 1 Level 1

    Off topic but here is a link for Matags:

     

    http://www.indev.ca/Mavericks/prereleases.php

  • Roger.Cavanagh Level 1 Level 1

    Thanks, mrtimp. But I think will hold off trying beta software on top of buggy software.

  • Doc411 Level 1 Level 1

    New mail isn't filtered properly, either, for me.  I have a "Today" smart mailbox, and there's nothing in it, even though when I look in my Inbox, I have new mail.

     

    It was working before I upgraded to Mavericks.

  • tarpus Level 1 Level 1

    All my smart mailboxes are empty after upgrading to Mavericks today. Looking for a solution....         

  • RioMacUser Level 1 Level 1

    Same for me. Tryied to rebuild all mailboxes but problems persists.

  • RioMacUser Level 1 Level 1

    Got from other post the following instructions. After following these steps my problem is solved. Hope this works for all of you:

     

     

    • Quit Mail if it’s open.
    • In ~/Library/Mail/V2/MailData, delete any file that begins with “Envelope Index,” such as Envelope Index or Envelope Index-shm.
    • Your home Library folder is hidden by default. To display it, choose Finder > “Go to Folder” and then enter “~/Library.”
    • Open Mail.
    • Mail creates new Envelope Index files. This process may take a few minutes, depending on how many messages Mail is reindexing.
  • Roger.Cavanagh Level 1 Level 1

    Thanks for the suggestion. Didn't work me.

  • jdstil Level 1 Level 1

    Same here, rules do not work on output (i.e. using the ¨To¨ field). It was never flawless for me, as to make it work, I had to select the Sent folder and then pick Apply Rules on a selection of messages; however, that at least worked and good enough for me. Now it doesn´t work at all anymore. Incoming messages, no problems that I spotted, though.

  • MikeNBD Level 1 Level 1

    I treid this solution, it didn't work for me. I'm pretty sure the problem I'm having with smart mailboxes isn't about including messages, but with rules that exclude.  So my mailboxes that are supposed to have messages from Today, or This Week, or a specific From address include appropriate message, but the smart mailboxes no longer exclude messages.  This is at least how I understand my particular predicament.

Previous 1 2 3 Next