Previous 1 2 3 Next 38 Replies Latest reply: Dec 6, 2013 6:27 AM by Reistad
Pierre1273 Level 1 (0 points)

I bought Aperture in a box et can't upgrade from 3.4.5 to 3.5 on the Mac App Store.

 

Is there any solution ? Thanks.

  • Frank Caggiano Level 7 (25,722 points)

    I was in the same situation, boxed version of Aperture 3.

     

    Late last night Aperture 3.5 showed up for me when I did a Software Update, then afert that it showed in the App Store for the first time.

     

    Have you ried Software Update (apple menu upper left hand corner of the screen,

     

    Screen Shot 2013-10-23 at 08.28.31.png

  • Pierre1273 Level 1 (0 points)

    Thanks. Yes, I upgraded to Mavericks, of course, but Software update doesn't show me available updates. And a I have the samie issue for iLife...

  • léonie Level 10 (91,094 points)

    Have you already upgraded to MacOS Mavericks? If not, upgrade first.

    Then use the -menu "Software Update" item. This should show the update for you on the AppStore, if you signed in with your AppleID.

     

    If the AppStore does not show you the Update,

    • write down Aperture's serial number from the "Aperture > About Aperture" panel.
    • Quit Aperture. Then move Aperture to the Trash, but don't empty the Trash.
    • Now reinstall Aperture from your installation media, and immediately go to the -menu "Software Update" item.

     

    If you no longer have the CD/DVD in the box, downlod the

    (Aperture 3.1 Trial) installer and run that. You will have to disable the security & Privacy setting > General "Allow Apps downloaded from" to be able to run the installer. After installation upgrade immediately from Softwareupdate.

     

    Regards

    Léonie



  • Frank Caggiano Level 7 (25,722 points)

    Not sure why it is working for some and not others. 

     

    If you open the Mac App Store and log in with your Apple ID AND then try running Software Update from the Apple Menu does that make any difference?

     

    You may have to give Apple a call and see what's up. It could just be the backlog with there servers's now. As I wrote this seems to have started working for some last night and as time went on more users were able to see it

     

    regards

  • léonie Level 10 (91,094 points)

    Have you moved your applications from the "Applications" folder? If yes, put them back. Sign into the AppStore with the AppleID that you used, when you originally accepted the iLIfe applications on your computer.

  • Pierre1273 Level 1 (0 points)

    Thanks for your help but I tried what Frank purposed but it didn't work.

    For the procedure described by LeonieDF, would it be too risky to download the trial version 3.5 and to use my serial number ?

  • alwayslookup Level 1 (5 points)

    I had the same issue but the following did the trick in my case.

     

    * Change your system language to English which triggers reboot.

    * Once up with English Language, kick the AppStore and check updates

    * Now you should see free update for all the iwork/ilife programs you burchased in a box before.

    * After completing all the updates, change the language back to the original

     

    Hope this helpls.

  • lars@work Level 1 (5 points)

    Hi, the above solution did solve the problem.

     

    I was suffering from the missing update problem too. A small addition from my side. When you start the App Store the Update for Aperture 3.5 shows us. Then I pressed the Install Button and was prompted for my Apple ID credentials. I entered them but nothing happened. Normally here you would see some kind of progress bar. Then I checked the App Store download folder and saw that there was a growing .pkg file. So I waited a view minutes and then the view in the App Store shows the Aperture 3.5 Update as an installed one. That it.

     

    Great work

  • DrMichi Level 1 (0 points)

    thanks, changing the language really did the trick.

  • jonniefromcavite Level 1 (0 points)

    Thank you for the solution. Now it works.

  • Andrew Jung Level 2 (310 points)

    leonieDF wrote:

     

    You will have to disable the security & Privacy setting > General "Allow Apps downloaded from" to be able to run the installer.


    A little tip about this step, you don't have to change the Securty & Privacy settings to run unsigned applications. You can do it on an Application by Application basis by using this exception workflow.

     

    You just have to right-click on the application in question and select from the contextual menu the Open command, a dialogue window will pop-up with the option of being able to run the un-signed Application without changing your settings.

     

    This way your computer remains at the security level that you want while allowing you to open applications that you know are safe, but just made before developer signage came out.

     

    Cheers, Andrew.

  • Tumulus Level 1 (0 points)

    Changing system language to English helped me upgrading to Aperture 3.5, and on top of that also for iWork apps, where I had also issues. Great help!

  • Vladimirfromsvk Level 1 (0 points)

    Thank You a lot. Works great. Regards Vladimir

  • Stjerne Level 1 (0 points)

    I changed my language from Danish to English and did a reboot.

     

    After the reboot the update showed up, but every time I pressed Update, nothing happened besides I had to type in my password for my account. I did that three times but it did not update.

     

    Then I went back to Danish - and the update was gone.

     

    Any suggestions.

     

    I actually have two boxes of Aperture and I don't know what to do.

Previous 1 2 3 Next