14 Replies Latest reply: Nov 5, 2013 7:51 AM by Haroway
JuergenB Level 1 (0 points)

I upgraded to Mavericks / Keynote 6 yesterday.

 

I have a dual monitor setup on my iMac27, and today when I'm trying to play a keynote presentation, it displays on the wrong monitor.

 

I seem to be unable to switch it to my primary monitor, because the "Presenter Display Options" tab (under preferences) that was present in the previous version is alltogether missing.

 

  • Anyone else have this issue, and a work-around?
  • Where are the "Presenter Display Options"?

 

 

Thanks, JB


iMac (27-inch Mid 2011), Mac OS X (10.5.1)
  • David L. Adams Level 1 (5 points)

    This seems to be the same problem (or at least a related problem) to the one that I reported under the title ''

    Presenter Display Problem''

  • mainman1303 Level 1 (5 points)

    I'm having the same issues.

     

    I have found a bit of a work around, if you move your keynote window to the secondary display and then click play, you get your presenter display on the mbp and outputting to the external display.

     

    Not ideal but it works for now!

     

    I need apple to fix this ASAP as i use this program for professional purporses and cannot have a simple problem like this for corporate events!

  • JuergenB Level 1 (0 points)

    Thanks for the suggestions, folks!

     

    I've also found another part of the work-around to get the presentation to permanently switch to the primary monitor:

     

    1. Enable "Presenter Display", under Keynote / Preferences, then click "Play"
    2. Notice the "Switch Display Icon" in the upper right corner, looks like a "Refresh" icon
    3. Toggle the presenter display until the  presentation appears on the primary monitor
    4. Disable "Presnter Display" under Keynote / Preferences, then save.

     

    I find that this sequence permanently switches the monitor used for the presentation.

     

    JB

  • David L. Adams Level 1 (5 points)

    This worked for me. As you say, this is a bad bug that needs to get fixed fast. The 'work around' works, but does not look very professional if anyone is around while you are setting to and getting started.

     

    Thanks for the tip.

  • JuergenB Level 1 (0 points)

    Agreed, the "Presenter Display Options" Tab in Preferences was a better place to manage these settings from a UX point of view. Perhaps it's just a fixable bug that it's missing.

  • David L. Adams Level 1 (5 points)

    This suggestion did not work for me. For one thing, the 'swap screens' icon is covered up by the primary display and cannot be seen or selected. I did try using the 'x' key shoertcut, which does the same thing. After 20 swap attempts it does not seem that it is going to put anything at all on the external display. Keynote appears not to recognize that there is an external display at all (though every other piece of software does). As mainman1303 suggested above, moving the Keynote window to the external display and then running the presentation works, though it is clumsy.

     

    BTW, I have now tried this with three external monitors/projectors, all with the same result. So it is either something in K6 or in Marvericks, but it doesn't seem to affect any other software that I have tried.

  • macmine Level 1 (0 points)

    Hi everybody,

     

    I think I've found the solution.

     

    After doing what JuergenB has said, don't do step 4. At step 3, you'll find your primary display (where your presenter display is) on the projector, and your presentation on your computer, right?

     

    Then, right click on the Keynote icon in your dock, then choose OPTIONS - ASSIGN TO - Desktop on Display 2.

     

    Viola! Now it's the right way round and you still have Presenter DIsplay on your computer, presentation on the projector.

     

    Try it!

  • mainman1303 Level 1 (5 points)

    After reading what macmine just wrote,

     

    Instead of assigning it to desktop 2, i assigned its to all desktops and made sure presenter display is on in the preferences.

     

    Now it seems to work properly even after opening new presentations!!!

     

    Edit: thanks macmine for the tip!

  • macmine Level 1 (0 points)

    That's right!

     

    Phew- I thought I was stuffed with Keynote acting weird!

  • robfrommusic-it Level 1 (0 points)

    When in presentor mode press X to switch display's !

  • David L. Adams Level 1 (5 points)

    Yes. The 'all desktops' option seems to solve the problem. In a new presentation the screens came up reversed the first time (presenter display on the projector) but 'x' solved that. When re-launching the screens staryed in the right place.

     

    Still, this is a bad bug that needs to get fixed.

  • Damon4dworld Level 1 (0 points)

    Hi, everyone. 

     

    I, too, have encountered the same problem the first time I fired up Keynote to an external projector.  After trying out all the suggestions posted here, I stumbled upon a simple remedy.

     

    1.  Ensure that the "Enable Presenter Display" checkbox is ticked under the "Slideshow" preferences tab of Keynote.  I believe this is enabled by default.

    2.  Then right click the "Keynote" icon at the dock, and under "Options," assign to "None" or "All Desktops."

     

    I found that this enabled Keynote to present my slides in the exact same way as the previous Keynote version did.  Whether assigning it to "None" or "All Desktops" makes any difference or not, I cannot tell, but both options work. I hope this helps. 

  • davemurphy Level 1 (0 points)

    hi folks,

     

    I think this is the correct and simpler solution to the problem:

     

     

    https://discussions.apple.com/message/23663657#23663657

     

    rgds Dave

  • Haroway Level 1 (0 points)

    All Desktops seems to work fine !

    (That was a hard trick dude!)