Previous 1 2 Next 29 Replies Latest reply: Mar 22, 2014 12:43 AM by avaluk
ruben10 Level 1 Level 1 (0 points)

Seem to be running into an issue using iMovie v10 post-upgrade...

 

I run iMovie v9.0.9 with many projects and events on several external (multi-TB) hard drives. They would not fit on my primary HD due to sheer file size.

 

I was able to upgrade to v10, but when I tried to convert my existing iMovie library, my primary HD suddenly got a disk out of space error. It appears that the library conversion process is consolidating project and event files from the external drives onto the primary drive. Is this to be expected? Are external drives still supported with iMovie v10?

 

Not sure the best way to proceed, other than to continue using the old library and iMovie v9.0.9 (which thankfully still works) and try to descipher what files to delete from my now-full primary drive.


OS X Mavericks (10.9), iMovie v10 (2013)
  • Builder1 Level 1 Level 1 (0 points)

    I too have an issue. I cannot even get my movies from my external drive to show up in iMovie. My movies that were on the computer hd showed up at first then iMovie said it needed to optimize videos now no videos are showing internal or external...

  • Builder1 Level 1 Level 1 (0 points)

    Basically my entire library is empty. It shows a file for today's date under iMovie Libraries but it is empty since I have not loaded any movies today. Everything else is gone. I can find the old files in finder but I don't think it seems right to have to manually import them all back to imovie. The biggest issue is that it is not seeing my external drives at all.... which is where most of my home movies are stored. I literally have terabits of home movies I cannot access.

    Screen Shot 2013-10-24 at 1.34.26 PM.png

  • Ian Sinclair Level 1 Level 1 (0 points)

    Likewise. I was afraid there might be a problem when they let Sarah Palin name the new OS.

     

    I have a 500 GB hard drive that had 100 GB free space before "10.9 Mavericks." Now the disk is full. The iMovie Library on my internal HD is 106.1 GB, and "iMovie Theater.theater" (sic) that is 90.3 GB. The computer is now slower than slow. Also, events that were organized under the names of the Hard Drive that contained them, are now simply called iMovie Library 1, iMovie Library 2, iMovie Library 3, iMovie Library 4, iMovie Library 5, etc.


    I had to use my finder and re-name the libraries to indicate the name and size of each HD. in the new iMovie interface.


    I copied the events from the internal iMovie library to an external library now called "iMovie Library July2013-3TB" and then moved the events to trash. But the events did not appear in trash, and cannot be emptied. So, the HD is still full.

     

    It seems that the new iMove just wants to fill any available HD space with iMovie Theater (sic) whatever that is. I can't realy explore the new OS until I deal with the HD issue. Fortunately, iMovie 9 is still there, so I can go back to using it. I wll try to drage the iMovie library to an external drive and delete the iMovie Library, iMovie Theatre.theatre, and go back to using iMovie 9. I may never open iMovie 10 again, since the mere act of opening it preceeds the destruction of disk space. 

  • martinfromrainham Level 1 Level 1 (0 points)

    I am also among the many faced with this dilemma, come on Apple please sort it out!

  • coachgarrett Level 1 Level 1 (0 points)

    It recognizes my video camera...but it will not let me download any video.  I have reloaded 9.0.9 and it works perfectly. 

  • Aussiefoto Level 1 Level 1 (0 points)

    This is awful .. anyone have any simple solution? Do I just delete the .imovielibrary folder and go back imovie 09? I just deleted over 60gb of photos off my iMac HD to make space, and it's simply filling up again with this iMovie thing. I had several hundred GB of space available before this nonsense started, and all the iMovie events etc were on an  external HD. This is a pita.

     

    Thanks in advance.

     

    Cheers

     

    Carl

  • Hippotech Level 1 Level 1 (25 points)

    I had the same issue. For me I fixed it with File / Open Library / New and created a library on the same drive as the drive where the media is stored.

     

    I had 300Gb of old home movie clips on this particular drive and it upgraded them making the iMovie Library also 300Gb but total free space seemed close to unchanged ( maybe 10 Gb different ). I'm assuming all the files in the library are now linked as it is on the same drive.

     

    Having said all that, I'm not convinced and am sticking with the old version for now.

     

    Hippo

  • br121 Level 1 Level 1 (20 points)

    I have the same problem. The iMovie upgrade is not really an upgrade. It's an entirely new program, with incompatible movie files. Bad luck if you also use FinalCut Pro and automatically import video files into iPhoto as well. How many copies of our video files do we need?

     

    I have multiple external hard drives full of video files. Now I will need to go out and buy an entire library of external drives to make copies of absolutely everything. This will cost the same as a new computer. Madness.

  • Ian Sinclair Level 1 Level 1 (0 points)

    After much stress and frustration that reminded me of the dark ages spent on Windows OS,  I decided that the most trustworthy solution was restore my computer from Time Machine. I'm back on OS 10.8.5, using "iMovie 11 version 9.0.9". Aside from loosing 2 days of work, (1 for the install and hair pulling, and another for the restoration) I am happy as a clam. I may just stick with 10.8.5 as long as I have this computer.

  • Builder1 Level 1 Level 1 (0 points)

    I was able to force iMovie to open my old iMovie files from my external drive by cliking on the external drive desktop icon to view the files. click on the file "iMovie Library", it forces imovie to open and like magic, all the files on the ext drive were listed in iMovie, ready to go! There must be an easier way but this seems to work for now.

  • Tactos Level 1 Level 1 (5 points)

    to resolve do this go to

    in the folders of imovie 9 (eventes of imovie, imovie projects, etc)

    there is a file with the name "UpdatedToiMovie10", delete that file and go to

    Imovie -> file-> upadte projets and events.

    P.S- It take some time you have to wait, DON´T STOP THE IMOVIE.

  • Ian Sinclair Level 1 Level 1 (0 points)

    How does this resolve this? What happens to all the other imovie projects and events on the external hard drives?

  • Tactos Level 1 Level 1 (5 points)

    just delete that file -> UpdatedToiMovie10"

    after you delete just that file the imovie detect the projects and events on the external hard drive.

  • SiriusStargazer Level 1 Level 1 (20 points)

    What I have found so far is that iMovie 10 creates a duplicate set of events coverted from iMovie 9 events in order to be compatible with iMovie 10.  I had v9 events on the primary drive as well as on an external drive.  The v9 events folders were duplicated and renamed iMovie Library (on the primary drive) and iMovie Library 1 (on the external drive).  This duplication process utilized what remaining free space I had on my primary drive and external drive.  Fortunaley I had just enough space to spare.  Unfortunately not enough space to continue with Time Machine backup on my external drive.

     

    The decision now is whether or not to remove iMovie 9 and the related "iMovie Events" folders in order to recover the space to support Time Machine backup.

     

    Both primary drive and external drive iMovie Library events show up perfectly in v10.

     

    Maybe some individuals have run into issues if they did not have adequate space for the conversion/duplication process on either their primary drive, external drive or both.

Previous 1 2 Next