Previous 1 2 3 Next 42 Replies Latest reply: Apr 16, 2015 7:20 PM by Van-D Go to original post
  • opmc78 Level 1 Level 1 (0 points)

    Thank you William Kucharski - worked a charm!

  • funcritic Level 1 Level 1 (0 points)

    Worked like a dream.  Flagged messages said I had 5 but there were only 2.  Did as William Kucharski advised, plus rebooted before going into mail, and all the phantom messages had gone and I was left with the 2 that I wanted.  Thank you William!

  • bastings Level 1 Level 1 (0 points)

    I updated to mavericks last night and now i had 11 marked e-mails. But when going to that mailbox "marked e-mails" it was empty.

    I just did what you advice and that helps!

    Thanks!

  • H-Dog Level 1 Level 1 (70 points)

    I continued to see this issue in Yosemite with a smart mailbox showing 2 unread messages even when no other mailbox showed unread items. The solution was embarassingly simple and obvious, hopefully helps others who are still seeing this:

     

    1) Create new Smart Mailbox

         - name "All Unread"

         - match "All" conditions

         - "Message is Unread" as only condition

         - check boxes to include form Trash and Sent

    2) Select all messages inside new "All Unread" mailbox

         - Note: for me, all of these were marked as unread

    3) Mark all selected messages as "Unread"

    4) Mark all selected messages as "Read"

     

    Doing this quickly and simply solved my problem. I didn't dig into it, but I assume the multiple databases tracking unread message counts got misaligned - this process brings them all into sync.

  • John Armbruster Level 1 Level 1 (50 points)

    Just wanted to add that I have this same problem in Yosemite.

  • WarrenO Level 1 Level 1 (10 points)

    Running 10.10 (Yosemite), same problem - William's advice worked.

     

    This doesn't destroy any mail data; it just updates the databases.

  • philipfifibachinger Level 1 Level 1 (0 points)

    Easiest way:

     

    1. In Spotlight Search

    2. Search "Spotlight"

    3. open Spotlight System Preferences Menu

    4. Privacy Tab

    5. + Add Macintosh HD

    6. - Remove Macintosh HD

    7. done

    8. just Wait till Flag Database is rebuilt

    9. actually done

     

    Flagged Mails in Smart Folders disappear for some time, rebuilding might take up to a few hours.

  • jnew84 Level 1 Level 1 (0 points)

    philipfifibachinger's suggestion is BY FAR the easiest way to fix the problem of flags not going away. I've had this problem several times now and have found that to be the easiest fix every time.

     

    A couple notes about his post though:

     

    1. Your spotlight system preferences may not appear in your spotlight search. If not, just click on the apple in the upper left corner of your screen, click system preferences, and click on spotlight.

     

    2. Your computer might not be named Macintosh HD. In fact, most people have probably renamed it "John Doe's Macbook Air" or something like that. In any event, add that drive to the privacy list as explained by philip and then remove it a few seconds later.

     

    3. It will take some time for the indexing to be done and for the flagged folders to rebuild. When you start a spotlight search, you'll see a status bar showing how long the indexing has left.

  • 3GShelp Level 1 Level 1 (0 points)

    Using philipfifibachinger's Spotlight derived solution to rebuild didn't work for me unfortunately; I still had the Flagged unread count, despite having no messages showing in the Flagged folder.  After some concern about deleting files from the system along the lines of William Kucharski's  instructions given the various subsequent posts about machines left hanging, I decided to do a full back up and then try William's method.

     

    It worked perfectly for me on Yosemite 10.10.1.  Note for my Mail with c50k messages, the Flagged folder disappeared completely to start with, returning 5 or 10 minutes later.  My heart sank, but as suggested the folder now actually contained the Flagged messages which I could then deal with.  Many thanks William Kucharski.

  • dfoi Level 1 Level 1 (5 points)

    Add my name to the list....the suggested fix by William Kucharski worked like a charm.

    My thanks for your assistance. Reimporting the mail took a few minutes ....not a problem.

  • ianmchenry Level 1 Level 1 (0 points)

    But it deleted all but 1 of my Flags....

     

    apologies, that database was just rebuilding - all back now

  • frayjoal Level 1 Level 1 (0 points)

    This fix also worked for me (Macbook Air running OS X Yosemite).  Had 98 phantom flagged mails.  Now clean as a whistle.

    Steps taken:

    1.  Removed Gmail account.

    2.  Applied fix.

    3.  Added gmail account after.

     

    Thanks man!

  • Van-D Level 1 Level 1 (5 points)

    Many thanks for helping with this vexatious problem.

Previous 1 2 3 Next