13 Replies Latest reply: Oct 27, 2015 10:47 AM by 99Lu
ellephillipsdesign Level 1 (0 points)

I installed the new OS X Mavericks upgrade this morning, and now when opening documents via my Adobe programs, I'm getting "fonts missing" errors. When I scroll through my list I notice that quite a few were affected and are now missing from the list... these are common fonts such as AvantGarde and Myriad Pro Black. Is there a way to get them back to working? As a designer working on client files without the ability to replace the affected fonts, this is a huge hinderance.

Mac Pro, OS X Mavericks (10.9)
  • bigj6360 Level 1 (15 points)

    Same problem here...

  • zotsf Level 1 (0 points)

    I noticed this too and can't install fonts.

  • bigj6360 Level 1 (15 points)

    I don't know, but I just went into Fontbook. I was able to see all my fonts that were listed as missing. I reopened Photoshop and it nolonger complains...


    Fontbook did say I had duplicates. I told it to resolve manually.


    Hope yours gets fixed.

  • Fudge4u Level 1 (0 points)

    I upgraded to Mavericks and I was unable to install fonts (primarily being the Postscript fonts with separate suitcase files).  Here are 2 options that worked for me:


    Solution #1 ($99): Purchase a font converter program (Such as FontXChange) and convert all your fonts to Open Type.  I was able to add those to my FontBook without problem.  I tried it with the free demo to see if it would work, but you have to purchase the license for $99 to use it, as it randomly puts letters upside-down in the demo mode.  But the demo mode will verify if that solution will work for you.


    Solution #2 (Free):  Add the font through FontBook (I added the font/font family in the "all fonts" collection.)  At this point, the font may not show up in FontBook.  If it shows up, then you can probably use it.  If it does not show up, then go to your finder level and find the original font files for the font or the font family and copy them to the ~library/fonts folder.  If you get a dialogue asking if you want to replace duplicate  files, I clicked "allow".  If you added the fonts in FontBook to the User collection, then you have to add them to ~user/library/fonts.  Once I did that, the font showed up in FontBook, as well as automatically updating the list in InDesign.


    NOTE: It did not work for me to just add the font files to the ~library/fonts folder, I had to try to add it in FontBook first.  Probably has to do with some kind of pointer or something.


    If your library folder does not show up, check out: http://www.macworld.com/article/2057221/how-to-view-the-library-folder-in-maveri cks.html


    Hope that helps someone with the Mavericks font issue. 

  • Lump Apps Level 1 (0 points)

    Thank you so much Fudge4u!


    This is the way Apple looses its fanbase. Another hour down the drain. When will they start building good stuff again instead of stealing designs from the other ones. Sorry to post this here but it is really getting frustrating.

  • J Crash Level 1 (15 points)

    This solved my problem, thanks Fudge4U (great name BTW). One small thing I'd like to add is don't forget to purge image cache if you are trying it out in a project that already used those fonts (mine files were transfered from my old computer). I was working in After Effect and my type was flashing between fonts and basically freaking out (even after Font Book finally recoginzed my fonts). A quick purge cache did the trick and all is well.

  • gjohung Level 1 (0 points)

    Thank you.  When I first upgraded to Maverick - purchasing a new iMac from MacPro, and used Migration Method to transfer apps and settings, Lot of my fonts were missing, Looks like OSX store fonts in 2 places... Users/LIb and System/Lib. 


    I get confused which Font folder my Adobe Suites looks at.  I may have multilple Font Folder because I have Active Directory log in issue and had to create multiple profile. But that is another story.....


    I learned through trial and error..Fudge4U's #2 method.  Not knowing why it works. But even that method is NOT stable. Known good Adobe Project File will all of sudden get Missing Font error. When you try to validiate the font within Font Book, it does gove me an error..  It is old Font Suitcase file (time stamp 2001)


    I got to work today by doing #2 method "again" but there is no guarantee it wil work tomorrow..


    Will FontXChange resolve my problem? I do have to get approval from upper management for spending $100. They have little understanding of how OSX/Mac works..



  • shadowweep Level 1 (0 points)

    Thank you Fudge4u
    This issue has been greatly affecting my workflow on projects that use a number of different fonts and the latter workaround you mentioned did the trick.


    I also point out that the new Font Book in Mavericks does not like the erroneous fonts installed on the system, So it's best to select all fonts, Validate them then manually remove all the fonts marked 'Error' once this was done most of the fonts I needed were recovered in the programs I use save for two which fell in to the error category.


    One of many Graphic designers out there who upgraded to Mavericks now giving a sigh of relief..
    Thanks again.

  • userremoved Level 1 (5 points)

    With Adobe CC and Mavericks I am having serious font and permissions issues that keep cropping up. Like you, I have spent hours trying to solve these problems which I don't get paid for. The font issue is the worst. Do you have CC? I think there is some kind of conflict with Adobe CC and how fonts are handled in applications and Mavericks as well.

  • Michaelblast Level 1 (0 points)

    These font issues remind me of the Mac in the late 80's. Then with later OS upgrades they were eliminated.  Now the font frustrations are back, along with lost, highly-valued functions in Pages and Keynote ... what is wrong Apple???  Who's minding the store?

  • Kurt Lang Level 8 (36,160 points)

    This happens frequently to Font Book when upgrading one OS over another. The problem isn't the fonts and there's no need to convert them to any other format. Being unable to open or close fonts from within Font Book's interface is almost always a sign its database is damaged. The fix is to clear it and start over.


    Restart your Mac and immediately hold down the Shift key when you hear the startup chime to boot into Safe Mode. Keep holding the Shift key until you see a progress bar towards the bottom of the screen. You can let go of the Shift key at that point. Yosemite is a bit different. Whether it's a Safe Mode boot or a normal one, you get the same progress bar. It just takes longer to get to the desktop in Safe Mode. So hold the Shift key until you get to the desktop.


    OS X asks you to log in (you will get this screen on a Safe Mode boot even if your Mac is set to automatically log in). Let the Mac finish booting to the desktop and then restart normally. This will clear Font Book's database and the cache files of the user account you logged into in Safe Mode.


    When you launch Font Book, it will create a new database.

  • madjennifer Level 1 (0 points)

    Put your fonts here:

    Windows: Program Files/Common Files/Adobe/Fonts

    Mac OS: Library/Application Support/Adobe/Fonts

  • 99Lu Level 1 (0 points)

    Thank You!!! This was driving me crazy.