Previous 1 3 4 5 6 7 Next 124 Replies Latest reply: Mar 28, 2014 2:57 AM by Csound1 Go to original post Branched to a new discussion.
  • isistrex Level 1 Level 1 (0 points)

    Yes, I am noticing this too: "Apply rules' doesn't work any longer run explicetely on messages, it seems like rules are applied only at the moment of the arrival of new messages." There are lots of other Mail bugs too. I can't type an address into the To window the same... I mean wow!

  • DCIFRTHS Level 1 Level 1 (20 points)

    Oregon Ducky wrote:


    I've been having issues too. To add to what others have offered, when you go to create a new rule, and are asked whether or not you want to apply the rule, it doesn't do it. This is apart and separate from the Sent Mail issue point out above. This is new rule, on inbound mail, and trying to apply it after the mail is already in the inbox. It doesn't work as it should.


    I am having the same problem. I spent a lot of time trying to figure out why this was happening

  • slothinker Level 1 Level 1 (0 points)

    Ditto ... in my experience the Rules don't seem to work as advertised at the moment.


    I tried to write a rule which would move obviously unwanted spam (i.e. 'enlargement') into a separate folder which I could simply keep around in case some ham mail had a word which caused it to be caught up with the unwanted group.


    Unfortunately, whether I use Move or Copy, the mail seems to stay in the Bulk mail folder. If I do Copy, then Delete it deletes the identified set of new email from the new folder (where it was just copied to), rather than the Bulk folder.


    Just recently I started getting 20-40 of these unwanted and unsolicited emails a day. They do go into the Junk folder but it's still an unwanted chore to have to go in and review the list before deleting as something I wanted/needed to see might have ended up in Bulk.

  • SteveBird Level 1 Level 1 (0 points)

    In fact, the rules CAN be applied to sent messages in 10.9.


    I have a rule that says:

      If TO or FROM contains

         Play sound "Glass"

         Move message to mailbox "ZZZ"

         Stop evaluating rules.



    If I apply that rule to a SENT message (as I have been doing for years), it plays the sound, but it does NOT move the message.


    It's only the MOVE MESSAGE part that is broken.

  • nanfromencinitas Level 1 Level 1 (0 points)

    Please add my name to the list of people whose had long time rules stop working when I upgraded to Maverick.   Some still work, others do not and I can't see anything  about either one that would determine which do/which don't and why.


    Since I get several hundred a day, its maddening not to have messages filtered automatically according to the rules I set up..

  • dielenator Level 1 Level 1 (0 points)

    Same here. Rules stopped working when I upgraded to Mavericks. Can someone at Apple please fix this problem. Thanks.

  • Laura in CA Level 1 Level 1 (0 points)

    On my old MacBook, the Rules worked great on Sent messages and it was very helpful to have all the messages together, whether I wrote it or someone else. Any resolution? Will Apple correct this in an update?

  • SteveBird Level 1 Level 1 (0 points)

    More info: I have some rules that say:

       If ToOrFrom contains "Joe"

           move message to "Joe's folder"

           Play sound "Glass"

           Run Applescript "Speak Name of Sender".



    --- In this case, if you apply the rule to incoming mail, it does the MOVE and the PLAY SOUND, but NOT the RUN SCRIPT.

    If you apply the rule to a message in the INBOX, or the SENT MAIL (or anywhere else), it does the PLAY SOUND, but NOT the move and NOT the RUN SCRIPT. 


    All these worked fine before 10.9

  • Is there a vet in the house? Level 1 Level 1 (145 points)

    There's no sign of a fix so I suggest all of us submit a bug report here:


  • Yvesfb Level 1 Level 1 (0 points)

    After problems with mail rules... I was happy to see yesterday (16 Dec 2013) the update of the mail system for the MAC Book Pro 13 and 15" retina (gmail account problem, problem with rules not moving files any more etc.)

    I just applied the update:

    - still the same problem with the rules (which are not moving email to junk mail; I need to copy the mail to the junk folder and then to delete the mail from the inbox).


    and something strange: I have seen all my flags on emails being erased by groups...; and only after posting this message and searching on forums, when I went back to mail, all the flags were back...


    (this was posted just for info here before you run to get the update!!!
    I started a similar thread in another place as it is a new problem:




    N.B.: I edited that post to correct as flags went back. In my original post the sentence on "and something strange..." was in originally: "but WORSE: all the flags on my emails have been erased!!!".


    Message was edited by: Yvesfb after flags reappeared - only to keep the info on the strange behaviour of the Mail application

  • mountainbikerbikerforever Level 1 Level 1 (0 points)

    Just FYI as well ... I applied the update yesterday too without any success in fixing the mail rule issue.

  • SteveBird Level 1 Level 1 (0 points)

    The 10.9.1 MAIL update does nothing for me, either.


    Except I did notice this: I used to be able to drag a message from a mailbox to the INBOX.  I did that mostly to test the rules - I would drag it out from where it was supposed to be and apply rules to see if all the rule features were working.


    not only are they NOT working now, but I can't even drag the messages into the INBOX.  It just won't do it.

  • Dr.MORO Level 1 Level 1 (5 points)

    Dumb dumb dumb...

    If I only knew about the "Rule" curse...

    Just 'thought' that it was time to upgrade to Mavericks from ML, as a new update mainly on 'Mail' was out.

    Total disaster...


    The Rules only moves new incoming mail.

    All read mails on server are not moved at all.

    The 50+ rules I have created over the years on just all useless...


    Come On, Apple!!!


    Such a basic feature, and many are still unhappy about it not working properly!

    Fix it immediately!

  • terriergal Level 1 Level 1 (5 points)

    Same here.  Nothing's changed.  Well, ONE of my rules worked better today but only after I manually applied it.  I also had mail lock up entirely right ater the update and had to force quit it.  This is getting ridiculous.


    Dr MORO, whatever you do don't erase your rules and start over.   I did that and then NONE of them worked.  Now I have just a couple that work.  Sometimes.

  • Dr.MORO Level 1 Level 1 (5 points)

    Thanks, terriergal!


    I will NOT erase my rules.

    Really hopng Apple fixes this bsic feature, and this time the right way!


    Anyways, I also wish that the Rules where Exportable/Importable in an universal way. Great for backups, sharing between your own Macs, as each Mac you would have to rewrite all your rules.

    OR, are the rules saved in a format somewhere that users can see as plain text? Anyone?

Previous 1 3 4 5 6 7 Next