Previous 1 2 Next 24 Replies Latest reply: Oct 21, 2014 10:25 AM by Cyril2000
jinet Level 1 Level 1 (0 points)

Canon's site says that the CanoScan Lide 90 is not compatible with 10.9. Has anyone found a way to get it to work? thanks

iMac (27-inch, Late 2012), OS X Mavericks (10.9)
  • David Dellinger Level 2 Level 2 (165 points)



    I was about to let you know that the CanoScan LiDE 90 does not work in OS X 10.9 Maverics, but now I can verify that the CanoScan LiDE 90 scanner does work, at least somewhat, with OS X 10.9 Mavericks.


    I upgraded to 10.9 Mavericks the day after it was released, but could scan using my CanoScan LiDE 90 scanner using VueScan v. 9.3.17, the scanner program that I have exclusively used with this scanner for the last several years.


    I reinstalled the drivers which are meant for 10.5-10.8 (LiDE 90 Scanner Driver Ver. 13.9.2a), but the scanner still did not scan using VueScan.


    I then tried Apple's Image Capture, but it still didn't scan.


    In the process of writing this post about how the scanner does not work in 10.9, I tried MP Navigator EX 1.0.7, the latest version of Canon's own scanner program, which I had installed some months ago.  I almost never use this scanner, but MP Navigator was able to scan from my LiDE 90!  It scans whether I chose "Use Scanner Driver" or not.


    Even after I scanned a few documents using MP Navigator EX, I was not able to use VueScan - it claims that there is no scanner, so it appears that there may just be an issue with VueScan, I am not sure.


    I hope that helps!

    Hopefully Canon will release updated drivers that are completely verified for 10.9.  In the meantime, it appears that MP Navigator EX works.



  • ettore_from_milano Level 1 Level 1 (0 points)

    Thank you David, your advice solved the matter, but also let's hope Canon drivers are on our way soon.



  • Russell Alman Level 1 Level 1 (15 points)

    Confirmed.  Apple System Report shows my LIDE 90 as an "unknown device."


    Well that's frustrating :/

  • jinet Level 1 Level 1 (0 points)

    Thanks David. I too am a Vuescan junkie. Whether it's up to Canon or Vuescan, I'd hate to junk my scanner, which still works fine, or rather did until 10.9.

  • Russell Alman Level 1 Level 1 (15 points)

    Also confirmed that reinstalling the MP Navigator software works as a workaround.  Importing into Photoshop also works using the scanner driver.

  • Dan White Level 6 Level 6 (9,425 points)


    My 10.9 iMac shows it as a Canon scanner:




      Product ID:          0x1900

      Vendor ID:          0x04a9  (Canon Inc.)

      Version:           3.07

      Speed:          Up to 480 Mb/sec

      Manufacturer:          Canon

      Location ID:          0xfd142000 / 6

      Current Available (mA):          500

      Current Required (mA):          500


    MP Navigator EX 1.0.7 does (sorta/kinda) work, but the buttons on the front of the scanner do not want to function now. 

  • David Dellinger Level 2 Level 2 (165 points)

    You are welcome, Jinet.  I've been using VueScan for several years.  Hopefully all of this will be sorted out soon.  It's only been a few days since Mavericks was released, so there's still hope.


  • David Dellinger Level 2 Level 2 (165 points)

    Russell, my 10.9 Mac Mini also shows it as a Canon scanner:




      Product ID:          0x1900

      Vendor ID:          0x04a9  (Canon Inc.)

      Version:           3.07

      Speed:          Up to 480 Mb/sec

      Manufacturer:          Canon

      Location ID:          0x26200000 / 2

      Current Available (mA):          500

      Current Required (mA):          500


    Thanks for pointing out that it works with Photoshop.  I only have Photoshop at work, but my scanner is at home, so I could not test that.


    Dan, hopefully the driver will be updated to fully support Mac OS X 10.9 Mavericks.  My in-laws use another CanoScan model, and were heavy users of the buttons on the front.  Every so often with system updates, the buttons stopped working, then started working again.  I could never keep them working consistently, but they finally got used to using the menu instead of the buttons.



  • c warren Level 1 Level 1 (0 points)

    I can't speak to the LIDE driver, but installing Mavericks "broke" my Canon MG6120 MFP scanner and my Epson Artisan 810 plug-ins in Photoshop Elements 10.  I was able to use Image Capture successfully with both, and I could also access and work the limited scan functions via the "Printers and Scanners" System Preferences - but I normally scan into Photoshop Elements.


    Both printers functioned fine as printers after the Mavericks install; it is only the scanner integration with Photoshop that was a problem.  The Canon MFP did not show in the Photoshop Import options at all; and while the Epson MFP shows, it does not work there.


    I was able to get the Mavericks-compatible scanner driver (with a TWAIN plug-in for Photoshop) for the MFP from the Canon site; after downloading and installing it, the Canon scanner once again showed in Photoshop Elements' Import function.  The driver for that particular scanner  can be downloaded at eries/pixma_mg6120#DriversAndSoftware


    I am prettys sure the drivers are there for most Canon MFPs and dedicated scanners as well.  Get to the page for your particular scanner or MFP by entering the matrix here:


    One can also download the ICA and CUPS drivers from the support page.  Having done that, Photoshop now once again shows the Canon scanner.


    No luck so far for the Artisan 810.  Epson says new drivers should be out "in a few days."


    None of my efforts to get newer drivers via Software Update worked - including having trashed the two Epson printer files and trying again to download from Software udate, as suggested elsewhere in these forums.

  • Russell Alman Level 1 Level 1 (15 points)

    Prior to 10.9, I was able to run my LIDE 90 through Image Capture.


    Mine is now at least showing as a Canon scanner.  Before I reinstalled the Canon software, it was showing as an unknown device.  This scanner was preinstalled under 10.6 - 10.8

  • William Donelson Level 4 Level 4 (2,495 points)

    Epson XP-600 scanner here. The TWAIN that Espon recommend does nothing for Photoshop CS6.

  • bastienvans Level 1 Level 1 (0 points)

    I tried installing MP Navigator EX but it won't open. The icon pops up for 1/1000 of a second in the dock and closes. Running 10.9.

  • David Dellinger Level 2 Level 2 (165 points)



    Did you try to install version 1.0.7 of MP Navigator EX?  I downloaded a new copy from Canon's website.  I had to select the version from Mac OS X 10.8.



  • JIP-1 Level 1 Level 1 (105 points)

    The latest version of Vuescan solves the problem: 9.3.21. Works like a charm.

Previous 1 2 Next