Previous 1 2 3 Next 41 Replies Latest reply: Feb 20, 2015 2:46 PM by SBeattie2
SBeattie2 Level 2 Level 2
expertise.serversenterprise
Servers Enterprise

After upgrading to OS X Mavericks - I no longer see the "show as busy/free" option when adding, viewing or editing an event.  This option is available on the calendar in iOS 7 and appears to work there - but when I add a new appointment via calendar in Mavericks - there is no longer an option to specify show time as busy or free - and when I view the event/appointment in iOS 7 - the event shows the time as "free".  Did this setting go away in Mavericks?


MacBook Pro, OS X Mountain Lion (10.8.2), 15"
Reply by Bryan Schramm on Oct 31, 2013 12:12 PM Helpful

Double-click on the date/time in the inspector view and you'll see these options.Meeting.jpg

Reply by SBeattie2 on Oct 31, 2013 11:19 PM Helpful

After digging through calendar help

 

For status (busy/free) - I found the following information:

 

If the Calendar account you’re using displays your status for an event, you can change the status at any time and still be available to meet during an event.

By default, Calendar sets your status as free during all-day events and as busy during all other events.

... This would indicate that not all calendar (accounts) are going to display this status.

 

For private appointments - I found the following information:

If your calendar is administered through a CalDAV or Exchange server (for example, through your workplace), you can make a Calendar event private. Private events can’t be viewed by other users, even if you shared your calendar account with them.

.. This might explain why I don't see the private option.

I'm now wondering if this is also true for the visibility of the busy/free status option?

All replies

  • SForrest Level 1 Level 1

    I'd love to know what happened here as well.  This option is available on iOS as the OP mentioned but missing from Mavericks.

  • SBeattie2 Level 2 Level 2
    expertise.serversenterprise
    Servers Enterprise

    I just logged into iCloud and opened the calendar there.  The busy/free option is also missing in iCloud as well.  The busy/free setting seems to only be available on iOS devices - and does in-fact sync between the devices when the setting is changed.  I am now thinking this is an improved feature vs a bug.  Prior to Mavericks - I was having to switch the busy setting back to "free" whenever I would create an all day appointment.  This was the only time I would ever use the setting.  In Mavericks (and iCloud) - when you create an all-day appointment - the show as setting defaults to free - and when you create a regular appointment - it shows as busy.  This is actually the behavior I want.

     

    I have been googling this all day and so far nobody is mentioning the fact that this setting has disappeared.

     

    ~Scott

  • SForrest Level 1 Level 1

    I also did notice that the busy / free syncs between iOS devices but I would still like to have this option back on the Mac Calendar as I use this feature quite frequently.   For example, we're having work done on the house and the contractor will be here for two half days, I want to mark that time on my calendar but also leave my time as free so now I either have to create the event on my iDevice or create it on my Mac and edit the time to free on my iDevice.  KInd of defeats the whole purpose of having a nice new Calendar app on my Mac!

     

    While I do think the way the app functions now in regard to full day events being free does make sense for perhaps the majority of users it doesn't work for me.

  • SBeattie2 Level 2 Level 2
    expertise.serversenterprise
    Servers Enterprise

    Your point is well taken - and I just ran into this very circumstance myself - where I needed actual events to track something that somebody else is doing - and the "all day" event was not appropriate.  I have submitted feedback on this to Apple - at http://apple.com/feedback - and others may want to do this as well.  I have not gone as far as submitting a bug report - but I may do that in the next day or so.

     

    ~Scott

  • SBeattie2 Level 2 Level 2
    expertise.serversenterprise
    Servers Enterprise

    Just curious if anybody who is reading this - happens to have a new Mac with a clean install of Mavericks to see if this is an upgrade issue - but I doubt that is case - since the same behavior is happening on the iCloud version of Calendar.

     

    ~Scott

  • Bryan Schramm Level 1 Level 1

    Double-click on the date/time in the inspector view and you'll see these options.Meeting.jpg

  • SBeattie2 Level 2 Level 2
    expertise.serversenterprise
    Servers Enterprise

    Bryan - This does not work.  There is no show as Busy or private checkbox when double-clicking on the date/time.

    The only visible new Mavericks feature is the travel time option.  Is your version of Mavericks a clean install - or an upgrade from Mountain Lion?

     

    Screen Shot 2013-10-31 at 6.01.57 PM.png

     

    ~Scott


  • SBeattie2 Level 2 Level 2
    expertise.serversenterprise
    Servers Enterprise

    I also turned on time zone support - hopting that it would make a difference - but it did not.

  • SBeattie2 Level 2 Level 2
    expertise.serversenterprise
    Servers Enterprise

    After digging through calendar help

     

    For status (busy/free) - I found the following information:

     

    If the Calendar account you’re using displays your status for an event, you can change the status at any time and still be available to meet during an event.

    By default, Calendar sets your status as free during all-day events and as busy during all other events.

    ... This would indicate that not all calendar (accounts) are going to display this status.

     

    For private appointments - I found the following information:

    If your calendar is administered through a CalDAV or Exchange server (for example, through your workplace), you can make a Calendar event private. Private events can’t be viewed by other users, even if you shared your calendar account with them.

    .. This might explain why I don't see the private option.

    I'm now wondering if this is also true for the visibility of the busy/free status option?

  • tpaterno1 Level 1 Level 1

    Busy/free is needed but I was also looking to edit the choose to add completed.  Is there a option to mark as completed?

  • Bryan Schramm Level 1 Level 1

    This works on my calendars connected to Microsoft Exchange and Kerio Connect.  I've not tried it on any other solution.

  • SBeattie2 Level 2 Level 2
    expertise.serversenterprise
    Servers Enterprise

    Bryan - I wonder if the fact that you are connecting to an exchange server is what is causing the busy/free to appear.  By any chance can you create an icloud calendar and see if the busy/free option disappears for events on that calendar?

     

    I'm in the process of setting up the calendar functionality on my OS X Server - to see if those calendars will show the busy/free.  It's taking longer than I was expecting.  No results yet.

     

    ~Scott

  • SBeattie2 Level 2 Level 2
    expertise.serversenterprise
    Servers Enterprise

    Here is some additional information:

     

    I added my Google calendar account to the calendar app - and I now see the show as busy/free options whenever I create or view events on the Google calendar.

     

    I also got the calender server working on Mac OS X Server (Mavericks) - and when I add that calendar account to my calendar app - I see the busy/free setting as well as the private checkbox.

     

    I am wondering if Apple has decided to remove the busy/free option from iCloud calendars entirely - and they just haven't removed it yet from iOS 7?

     

    ~Scott

  • Bryan Schramm Level 1 Level 1

    Yes, it appears that Kerio and Exchange are what provide me with the free/busy capability.  When I created an iCloud calendar, those options were not there.

Previous 1 2 3 Next