Previous 1 2 3 4 Next 519 Replies Latest reply: Feb 16, 2015 8:08 AM by Sarah24 Go to original post Branched to a new discussion.
  • globehead Level 1 Level 1 (0 points)

    Same issue here, all was fine before Mavericks upgrade, now WiFi doesn't reconnect automatically after waking from sleep. Non-Mavericks machines on the network are unaffected.

  • rogerfromwil Level 1 Level 1 (0 points)



    Was in contact with Apple Support Chat (amazing support as usual).

    Resetting the System Management Controller solved my WLAN issue:



    Now if my Mac comes back from sleep, WLAN is immediately available and stable, as it was with Mountain Lion. Great!!


    If resetting the SMC does not help, the second option is to reset the PRAM






  • TheGuyintheProjectionBooth Level 2 Level 2 (195 points)

    Have done them both many times, just today, and no go. Some of the things that I am noticing is that after waking, every time, WiFi comes up for anywhere from 5 seconds to 5 minutes. It will either say it's there and work or just say it's there and not work. Then the menu bar icon goes gray and the control panel says it's off. But it does work for a few seconds every time I wake or restart. It worked fine for a month or so right in the middle of all this last Summer. So I am confident that it's software and not hardware. But then . . .


    But mostly I get no reaction to trying to turn on the radio, or mismatched responses from the panel and menu bar with nothing working or the "No hardware installed" message. This has been ever since about 10.8.3-4.

  • NielsC Level 1 Level 1 (50 points)

    I was experiencing the same issues with my 2013 MBA not connecting to wifi ather putting it to sleep. I had this problem everywhere (uni, home, girlfriends house etc..). I had no issues in 10.8.5 or in 10.9 since its release untill a week ago. Resetting the SMC seems to have solved this issue for me.

  • bobsiz Level 1 Level 1 (0 points)

    Thanks Rogerfromwil


    This worked for me!

    Worked on a Macbook 13' & iMac





  • samyfrommontpellier Level 1 Level 1 (0 points)

    For me I disabled the bluetooth and probleme gone, but it's annoying to have always bluetooth disabled :s

  • guyguyon Level 1 Level 1 (0 points)



    I've called the Israeli Apple reseller and they recommend me to create a new location and then restart my mac while pressing alt+cmd+P+R and hold the keys while it restarts for four times.


    i did all of it and the problem is gone!!!

  • F1wanabe Level 1 Level 1 (0 points)

    I spent 1 hour on the phone with apple support and had to connect my iMac 24 in. Early 2008 via ethernet cable so that he could help me with remote assistance. No dice. I tried all of the above solutions and still have the wifi issue.  My macbook is fine with Mavericks, my other devices connect to the Belkin wifi just fine (Tivo, Samsung note 3 and Chromebook) only the imac 24 inch has the problem and only since Upgrading to Mavericks.  So, yesterday I dusted off the airport express and what do you know?  Works fine all the time when connected to airport express.  The problem I have is that the wifi printer and Tivo cannot connect via the airport, so for now I'm stuck with 2 wifi routers.  There's word of 2 updates coming- I hope they help.

  • sw6lee Level 1 Level 1 (0 points)

    I am having the same issue! I didn't know that my bluetooth was on, so I just turned it off as I don't really use it. Hope the problem is resolved for me like some others here.

  • eponymous Level 1 Level 1 (0 points)

    I had the same issue - disabling (un-checking) "Wake for Wi-Fi network access" in System Prefs, Energy Saver seemes to have fixed it.

  • bobsiz Level 1 Level 1 (0 points)

    To: guyguyon

    This worked...I also unplugged the iMac for a minute and plugged it back in, held down the key as you mentioned, it worked for my iMAC and 13" Mac Book pro.




  • Steve Traut Level 1 Level 1 (5 points)

    I'm not sure, but it seems to me that this is just a simple bug with a sticky DHCP lease introduced in 10.9. I've tired everything listed here (short of reinstalling everything) and none of it has helped me so far.


    To resolve the issue manually, I open Network pref-pane, click advanced and click "Renew DHCP Lease" and that interface starts working again.


    I have seen my wired ethernet interface get stuck more often than my wifi interface, but it seems to be the heart of the issue.


    And I'm seeing this when ever I put my MacBook Pro to sleep in one location (work) and wake it up plugged in at another location (home). I've been working this way for years across 10.5, 10.6, 10,7, & 10.8. This is the first time I've encountered the wrong IP address sticking on an interface. Pretty obvious that it is since I run 10.x.x.x at home on an Airport Extreme and work runs 172.x.x.x.


    Or maybe I'm seeing a different issue.

  • jluckyiv Level 1 Level 1 (0 points)

    My problem disappeared as soon as I disabled iCloud Keychain. Has anyone else tried that solution?

  • Ben Busch Level 1 Level 1 (55 points)

    My early 2008 MacBook Pro is having the same problem. It only started after I setup a new AirPort Express. None of the solutions here have worked, an I've tried them all short of reinstalling OS X.

  • AppleIIme Level 1 Level 1 (0 points)

    Disabling Bluetooth also worked for me.


    This is obviously a widespread problem with Mavricks, no matter what the cause.

Previous 1 2 3 4 Next