Previous 1 3 4 5 6 7 Next 520 Replies Latest reply: Dec 8, 2015 4:14 PM by Vulch1 Go to original post Branched to a new discussion.
  • wifiguru Level 2 Level 2


    what wireless router and wireless settings are you using ?

  • KJPM Level 1 Level 1

    Many thanks!


    Switching off i-Cloud Keychain seems to do the trick!

    Looking back, since I switched on Keychain on my new iPhone 5S, I suffered severe wifi problems.

    After switching off i-Cloud Keychain and restarting my Time Capsule, wifi problems disappeared.

  • Jeff Grant1 Level 1 Level 1

    Same problem.  Upgraded to 10.9 and WiFi disconnects randomly after about 5 minutes.  Reconnects with diagnostic.  iPads, iphone & Apple TV all maintain the wifi.  Something is amiss with 10.9!!!!!!!!

  • Nikolaus Heger Level 1 Level 1

    Had the exact same issue, it was driving me nuts. Retina MacBook Pro 2012 would not connect to an Airport Extreme base station. WiFi would appear like it's working for a moment, then get the exclamation mark, then I had to turn it off and on again to make it work; sometimes it would also just lose it during operation and I'd have to turn WiFi on and off. Never had issues before Mavericks.


    Tinkered with all sorts of settings on the WiFi to no avail.


    The PRAM reset seems to have fixed it but since I tried so many things it's not clear that this was the only thing I needed to do. Here's what I did:


    - Create a new location in Network Settings

    - Turn off Bluetooth

    - Reset PRAM two times in a row


    Laptop seems to connect to WiFi fine now. Should I have issues I'll turn off iCloud Keychain. Turned it off on the iPad too, and that fixed things there. The iPad had been very unreliable and slow on WiFi before. Will turn it off on the phone too.


    iCloud Keychain is new in Mavericks so that's a red flag - might very well be what's causing this.


    My theory on why this happens much more at home than anywhere else is that I have two iPads with iOS 7, two iPhones with iOS 7, and one laptop. Now I think if the WiFi is flakey on all of these thanks to keychain, there might be a compound effect where IP addresses "are already in use" - it confuses the router and makes things worse for all devices. Just a guess.

  • Costa M Level 1 Level 1

    It's already 6 months since MBAir13 was released. It is ridiculous it is taking Apple Support so long to fix this issue. You are aware that this is worldwide phenomenon and not a small percentage of your sales.

  • basicappleuser Level 1 Level 1

    I'm no expert on this stuff.  I installed Mavericks last week, and immediately lost wifi on my machine.  I have two other macs and a few ipads that were able to get on the wifi with no problem.  I spent 45 minutes on the phone with Apple support, wound up reinstalling Mavericks, but still no dice.  Based on a hunch, I uninstalled my internet filter (Net Nanny), and then reinstalled.  Problem solved.  Don't know if this will help anyone, but it helped me. 

  • wifiguru Level 2 Level 2

    Please list out the wireless router you guys are using when you mention a WiFI issue. It will help others and might point to any issues with specific wireless routers.

    Have you guys tried using the built in Wireless Diagnostic tool to debug the issue ?

    Wireless Diagnostics

  • AppleIIme Level 1 Level 1

    I'm using an Arris / Motorola SURFboard Gateway SBG6580 DOCSIS 3.0 Wireless N Cable Modem.


    The issue doesn't occur on a different router.


    Again, turning off Bluetooth solves the issue.

  • DaverYYC Level 1 Level 1

    I'm using an all-in-one Cisco DPC-3825 modem/router/wifi brick provided by the cable company for broadband 50.  The temporary fix that works for my new Macbook Air 11" is to uncheck "keychain" in System Preferences> iCloud.

  • intraintel Level 1 Level 1

    I think it is nothing to do with any router or modem. I have one iMac and a Macbook pro working fine with Mountain lion. This issue started on my another iMac when I upgraded to Maverick. For me no solutions suggested till now are working…waiting for a next fix from Apple

  • Costa M Level 1 Level 1

    I totally agrre to INTRANTEL's comment.

    I am using a MBair11 2013 model on Mountain Lion, having installed that Firmw. upgrade from apple this past summer after th initial release of the mac and this phenomenon still occurs. I am using a ZTE model/router provided from my tel company at work and another Thompson at home. On both wifi networks it happens. Whatever mentioned on this super rich forum won't work 100%. My bluetooth is off, i am not on Mavericks yet, i have reset PRAMs, SMCs, deleted network .plist files from the library etc etc etc but this issue "disconnecting and refusing to reconnect or find the proper & desired wifi net" is STILL HAPPENING. COM' ON APPLE.

  • David in Germantown Level 1 Level 1

    I use an Apple Airport Extreme with the latest firmware.  It's not the router's problem in that I don't experience the problem with an older MacBookPro using 10.8.  Only the brand new rMBP using Mavericks.  When I turn off Bluetooth, the problem goes away.


    I turned BT back on and tried turning of Sync KeyChain in iCloud and that too restures normal internet connectivity.  Apple has some work to do with the new Mavericks.


    Not fun to buy a brand new fancy MBP and have to turn off these features in order to get it to work right!

  • KJPM Level 1 Level 1

    I have a fully updated Time Capsule (TC), with 1 wired Airport Express (AE) 1st gen. and 1 AE 1st g by wifi; wired to the TC, a Mac Mini (MM) with Mavericks (MVR), Pages. New MacBook Air (MBA)  by wifi.

    Severe wifi problems for weeks, probably since activating iCloud Keychain on new iPhone.


    Switching off iCloud Keychain on all accounts !!, also the ones of my wife and children, finally stopped problems. 


    Today a new problem occurred. I first printed an email directly frommy MM Mail via wired tc to wifi AE 1 g connected USB printer; worked fine. Then tried to print an attachment, opened with Pages. It stuck in the waiting list with a reading error.

    After directly connecting my printer with USB to my MM, it printed without any problem...


    Since Pages also has an iCloud option, this probably disturbed wifi printing.

    Anyone with comparable wifi failures?

  • bretstar Level 1 Level 1

    I just went through all these steps, the only one that worked was disabling the 'wake for network access' feature. Easy to do, solved a very frustrating problem for me!

  • Level 2 Level 2

    Here's a list of fixes you can try:

Previous 1 3 4 5 6 7 Next