Previous 1 2 3 Next 519 Replies Latest reply: Feb 16, 2015 8:08 AM by Sarah24 Branched to a new discussion.
supersleb Level 1 (0 points)

Ok so Wifi is really starting to annoy now....


I have a 2013 Mac Air (about 1 month old). I upgraded to mavericks and now EVERYTIME the machine goes to sleep, i close the lid, whatever the wifi connection is shut down and on logging in again, the wifi doesn't connect. I have to manually turn off wifi and then turn on again before selecting my network (and usually needs 2 attempts).


This is unacceptable.


Does anybody else suffer from this issue? any ideas on how to fix it (other than reverting back to MLion - if that's even possible)


Thanks in advance for any responses


Kind Regards



MacBook Air (13-inch Mid 2013), OS X Mavericks (10.9)
  • ChavRash Level 1 (15 points)

    I would recommend you to check your router, I had many Wifi issues with my macbook air 2013 after mavricks as well but just to discover that it was all about my router! ..

    before the wifi issue while on M.lion, I disabled the SSID broadcasting but after upgrading to Mavricks, I had simmiler problem with my wifi and after changing my router sittings to allow broadcasting the SSID I've had no prblems since then!


    My problem was solved by the SSID thingy, try to check your router for a suspected option too!

  • Linc Davis Level 10 (184,975 points)

    Test after taking each of the following steps. Back up all data before making any changes.

    1. Make sure the network is on the preferred list by following these instructions. It's important to read the article carefully, as it's the starting point for any further efforts to solve the problem. If you skip any of the steps, the problem may not be solved.

    2. Follow the instructions in this support article under the heading "Symptom: The network connection drops unexpectedly."

    3. Make a note of all your settings for Wi-Fi in the Network preference pane, then delete the connection from the connection list and recreate it with the same settings. You do this by clicking the plus-sign icon below the connection list, and selecting Wi-Fi as the interface in the sheet that opens. Select Join other network from the Network Name menu, then select your network. Enter the password when prompted and save it in the keychain.

    4. From the Location menu at the top of the Network preference pane, select Edit Locations. A sheet will drop down. Click the plus-sign button to create a new location. Give it any name you want. In the new location, set up the Wi-Fi service with the same settings you used before. Click Apply and test.

    5. Launch the Keychain Access application. Search for and delete all AirPort network password items that refer to the network. Make a note of the password first.

    6. In some cases, the problem has been resolved by repairing permissions on the startup volume.

    7. Reinstall OS X.

  • supersleb Level 1 (0 points)

    Hi ChavRash


    I have taken my mac to work and I am having the same issue there so I think it must be a problem with the machine rather than the wifi router. I have never connected to the work wifi before so this is a brand new connection....


    thanks for your suggestions though.



    Hi Linc Davis


    I will be working thorugh the points raised in your suggestion today... really hope i dont have to re-install OSX as i have tons of apps etc that presumably will need re-installation!!??





  • Linc Davis Level 10 (184,975 points)

    No, you won't have to reinstall any apps.

  • DWnAZ Level 1 (0 points)

    After I installed 10.9 on my Macbook Pro.  I had no wifi connection.  I did network diagnostics, the wifi worked and the internet came on. However opening any app or trying to go to the web caused a loss of connection.  Repeated the process of network diagnostic 3 X, and had connection briefly, but when I opened an app or tried to go to the web, I again lost connection.  It is not my router or modem, becuase  I have an old iMac (too old for more recent OS updates), and the wifi / internet is fine?  I am using it right now to connect with this support site.  Any ideas?  Thanks DWall

  • DWnAZ Level 1 (0 points)

    I was able to fix my wifi problem. Not sure if this is the same issue others are having and what I did may not be a good idea, but it worked.   Warning -- I am no expert, but tried some things out of desparation and one worked. 


    I have Macbook Pro (about 3 years old).  My wife as old iMac (too old for newer OS updates).  We have wifi network.  three computers use the network, 3 ipads, and our iphones. 


    I went into network settings - clicked on our network -- went to advanced -- then opened TCP/IP tab and changed the Configure IPv4: to Using DHCP with manual address.  I then entered the address I found on my iPad by going to Setting / WI-FI to find our Network. I clicke the i with the circle around it (information) and found the IP address, I entered the IP address into the MacBook Pro IPv4 address, which is in the format of XX.X.X.XX.  However I changed the last number by one digit up.  Clicked apply and it worked.  Again I am a novice, so this may or may not be a good idea, but at least for now, it is working.  DWall71

  • vanderwallus Level 1 (0 points)

    I have exactly the same annoying issue. Definately not related to router but has to do with Mavericks upgrade. All other systems work perfectly fine on WiFi and so did Macbook before Mavericks.


    Apple please resolve asap!

  • TOWjr Level 1 (0 points)



    None of this helped me, still had problems....I will stick with Mountain Lion until they stabilize Mav....

  • mashahr Level 1 (0 points)

    we all have same problem. it is very it is very it is very annoying. App store loose its connection to internet in sleep mode when power cable plugged. App nap enables but it doesn't work.

  • rogerfromwil Level 1 (0 points)

    I have the same issue with my 2011 MBP after upgrading to Mavericks. When you bring the Mac back from sleep, the WLAN SSID's are not available anymore. A workaround for me is to disalbe Bluetooth before I put Mac to sleep, this seems to help, but is not a long term solution for me...





  • Harajukujuju Level 1 (0 points)

    Thanks Linc - that resolved my "wifi exclamation mark" problem. I had to go all the way to clearing out the keychain - but not all of the entries were in the "Login" section, so that's one of the things others might want to check.



  • TheGuyintheProjectionBooth Level 2 (195 points)

    This is not just a Mvrx problem, but started back in the Lion releases on MBPs (2007 on) only. Then seems to have spread, minorly, to other machines. I have a 2003 iMac that I just put on my network and it's doing great at 100' on the opposite side of a concrete core from the router. Full speed (54MBps) and great connectivity, no drops.


    I have been dealing with this for some time now on an early 2008 MBP and have tried all the "fixes". None have worked. Linc's above only got the WiFi to turn off and it will not turn back on. Although in the middle of my crisis last Summer, my WiFi came back on its own for a couple of months with no problem jumping on any network. I did nothing to provoke its return. I counted my blessings, plodded on as if and pretended that there was no "issues". Now stone cold dead. Well except the brief minutes/seconds it does come on after a restart or wake. Then stone cold dead.

  • rgberkhout Level 1 (0 points)

    Also problems with mvrx, I have since update major problems with streaming audio over my airports express no matter if I connect my mac book pro (1 year) via wifi of LAN to the network My wife's laptop (vaio) doesn't have any troubles streaming audio (airfoil and itunes) to 3 different airports. Apple pls update.

  • mosn Level 1 (0 points)

    I am having same issue !. cleaned up all wifi networks as well as keychain password, It was a pain to reconfigure everything and still have problem.

Previous 1 2 3 Next