Previous 1 2 3 Next 120 Replies Latest reply: Jul 7, 2015 3:37 AM by neohaha
Saperr Level 1 (0 points)

Hi,

After upgrade to Mavericks I can't install my Canon Selphy CP900 printer.

I simply wanted to print over WiFi network.

How could I do that?

 

Thanks in advance!


MacBook Pro with Retina display, OS X Mavericks (10.9)
  • jotakos Level 1 (10 points)

    Got the same problem. No solution yet...

  • Maku70 Level 1 (5 points)

    Got the same problem. I called Canon Poland and said they did not know whether it will be the driver. And for now I use print from your iPad, or Windows ...

     

     

  • redogg Level 1 (0 points)

    The latest driver on Canon's website for OSX 10.8 will work with 10.9 Mavericks but requires editing the Distribution file inside of the SELPHY CP series Printer driver_6.2.0.1.pkg file. I was able to get it working by doing the following.

     

    • Download SELPHY CP series Printer driver_6.2.0.1.pkg from canon.com
    • Open the .pkg file with Flat Package Editor (FPE) which is part of the X Code auxiliary developer tools.
      • To access FPE find the Packagemaker.app inside of the Auxiliary Tools.dmg that you can download form Apple Developer (https://developer.apple.com/downloads/index.action) search for packagemaker
      • Once you find Packagemaker.app right click on it and show package contents
      • Browse to Contents > Resources > Flat Package Editor.app *launch it
    • Open the SELPHY CP series Printer driver_6.2.0.1.pkg with FPE
    • See the Distribution File? Yes, drag it to your desktop.
    • Open it with Textedit
    • Around line 11 you will see

                   function installationCheck() {

                         if ( (system.compareVersions( system.version.ProductVersion, '10.8' ) == -1) ||                     (system.compareVersions( system.version.ProductVersion, '10.9' ) != -1) ){

    • Edit the 10.8 to be 10.9
    • Edit 10.9 to be 10.10
    • Save the file
    • Go back to FPE
    • Select the Distribution File and hit Delete
    • Drag the edited Distribution file form your desktop back into FPE
    • In FPE Save the file.
    • This now will allow you to install the driver on OSX 10.9
    • If you get a security prompt saying that you can not install because the file is unsigned then
      • Go to System Preferences > Security & Privacy > General and give it permission to install form there
    • Once you do all this go to System Preferences > Printers and click the + to add a new printer. It took about 30 seconds for the Selphy to show up but it did and installed without further issues.

     

    You can download the edited driver pkg  file that I used to get  my Selphy CP900 to work with OSX 10.9 Mavericks at

    https://www.dropbox.com/s/igdkf2hey22vj61/SELPHY%20CP%20series%20Printer%20drive r_6.2.0.1.pkg

     

    I hope this helps you out. Canon should be ashamed for not fixing this sooner. It takes 15 minutes.

  • Drewman62 Level 1 (0 points)

    I installed the software fine as you described, but the printer does not show up in the add printer window.  Is there a setting that I need to set on the printer itself to be recognized?  I can print fine from my iphone with their app.

  • redogg Level 1 (0 points)

    Is the printer and your computer connected to the same WIFI network? The selphy needs to be in infrastructure mode and connected - you will see the vertical bars on the selphy LCD screen.

  • landbking Level 1 (0 points)

    I'm dealing with the same issue.  My selphy is not showing up as a printer to add.  I do see the vertical bars on the selphy LCD screen and it says it is in infrastructure mode.  Any advice?

  • redogg Level 1 (0 points)

    Try setting it up using a usb cable (mini to full works also) first. Then see if it will detect it on wireless.

  • Drewman62 Level 1 (0 points)

    I solved my issue.  I turned off Selphy, installed software from above, rebooted machine, turned on Selphy, did the add the printer thing and it showed up!

  • landbking Level 1 (0 points)

    Drewman62 -- this worked for me too!  Crazy.  This after Canon customer service told me I was out-of-luck trying to get the Selphy to work with 10.9 Mavericks.  Thanks to redogg as well.  I couldn't find a usb cable to try out your suggestion, so I tried Drewman62's suggestion.  Note to others, when I turned on the Selphy and did the add printer thing...it took a few seconds before the Canon showed up on the screen.  Make sure to give it a minute.

  • Ali Hijaj Level 1 (0 points)

    Perfect!! I have Canon SELPHY CP810 and it has the same problem but I did what you explain then it started working!!

    Thank you redogg

  • redogg Level 1 (0 points)

    Right on!!! glad it worked for you all.

  • Rumont Level 1 (0 points)

    Thank you very much Redogg, you are my God!!! I have an Selphy CP810 and can not make it work but I just install you .pkg and it works.

  • virguiguie Level 1 (0 points)

    Thank you Redogg! you saved my life!

     

    do you know how have the software Photo Print? i have to print with the mac overview but i wanted to have the canon software but no way...

     

    thank you!

  • RCA1 Level 1 (0 points)

    I have installed the Selphy softwate via your edited install but I cannot see it in my applications?

Previous 1 2 3 Next