Previous 1 2 3 4 Next 87 Replies Latest reply: Oct 14, 2015 1:53 AM by Richie Hale Go to original post
  • ARCTOS Inspector Level 1 Level 1

    Resetting the keychain - what a mess - Didn't work.  Verification didn't work, and Repair was even worse.


    I've rebooted several times; have to use Activity Monitor to stop Mail (Mail cancels restart), etc.


    So, here's what I had to do: 

    1. I went to Finder>Go to Folder> "~/Library/Keychains
    2. I dragged the ~/Library/Keychains folder to the desktop. 
    3. Reboot.  Logging back in was no problem.
    4. I battled with mail for a while under Preferences>Accounts.  No luck.
    5. I finally logged onto my ISP and "changed" my email passwords (not really - I used the same ones as before) - otherwise, the mail account on my laptop could not connect, while I'm connected here on my desktop (and the Air at home, and the iPhone, too).


    iMessage has been another mess.  Logging into iCloud from desktop no problem. 

    1. System Preferences
    2. Accounts
    3. enter password for iCloud
    4. enter password for internet accounts (I had to delete several that did not work with "Notes")


    Seems to be working now - what a mess, Apple.  This was a straight upgrade from Mountain Lion.


    And, what is it with the popup "Enable Access for Assistive Devices" - open system preferences with every boot?  I don't have any, don't want any & don't need any (yet).  I have to cancel it every time.


    Good luck, everyone!

  • MeddlesomeFilms Level 1 Level 1

    Alright guys, so the Genius Bar had a recent internal update that gave them specific step-by-step directons on how to fix this.


    To be totally honest it's something anyone could handle, but without the directions it could prove challenging. I would NOT RECOMMEND following ANY of the instructions below. I'm purely providing a glimps into what I saw happening to fix my mac. It was fixed by a certified Apple Genius. I, am definitely not.


    I know it required resetting a Keychain password, as well as unlocking the System in Keychain. Once that was done there was another PW reset I believe, and then a restart. As it's restarting you have to hold down Command, Option, P, and R. This is to reset your PRAM.


    I would highly recommend bringing it into a Genius. It sounds like this is a broad problem. Apple Care was not needed for me to see the Genius or to have it fixed. Saw them twice.


    Good luck to everyone!

  • ARCTOS Inspector Level 1 Level 1



    I ran Disk Warrior and rebuilt the drive - no change.


    I still have the keychains on my desktop, I've just been re-entering all the passwords.


    My mail is acting funny - (we have our own domain through IX webhosting; webmail by HORDE) in that not all the IMAP copies are being distributed properly nor are all emails being received (MacBook Pro; MacBook Air and iMac (also iPhone, but, push is off).


    Another problem, and whether it's showed up as a result of the keychain issue or not, is that one of my Login's now has the "wrong architechture".  I've cleaned the startup using Mavericks Cache Cleaner (MCC) but the "osascript[13623:d07] Error loadi.... 262): no suitabe image found.  Did find:   but wrong archtecture" (note there are blanks as a result of the MCC window and selecting "reveal" does nothing).


    I'll try the PRAM trick & keep you posted.

  • macluvin Level 1 Level 1

    Altnerative workaround:


    After weeks of trying different methods and non working, I decided to just create a new user account, transfer all of my files over to it and started over from there. If you're going to have to re-enter in all of your passwords as some of these solutions suggest, why not just do it this way? A few steps to create and setup a new user, apply your preference updates and you should be almost good to go.


    If you don't have an external drive to transfer your files and if you have any space, you can use your Public shared folder to grab your old account files to copy over to your new account files.


    This bug *****. Good luck everyone.

  • Mbthorco Level 1 Level 1

    for what it's worth ...(first apple ever...mac mini...and yes very frustrating)....


    Opened Keychain

    created new account (used my name)

    created new password for it

    Deleted old login keychain

    re booted



    all seems okay, at least for the last ten minutes!



  • Kalsta Level 1 Level 1
    Mac OS X

    Some of the suggested fixes seem to be for people having trouble with the login keychain. That's fine, but keep in mind that the OP's problem was reportedly with the Local Items keychain. I only point this out, because I hadn't noticed at first and it caused me a bit of confusion in trying to solve the problem on a friend's Mac, which, like the OP, was with the Local Items keychain. For example, the 'Change Settings for Keychain …' option is greyed out for the Local Items keychain, and the 'Reset My Default Keychain' also seems to apply to the login keychain unless I've misunderstood Apple's explanation of what it does.


    Anyway, the instructions that worked for us were the ones posted by Steve Singapore. Some people said these didn't stick, so my optimism is cautious until Apple acknowledges and fixes whatever the root cause of this is. But for now my friend's Mac is usable again, with only the minor inconvenience of having to to reenter the previously saved passwords.

  • activelife81 Level 1 Level 1

    I was extremely frustrated with this issue and this solution worked for me also...




    I had same problem and apple support fixed it in 5 minutes.


    1. Go to Finder

    2. Look for library in favourites.

    3. If not there hold down option key and click on GO in the top menu

    4. Scroll down to Library and click on it

    5. Look for Keychain folder and click on it.

    6. Inside KEychain folder is a single folder we random numbers and letters.

    7. Drag this folder onto your decktop.

    8. Re-boot and you should be good to go.

    9. If Ok drag the folder off your decktop  into trash !!


    Very easy

  • activelife81 Level 1 Level 1

    this worked for me also

  • clscurnutt Level 1 Level 1

    Thanks. It worked for me.

  • Oceanconcepts Level 1 Level 1

    I experienced this issue after the latest OS update. Steve's solution allowed me to log on, though I am still getting requests to use the Log in keychain every so often, even though I have preferences set to keep it unlocked.   At least now it is accepting the password I set- it was not before. Unfortunately doing this also eliminated the keychain data in my log in keychain. 


    I have used keychains a lot for a long time, have a ton of secure notes regarding application passwords, authorizations, purchase data, and so forth. I don't want to lose all that information, or have to reenter it manually to access it on this laptop. I'm wondering if there is some way to migrate keychain data from another (10.8, not Mavericks) system. Previously I had just copied the folder from one machine to another, but the iCloud seems to have changed the way keychains are handled. 


    Does the iCloud synch work if you have multiple keychains?

  • wattsba Level 1 Level 1

    This worked for me on my iMac. A simple solution to an annoying issue. Thank you for sharing.

  • leshnerg Level 1 Level 1

    Worked on my iMac, too, thus far. Thanks!

  • clarebear Level 1 Level 1

    Hi guys,

    I just experienced this problem last night, this is the first big issue I've had with Apple.

    The whole os froze which has never happened before.

    So I force rebooted, and then this stupid keychain crap came up.

    Some of my apps would freeze and I couldn't click on some things, so I did a disk repair thinking that would help, alas :|


    I haven't tried any of your fixes yet l, but why should we have to?? Looks like it's been over a month this problem occurred for some of you, Apple need to fix it themselves in a new update! It's been long enough.

  • Kalsta Level 1 Level 1
    Mac OS X

    True clarebear, Apple should fix it, and promptly. I usally report bugs like this to Apple <>, but I confess I've been too lazy this time. If none of us report it, chances are Apple won't fix it.


    The issue that reminds me most of this one was a few years ago when Mail kept deleting saved passwords every time it had trouble connecting to the mailserver. I hate to say it, but Apple took forever before they fixed that one—I remember it drove me crazy for months and months, and I was very vocal about it. At least this one has a simple fix—but only for those who stumble onto this thread!


    My friend who had it happen to him is a recent switcher from Windows to Mac. This stopped his shiny new iMac dead in its tracks, and he didn't know what to do. Hopefully Apple will realise just how bad this sort of thing makes them look and fix it sooner rather than later.

  • clarebear Level 1 Level 1

    I tried the fix where you open up the Keychain Access app and change the settings -

    Well once I click select Change Settings for keychain "login", the app just freezes.

    I can only access a couple of websites not including Apple, so I'm typing all this on my iPhone :|

Previous 1 2 3 4 Next