Previous 1 2 3 4 5 6 Next 84 Replies Latest reply: Nov 18, 2014 11:44 AM by MacBookPro71 Go to original post
  • Kalsta Level 1 Level 1 (25 points)

    Are your alerts asking for the login keychain or the Local Items keychain? In my friend's case (and the OP's) it was the Local Items keychain, and the fix that worked for me (and for quite a few others here) was this one <https://discussions.apple.com/message/23768561#23768561>:

     

    Steve Singapore wrote:

     

    I had same problem and apple support fixed it in 5 minutes.

     

    1. Go to Finder

    2. Look for library in favourites.

    3. If not there hold down option key and click on GO in the top menu

    4. Scroll down to Library and click on it

    5. Look for Keychain folder and click on it.

    6. Inside KEychain folder is a single folder we random numbers and letters.

    7. Drag this folder onto your decktop.

    8. Re-boot and you should be good to go.

    9. If Ok drag the folder off your decktop  into trash !!

     

    Very easy

     

    Have you tried that one?

  • clarebear Level 1 Level 1 (0 points)

    Hi Kalsta, yeah it's looking for "local" items.

    I went to my /Library/Keychains folder and there is 7 files, they don't seem to be typical folders.

    The most randomly named one is apsd.keychain the rest are applepushserviced.keychain, FileVaultMaster.cer, FileVaultMaster.keychain, System.keychain and System.keychain-orig

    So would the one to move be apsd.keychain?

  • Kalsta Level 1 Level 1 (25 points)

    No, I wouldn't touch any of those. I think you're looking in the wrong Library folder. It's the one inside your user folder. It's at /Users/clarebear/Library/Keychains/ or, as Steve said, the easiest way to get inside the correct Library folder (because it's hidden by default) is by holding down option and clicking on the Go menu. From there you can navigate to the Keychains folder. Inside that, the folder you're looking for has a very long filename with a random looking string of numbers and letters, broken up by some hyphens. It's pretty obvious when you see it—in fact, it's the only folder on my system.

  • Kalsta Level 1 Level 1 (25 points)

    iiDave, that only works for the login keychain. As I've mentioned a couple of times on this thread, the OP was receiving alerts about the Local Items keychain. If you select the Local Items keychain, you'll notice that the 'Change Settings for Keychain …' option is greyed out, so it's not the solution to this problem.

     

    Speaking of the OP (cliff from gray lake), it would have been helpful for everyone else if he had come back and marked Steve's solution as the answer (or whatever else worked for him), but it seems he posted the question and was never heard from again.

  • clarebear Level 1 Level 1 (0 points)

    Ahhh sorry Kalsta, derp moment, yes I was looking in the wrong Library, it was litterally a hidden file and it worked!

    Hoorah!

  • Kalsta Level 1 Level 1 (25 points)

    Hoorah! Glad to hear it!

  • Keef_W Level 1 Level 1 (0 points)

    Thanks Steve, been trying for two hours, followed your instructions and nailed it in two minutes. Thanks for for sharing.

  • mgagnon22 Level 1 Level 1 (0 points)

    Uh... help!

     

    I'm stuck at my login page and cannot log INto  my computer to even begin to fix the issue through the methods listed. Any suggestions?! Note: I've never had this keychain thing set-up and none of the passwords that I've used get me past the pesky "dialogue" boxes "AddressBookSourceSync" wants to use the "Local itmes" Keychain. It keeps rotating through a handful of other messages.

  • Kalsta Level 1 Level 1 (25 points)

    That's a tricky one… The first idea that comes to me is to try booting up into safe mode:

     

    1. Shut down your Mac and wait 10 seconds.
    2. Press the power button.
    3. Immediately after you hear the startup tone, hold down the Shift key. You should press the Shift key as soon as possible after you hear the startup tone, but not before.
    4. Release the Shift key when you see the gray Apple logo and progress indicator (spinning gear).

    To leave safe mode, restart the computer normally without holding down any keys during startup.

    (Source: http://support.apple.com/kb/PH11212?viewlocale=en_US&locale=en_US )

     

    Not sure, but I'm hoping that might allow you to at least login so you can try the aforementioned fix.

  • activelife81 Level 1 Level 1 (0 points)

    I was in the same situation and I got in by clicking on the little gray question mark next to the login field which let's you reset your login password. Use it to reset your login password and wrote it down exactly as you create it and don't mix it up with your old password or your Apple ID password or iCloud login and other passwords because you gotta get this right. This whole keychain and login issue can drive you nuts and typos and mixed up passwords in the process can make you go nuts.

     

    So so that and reset your Mac login password and then follows Steve's 9 step instructions. That's what worked for me just in time before I threw it out the window lol

  • Freces Level 1 Level 1 (0 points)

    After half a day trying to sort this mess out with various options, I finally came across this post.

     

    I tried Steve Singapore's solution and so far it has worked.

     

    I have been using Apple products for the last 7 years and never had such a problem to solve. 

     

    Apple: I feel this was pretty poor.

  • /iz Level 1 Level 1 (0 points)

    Thank you Steve,

     

    That worked for me as well. Just to be clear, the folder to remove is in the user's keychain folder.

     

    • Open Finder
    • Select Go > Go To Folder... from the menu
    • Type ~/Library/Keychains in the dialog and click Go
    • You will find the folder with the "random digits" there. Just move it somewhere - the Desktop or another folder.

     

    Thanks for your help!

     

    P.S. - I am seriously thinking Ubuntu 12.04 on Mac is not that bad, especially when Apple's sw releases are becoming more and more a nightmare.

  • Oletinstrum Level 1 Level 1 (0 points)

    Thanks, Kalsta and Steve Singapore!

     

    My MacBook Air suddenly wanted those local  items passwords AFTER I'd had to restart for I forget what reason (it was last week; I mostly work on my iMac so I'd forgotten there was a problem with the Air until just now). I rebooted in Safe Start mode and was finally able to access that pesky folder in ~/Library/Keychains that Steve talked about. So far, so good. 

     

    I am wondering, though, if I need to now set up some sort of new password for Keychains in case this happens again. Anyone know?

     

    And I just want to add that I really appreciate these forums.

  • Kalsta Level 1 Level 1 (25 points)

    You're welcome, and glad to hear you were able to get past the login screen in safe mode!

     

    > Oletinstrum wrote:

    > I am wondering, though, if I need to now set up some sort of new password for Keychains in case this happens again. Anyone know?

     

    I don't think so. I don't remember ever having to create a password for keychain—my user account password is the only one I've ever needed for local stuff (and Apple IDs for online stuff). I notice in Keychain Access preferences, there is an option 'Synchronize login keychain password with account', and by default it is ticked. There are also some notes there which say 'Check these boxes if you want Keychain First Aid to use your account password for the login keychain, so that it unlocks automatically when you log in.' Don't ask me what 'Keychain First Aid' is, but the wording suggests that your account password is supposed to unlock things at login. The Local Items keychain isn't mentioned here, but it is always unlocked on my Mac, and I've never been asked for a password.

     

    PS. Apple's having some serious issues with these forums. It kept giving me an under maintenance kind of message everytime I tried to post with a proper quote of your message. So I gave up with that in the end, as plain text is posting fine.

     

    PPS. Merry Christmas all!