Previous 1 41 42 43 44 45 Next 794 Replies Latest reply: Jan 28, 2016 3:33 AM by softhive Go to original post Branched to a new discussion.
  • rorydinho Level 1 (0 points)

    A few posts were discussing how few people are complaining about this; I have had the issue since the day I rceieved my 2013 rMBP (on release day) and many of my friends have the same issue but they're less enthusistic about checking the support community pages.


    I have been reading about the issue for at least 6 months, hoping for a solution, but it seems the only fix is via updated drivers, therefore, this is entirely in Apple's hands.


    I haven't tried the turn off bluetooth and delete preference files method, but I will tonight.


    I imagine Apple are well aware of this - it is impossible to miss - due to their staff using the same hardware and the undoubtedly numerous bug reports.

    This doesn't leave me hopeful however, as the issue has been around for so long; surely it would have been picked up by now. That it hasn't points to the fact that the issue is hardware related and Apple have, yet again, used faulty/unsuitable components in their products.


    Not impressed - try watching BBC iPlayer, or streaming anything for that matter; it's a complete farce.

  • monty88haynes Level 1 (0 points)

    I'm not tech savvy enough to join the beta program or follow the detailed instructions posted about writing script.  All I know how to do is to 'reboot' but if you're using BBC iPlayer, then you must be in the UK like I am.  I wrote into BBC Watchdog to complain about this issue and if everyone on this forum from the UK will do the same, perhaps Watchdog will do a piece on this and Apple will be shamed into doing something about this problem.  After doing all the simple suggestions, I have found the easiest thing to do is to turn the wifi OFF and then back ON again.  Caveman technique.for the 21st century.

  • McFiFth Level 1 (0 points)

    From my experience, turn wifi off and back on works very occasionally. I phoned apple care several times now, and they said already forwarded this to the senior engineers. dont know if this means anything though.

  • Splinky Level 1 (0 points)

    I went through the process of deleting the Bluetooth plist files a few days ago, but the Wifi dropouts are now reoccuring.


    I have now setup a macro using Keyboard Maestro to toggle my wifi off and on each time my Mac wakes from sleep.


    That seems to be working so far.


    Terribly hacky, but the best option I've found so far.

  • McFiFth Level 1 (0 points)

    I placed my holp on the new update, but the wifi issue remains after 10.9.3 installed!!!!!!   


    How pathetic!!!

  • monty88haynes Level 1 (0 points)

    Same here and agree that Apple is CRAP!!! if they can't sort something simple as this.  When I saw that the update was supposed to 'improve relliability of network directories' I thought they finally sorted it but no, still NO GOOD!!! How frustrating that I can't use this machine like I ought to.

  • McFiFth Level 1 (0 points)

    a friend told me this is caused by IPV6. Turn it off by type in "networksetup setv6off Wi-Fi" in terminal, and this will solve the wifi issue. I already turned it off and wifi seems staying normal now, I don't know if this will last though. Definitely worth to give a shot since there is no better solution now.

  • digoyP Level 1 (0 points)

    This is my second macbook pro retina 13" after Apple replaced the first one due to the same Wifi problem.  Just this past two weeks, the Wifi dropped signal problem came back again.  I realized that the signal dropped whenever the wifi connection changes between the 2.4 and 5GHz band. 


    I separated my Time Capsule 5GHz band from the 2.4GHz band.  Then most of the time, I just connect to the 2.4GHz (Wifi N) and the connections are OK so far.

  • William Kucharski Level 6 (14,985 points)

    Note if you read the thread on Thunderbolt GigE adapters you'll see it was addressed in OS X 10.9.2.

  • lacroix88 Level 1 (0 points)

    Interestingly, since updating to the latest OSX version (10.9.3) five days ago I have not had any troubles connecting to my network and internet via Wifi anymore. The issue I was having was a failure to connect after booting as well as after waking up from sleep mode in more than 50% of the attempts. Sometimes manually deactivating and reactivating the network adapter, sometimes just waiting for 5-10 minutes would fix this. If not I used to have to reboot my router in order to get the macbook to connect properly.

    As I have stated above, this issue has not occured since 10.9.3 anymore. I can't really make a comment on connection speed, since I have not been measuring it, but it seems also to have improved.


    Have anybody elses wifi issues been improved substantially with 10.9.3?

  • iDroid Level 1 (0 points)

    Applier that's true, I ran 2 tests,  first witht Bluetooth Off and everything was great,  the second one with Bluetooth On and results where awful ping latency incredible high.


    Bluetooth Off


    64 bytes from icmp_seq=184 ttl=255 time=4.777 ms

    64 bytes from icmp_seq=185 ttl=255 time=2.205 ms

    64 bytes from icmp_seq=186 ttl=255 time=2.877 ms

    64 bytes from icmp_seq=187 ttl=255 time=2.837 ms

    64 bytes from icmp_seq=188 ttl=255 time=2.280 ms

    64 bytes from icmp_seq=189 ttl=255 time=2.981 ms

    64 bytes from icmp_seq=190 ttl=255 time=2.838 ms

    64 bytes from icmp_seq=191 ttl=255 time=2.131 ms

    64 bytes from icmp_seq=192 ttl=255 time=2.335 ms


    --- ping statistics ---

    193 packets transmitted, 193 packets received, 0.0% packet loss

    round-trip min/avg/max/stddev = 1.287/3.242/77.116/5.387 ms



    Bluetooth On 


    PING ( 56 data bytes

    64 bytes from icmp_seq=0 ttl=255 time=123.488 ms

    Request timeout for icmp_seq 1

    64 bytes from icmp_seq=1 ttl=255 time=1449.394 ms

    64 bytes from icmp_seq=2 ttl=255 time=475.135 ms

    64 bytes from icmp_seq=3 ttl=255 time=1144.201 ms

    64 bytes from icmp_seq=4 ttl=255 time=161.733 ms

    64 bytes from icmp_seq=5 ttl=255 time=605.118 ms

    64 bytes from icmp_seq=6 ttl=255 time=285.173 ms

    64 bytes from icmp_seq=7 ttl=255 time=1528.698 ms

    64 bytes from icmp_seq=8 ttl=255 time=544.414 ms

    64 bytes from icmp_seq=130 ttl=255 time=2.389 ms

    64 bytes from icmp_seq=131 ttl=255 time=1.227 ms

    64 bytes from icmp_seq=132 ttl=255 time=1.711 ms

    64 bytes from icmp_seq=133 ttl=255 time=6.321 ms


    --- ping statistics ---

    134 packets transmitted, 134 packets received, 0.0% packet loss

    round-trip min/avg/max/stddev = 1.227/165.051/1528.698/344.615 ms




    Applier wrote:


    Hello, I have the same wifi problems with my MBPr late 2013 when I use my Magic Mouse via Bluetooth. But without Bluetooth connections wifi is working properly.

  • Grant Bennet-Alder Level 9 (56,466 points)

    Bluetooth uses the spectrum in the 2.4GHz band, where cheap Routers, microwave ovens, baby monitors, some portable phones, bad USB cables, and all your neighbors' Networks are competing with each other. A more expensive dual-band Router gives access to faster transfers using the 5GHz band, and often gives far better results.

  • johnniecache Level 1 (5 points)

    Sorry, but this kind of general advice is not helpful here. There are millions of notebooks out there where bluetooth and wifi get along on 2.4GHz. Also this is obviously not what causes the wifi problems with the MBPr's because there are many people here (including me) experiencing problems with BT turned off anyway.


    I insist this is a problem with the broadcom driver in Mavericks (try and run Windows and see for yourself), and unless apple fixes it, the problem will not go away, whatever magic or advice will be posted in this thread.

  • iDroid Level 1 (0 points)

    Thanks for your explanation, I checked the one supplied by my telephone/dsl service company and it's working in the 2.4Ghz band like you said. Now its very clear that I should invest in a better router.


    Also I want to comment that with 10.9.3 update, reconnecting to my router after sleeping my mac (closing lid) is no longer and issue, it reconnects instantly. 

  • monty88haynes Level 1 (0 points)

    I think an earlier poster said that he had problems with wifi connection even with the dual band Apple Airport so buying a better router does not necessarily solve the problem.  A better router may give you faster transfer speeds but you cannot be sure a dual band router will cure the problem.  Hate to spend a lot of money and come home and still have the same problem.  Aside from that my Google Nexus 7 tablet uses bluetooth to connect to my Bose mini Soundlink and there is no conflict and connects instantly.  My Windows laptop connects instantly as well so why oh why should my 'superior' Apple not?  It's only the most basic action of any operating system.

Previous 1 41 42 43 44 45 Next