Previous 1 2 3 4 Next 52 Replies Latest reply: Aug 11, 2015 8:51 PM by Scott Wager
DJWillis Level 1 Level 1 (10 points)

If you open the Activity Monitor and see that a process called "google chrome helper" is using too much CPU, here's how I fixed it:

 

I went to Chrome settings/content settings/Plugins and selected Click To Play for all plugins.  (The default is Run Automatically.)

 

This fixed my problem.  Now you have to click whenever you want to run a youtube video or other plugins, but it's worth it.  It stops those stupid Flash ads from loading, too, so that's an extra bonus.

 

I'm posting this because when I had the problem, I couldn't find any solutions at all.

Previous 1 2 3 4 Next