Previous 1 2 Next 23 Replies Latest reply: Jan 28, 2014 3:43 AM by insats22
chriscurnow Level 1 Level 1 (0 points)

I have a regular problem with Time Machine backups on OS X Server. The problem started in ML Server but continues in Mavericks.

 

Every few days I get the message "Backup Failed: The backup on <server-name> is already in use."

 

To fix it, I have to

  • go to the server,
  • turn OFF Time Machine,
  • turn OFF File Sharing
  • Eject the Time Machine backup volume
  • Use Disk Utilities to mount the Time Machine volume again
  • turn ON File Sharing
  • turn ON Time Machine

 

After this, TM works again quite nicely for a few days. Then the message re-appears.

 

Anyone had this problem?

 

If so, did you fine a solution?

 

regards

 

Chris


Mac mini Server (Mid 2010), OS X Server, Updated to Mavericks
  • Paul Johnson13 Level 1 Level 1 (60 points)

    I have seen the same error message for at least 2 months now. I've just restarted the server to recover from the error. I've never filed a formal error report, but I suppose this is one case where one is merited.

  • iGary Level 4 Level 4 (1,565 points)

    I've been experiencing this on 2 servers at different locations, but not with all users. My fix is similar to yours, but I haven't had the problem return with my method.

     

    What I do is:

     

    1. Remove the backup share from the client Mac (in System Preferences).

    2. On the server turn off Time Machine in Server.app.

    3. Remove the share point in File Sharing.

    4. In Terminal delete the sparsebundle backup in question.

    5. Turn Time Machine back on and point it back to the original backup location.

    6. Recreate the backup on the client.

     

    See if that improves things for you. Hopefully you don't have lots of users with the problem.

  • Paul Johnson13 Level 1 Level 1 (60 points)

    Isn't making a whole new full backup rather time consuming, iGary? Just restarting the server recovers from the problem for me and that just takes a couple minutes. I haven't needed to do a full TM backup for a while but I recall that on my machine it could take several days.

  • iGary Level 4 Level 4 (1,565 points)

    I find backups in the range of 200+ GB take a few hours. But that's worth it in order to bring back reliability to the backups.

  • Paul Johnson13 Level 1 Level 1 (60 points)

    Gary, what evidence do you have that trashing your backups and starting over with a complete backup is any more effective than a simple restart of your server? The "In Use" error may well be cleaned up by a restart that simply cleans up a "lock flag". My experience in my own configureation is that a 200+ GB backup takes days, unless Apple has fixed an obvious and old problem with incredulous backup times.

  • chriscurnow Level 1 Level 1 (0 points)

    iGary,

     

    Thanks for your suggestion. I appreciate it.

     

    However, I don't really want to trash my backups – that rather destroys the concept of having backups.

     

    In addition, I only started this backup set in June this year and have been having this problem for months. Doesn't this suggest that following your suggestion would only solve the problem for a few weeks and then I'd have to go through the whole process again.

     

    I'd rather just keep doing what I am doing now.

     

    It would be really nice to find what flag was being set and not cleared and then clear it manually rather than the 10 minute process I now have to go through.

     

    Thanks again for you reply.

     

    Chris

  • insats22 Level 1 Level 1 (5 points)

    I'm having the same problem. I had the exact same issues with Time Capsule, and we decided to install OSX server on a mac mini (with an external drive) to see if that worked better than Time Capsule. The backup speed increased significantly but this error persists. We have 12 units doing backup and this happens to two of them. The rest seem to be working just fine.

  • Corbin Harris Level 1 Level 1 (5 points)

    Having the exact same issue starting with ML and it's worse with Mavericks. 

     

    "The backup disk image "Volumes/Backup6/macname.sparsebundle" is already in use."

     

    My only solution is to reboot the MacMini running OS X 10.9 Server everyday.  Starting to look at other backup solutions now.

  • insats22 Level 1 Level 1 (5 points)

    The downside to other backup solutions is that they usually only cover files, not application settings etc. - which can be a pain to reset. Time machine is very elegant and it's extremely easy to get back on track if a laptop is stolen/breaks down or similar. With other systems you'd only be able to get files back, and it's not as easy as backing up the libraries folder.

     

    I'm really hoping that Apple will be able to fix this.

  • Corbin Harris Level 1 Level 1 (5 points)

    We have over a 100 Mac users and we manage them witih Casper (Jamf Software), so we can redeploy a newly imaged Mac quite quickly.  We exclude all users Music, Movies and Photos directories.  Looking at CrashPlan, but until then, I'm trying to reduce the headache that TM has become for backing up the Macs.

  • chriscurnow Level 1 Level 1 (0 points)

    TM was never meant for a large installation. I'm not surprised it is a headache for you.

  • chriscurnow Level 1 Level 1 (0 points)

    Insats22, other backup system will copy all your settings as well - after all they are just files. It's just that they don't restore as elegantly as TM.

  • bhamslacker Level 1 Level 1 (0 points)

    Same problem here. Time Machine service was the main reason I bought OSX Server, so I'm hoping this will be addressed in an update.

     

    This fix has worked quickly for me: Connect remotely to OSX Server using the Server app. Stop the File Sharing service. (This will also stop the Time Machine service.) Start Time Machine service. (This will also start File Sharing service.) That's it.

  • Wipeout69 Level 1 Level 1 (0 points)

    I stopped file sharing and time machine.  Then restarted time machine (which restarted files sharing services) on my server and the error went away on my MBP.  The Other mac mini never has had this issue.  This is the first time I have had this happen although I have only had the MBP for a week now.  :-)

Previous 1 2 Next