Previous 1 2 3 Next 33 Replies Latest reply: May 6, 2015 3:13 AM by steve PF
guitarrocker Level 1 Level 1 (0 points)

I just installed the new update for iTunes last night, and after it finished downloading, I was unable to access iTunes at all.  It popped up with error 7 windows error 127 and said that the entry point could not be found in iTunes.  I am unable to open iTunes at all now.  Has anyone else encountered this problem with the new update?  I can't figure out what to do from here...


Windows 8
  •  DirtTherapy Level 1 Level 1 (0 points)

    The exact same thing happened to me.  I read that installing the correct version of

    Microsoft's .NET Framework that are applicable to your OS would help  but that  did not help.  It is so frustrating to install something that is supposed to be an improvement that instead makes iTunes unusable.

     

     

    Windows 7 Home Premium

  • tyoksas Level 1 Level 1 (0 points)

    Same thing happened to me after installing the latest (20140124) iTunes update:

     

      iTunes was not installed correctly.  Please reinstall iTunes.

     

      Error 7 (Windows error 193)

     

    This is on Windows 7 64-bit fully patched.  I tried reinstalling twice with the same results, and then uninstalled and installed through Apple Software Updater... this failed also.

     

    I posted to see if others are having the same experience; evidently they are!

  • simonsharko Level 1 Level 1 (0 points)

    I am also having this same problem.

  • tboy79 Level 1 Level 1 (0 points)

    I received this same error after installing the latest version of iTunes. The only way I was able to resolve this error was uninstalling all aspects of this new version of iTunes including Bojour and everything that has to do with Apple in the uninstall programs area of Windows. I then downloaded version 11.1.0 and installed it and it worked the way it was supposed to. I am running Windows 8.1.

     

    http://www.oldapps.com/itunes.php?old_itunes=13043

  • simonsharko Level 1 Level 1 (0 points)

    I am also running Windows 8.1  However this solution did not work for me.

  • simonsharko Level 1 Level 1 (0 points)

    I believe I have resolved this problem.   there is no need to uninstall apple programs.  Instead see the following

     

    https://discussions.apple.com/thread/5465144?start=30&tstart=0

     

    go to the Jan 20 posting by helobuff and follow his/her solution (at this time, second to last on the thread.  This worked for me.  It appears that the Qtmoviewin.dll file included in the latest iTunes download does not work, but that the one in common files does.

  • tyoksas Level 1 Level 1 (0 points)

    I went the route of uninstalling everything Apple on my Win 7 64-bit machine; made sure that all of the directories referenced in the Applie HOWTO were empty; rebooted; and then reinstalled iTunes.  The full uninstall/reinstall procedure worked for me, but it took a LONG time mainly because Apple Application Support would not uninstall until I had Repaired it a couple of times.

     

    After the ordeal, everything appears to be working correctly.

     

    Question for the community:  Was this failure due to the iTunes update?  If yes, why hasn't Apple come forward and released an updated installation!?

  • gGeorgeb Level 1 Level 1 (0 points)

    I am usining Windows 8.1  and had Error 7 (windows error 127)  Here is what finally worked for me. Go into C: Program Files > Itunes Folder and remove all old .dll files (look at the dates) in the root of that directory (not in the sub-folders). Then delete and reinstall iTunes.

  • pando33 Level 1 Level 1 (0 points)

    Thanks tboy79!  This helped me!  I uninstalled all Apple software from my pc and reinstalled the old version 11.1.0 from your comment and I am back up and running!  Thanks so much!

     

  • alf51 Level 1 Level 1 (0 points)

    i am trying to open itunes but get this error7 error127 what can i do to fix it please

  • turingtest2 Level 9 Level 9 (55,455 points)

    For general advice see Troubleshooting issues with iTunes for Windows updates.

     

    The steps in the second box are a guide to removing everything related to iTunes and then rebuilding it which is often a good starting point unless the symptoms indicate a more specific approach. Review the other boxes and the list of support documents further down page in case one of them applies.

     

    Your library should be unaffected by these steps but there is backup and recovery advice elsewhere in the user tip.

     

    tt2

  • Alt@ir Level 1 Level 1 (0 points)

    Thanks gGeorgeb! I tried your way and it worked. iTunes is up and running again. Cheers!

  • lvio Level 1 Level 1 (0 points)

    One way that finally worked for me after 4 hours of trying everything:

     

    I followed the instructions from a much older version of this problem; the new iTunes help area tells you to delete the programs below except Quicktime; once I deleted Quicktime something worked; So the steps that I followed: 1. Uninstall the programs in the order below 2. Delete all the accessory files under program files and program files 86 3. empty recycle bin 4. reboot

    I did not reinstall quicktime as of right now....

    And it finally worked!!!! ( this taught me that I will never be buying an ipad again...I think the new tablets will be sophisticated enough so I will not have to use Apple products ever again and waste such a phenomenal amount of time)

     

     

    Use the Control Panel to uninstall iTunes and related software components in the following order and then restart your computer:

    1. iTunes
    2. QuickTime
    3. Apple Software Update
    4. Apple Mobile Device Support
    5. Bonjour
    6. Apple Application Support (iTunes 9 or later)
  • Mclennon Level 1 Level 1 (0 points)

    Thanks.  That helped me as well.   No need to even re-install.   Just remove the old .dll files from the Program Files(x86)/itunes directory and run itunes again.

Previous 1 2 3 Next