Previous 1 2 3 4 Next 55 Replies Latest reply: Apr 2, 2014 5:12 PM by Lee6666
mdjettatdi Level 1 (0 points)

I have a large document (16x32") that I am trying to print on a single legal sized page.


I have landscape mode selected in Page Setup, yet when I select Print and tell it to print to a single Legal page (under Paper Handling I select Scale To Fit Paper Size and then select US Legal), it ends up printing in portrait orientation--even though the preview in the Print dialog box has it in landscape.


I have printed this document before (a month or two ago) and it worked fine.  There have been I think 2 updates in the intervening weeks, has one of the updates changed something about printing?


Is there anything I can do to fix this?


Details: Pages 5.1, OS X Mavericks 10.9.1, MacBook Pro (late 2008)

OS X Mavericks (10.9.1)
  • PeterBreis0807 Level 7 (34,040 points)

    It all has to do with your paper feed in the printer.


    The landscape/portrait icons in your Print Dialog are only to rotate the design 90° to fit the sheet direction.


    It sounds like whichever you chose in the Print Dialog, you need to select the other.


    Users seem to get lost in double negatives.



  • mdjettatdi Level 1 (0 points)

    Maybe I'm missing something, but I can't for the life of me find any way to change the orientation in the Print dialog.  It is only in Page Setup.  At least as far as I can find.

  • PeterBreis0807 Level 7 (34,040 points)

    Sorry you are right. I'll do it step by step.


    Make a custom Paper Size:


    Menu > Edit > Print Setup > Paper Size > Manage Custom Sizes… > + > double click on Untitled > 16"x32" > Paper Size > Width: 16" > Height 32" > Non-Printable Area: 0,0,0,0 > OK > Orientation: Landscape (rotated 90°)


    This presupposes that your printer takes its US Legal size paper in by the short edge. You set the actual paper size up the way it is fed to the printer.



  • mdjettatdi Level 1 (0 points)

    I had already set up the paper size that way.  But when I try to print as I state above, it prints portrait.


    Again, it used to print fine.  Now, 1 or 2 updates later, it doesn't.

  • PeterBreis0807 Level 7 (34,040 points)

    So you have a short height and long width in your custom paper size?


    How does your printer take large paper feeds?


    What Printer are you using and have you updated the Printer driver?


    Waht updates to what?


    What happens if you print from Pages '09?


    or TextEdit?



  • mdjettatdi Level 1 (0 points)

    No.  I have a short width and long height and it is in landscape orientation (just as you described in your second message, above).  If I try to change it to short height and long width, it just changes it back once I select landscape mode.  And it still prints wrong.  The printer takes the paper in along the short side.  Which it did a few weeks ago when it was printing fine.


    I am using an HP Photosmart Premium (C309g-m) and I reinstalled the driver when I started having problems.  I have even installed a patch that came out 2 days ago to fix an unrelated problem and it still didn't help.  The printer isn't the problem anyway.  If I try to print to a different printer (a Canon MG6120, if you must know) it still prints wrong.  If I try to print to PDF it prints wrong.


    I only have Pages 5.1--I don't have Pages '09.  And I can't export it and print from TextEdit--it has a lot of graphics in it.  There is hardly any text.


    Again, it printed fine a few weeks ago!

  • PeterBreis0807 Level 7 (34,040 points)

    You need to swap your dimensions. You have set it up for a portrait document when it seems you are actually using a landscape layout.



  • mdjettatdi Level 1 (0 points)

    As I said before, if I try to change dimensions, it just switches them back.


    And if it is so important I set the dimensions the other way, why did it print fine a few weeks ago but not print properly now?

  • PeterBreis0807 Level 7 (34,040 points)

    "It", whatever that is, won't switch them back, you set the dimensions the way you want them to appear in Page Setup.


    Have you changed something in the intervening weeks?



  • mdjettatdi Level 1 (0 points)

    Pages switches the dimensions back.  I have tried it multiple times.  Have you actually tried any of your suggestions?  Perhaps you should play around in Pages with Manage Customs Sizes and Page Setup for a while and see for yourself.


    Honestly, this is getting a bit circular.


    Is there anyone else who has any suggestions?  Apple, could there be something wrong with Pages?

  • PeterBreis0807 Level 7 (34,040 points)

    I try, test and establish just about everything I post on these forums. I suspect I have also been doing all of this a heck of a lot longer than you, and actually understand what is going on.


    Pages does not switch anything in the Page Setup… that is part of the System set-up. Once you establish the custom Page size that establishes the normal straight view of the sheet. It can be either landscape or portrait in the Custom Page.


    The Orientation icon doesn't change to the shape of the paper.


    Changing the Orientation turns the layout as it goes to the printer. Or not. That is what Orientation means.


    The Printer has no clue as to the shape of the paper other than what you tell it to expect. You can tell it you are printing on a bed sheet and feed it a stamp and it won't know the difference.



  • Jeff Shenk Level 4 (2,700 points)

    When I print a custom page size to PDF, it produces a PDF with the custom page size; there is no setting a Paper size involved. I don't have any HP printers, so maybe there is something different in their driver (which would not involve the output from Pages).


    If it is something in the print driver, I would expect Paper Handling, where you set Fit to Page would also have a setting for Paper orientation (independent of document orientation), but that would be down to HP.

  • mdjettatdi Level 1 (0 points)

    OK, guys, try this:


    Open Pages.

    Creat a new file.  --I picked the template "Blank" (which starts in portrait mode, mind you) in the "Basic" group.

    Go to File->Page Setup.

    Select Paper Size->Manage Custom Sizes.

    Click the "+" and create a new custom paper size.  Title it "Really Big Paper" or whatever.

    Make the paper size 34 wide by 56 high.  (Again, portrait orientation).  Click “OK”.

    Make the paper landscape orientation and click “OK”.

    Put something in the file—like a big light gray box (make its Opacity <50% so you don’t waste ink) that fills up the whole page.

    Select File->Print

    Click the popup menu that says “Layout” and select “Paper Handling”

    Click the box for “Scale to fit paper size” and select “US Legal” as the Destination Paper Size.

    Click the “Print” button.


    What do you get?  I get a gray box horizontally across the middle third of a portrait oriented page.  What I want is a page almost entirely filled with gray, which is what would happen if it really printed in landscape mode.


    You can fool around with the custom paper size and start with it shorter on width or shorter on height, but if you want to print a document that is large and is wider than it is tall, when you print it on a single page, it will always print **across the middle of a portrait oriented page** and not in landscape mode.


    I can repeat this on both my HP and Canon printers.  Same result.  So it isn’t the print driver, unless you think HP and Canon have the same bug in their print drivers (fairly unlikely, I would guess).  You can print to PDF and you get the same result, too.


    Again: printing worked fine for me a few weeks (and one or two Pages updates) ago!

  • PeterBreis0807 Level 7 (34,040 points)

    I do not have a large sheet printer, let alone one that works in cubits.


    So what I have done is print to pdf using your specifications.


    I made a full page colored shape edge to edge with a horizontal shape at exactly half way, in contrasting red to check any cropping or displacement.


    1. If I print to 100% size I get exactly what you'd expect which is a Portrait 34 x 56".


    Screen Shot 2014-02-04 at 1.04.39 pm.png


    2. I then printed to pdf setting the Paper Handling to Destination Paper Size: US Legal, Scale to fit paper size checked. I get a US Legal size pdf with white printer margin inset. Again much as expected.


    Screen Shot 2014-02-04 at 1.04.30 pm.png


    I then made a horizontal custom page, it also worked predictably same as above, only horizontal.


    If you are getting a horizontal stripe across your paper it suggests to me you are sending a horizontal print to a portrait fed sheet. Which is what I said repeatedly above. I suggest putting an arrow pointing across your artwork like my red shape to tell you what is happening in your orientation settings.


    As Jeff says, the results you are getting may be due to your Printer Driver, but also, more likely your settings IMO.



Previous 1 2 3 4 Next