Previous 1 2 Next 18 Replies Latest reply: Jul 6, 2015 11:44 AM by empariup
kdedhia Level 1 Level 1 (0 points)

I recently upgraded to Mavericks and installed Keynote 6.1. But the files that I recieve from other folks created in the new version does not open. It just says the file can't be opened.

 

So i try to open in the older version Keynote 5.3 which i still have on my system to make sure if its the new version file or no and I do get the error - You need a newer version of Keynote to open this presentation.

 

How can i fix this problem? I can try installing the new Keynote but want to make sure I can do that from Mac App Store once i delete it from my system.

 

Thanks for your suggestions in advance!

  • Gary Scotland Level 6 Level 6 (11,480 points)

    If you are able to open your own saved Keynote files, then perhaps the files have not been created with 6.1

     

    Current wizdom is to only use 6.1 for creating new files, and never open files from any previous version. This is tedious but it avoids the corruption issues so many users have with the different file types just now.

  • help_keynote6.1 Level 1 Level 1 (0 points)

    I also have this issue.

     

    Files that other people made in Keynote 6.1 won't open in my computer even though I upgraded to the latest version.

     

    The same thing is happening when I create a presentation in Keynote 6.1. I'll send it to my colleauge and it doesn't open in their computer. Even though they have the lastest version.

     

    What the **** is going on?

     

    I thought Apple was supposed to be user friendly

  • Catherine Gleason Level 1 Level 1 (5 points)

    I am having this same issue with Keynote 6.2. I don't have any other version of Keynote on this machine. I made the file in keynote 6.2 today, posted it on an ftp site, then downloaded an hour later via fetch on to my machine in a different folder so it wasn't overwriting, and I am getting the same error message: You need a newer version of keynote to open this file.

    I went to file/open in keynote and that didn't work either. The rename it zip workaround didn't work either.

  • Gary Scotland Level 6 Level 6 (11,480 points)

    Catherine, I have only recently heard of this problem but haven't encountered it personally.

    I'd be happy to see if your file opens on my machine as I have been able to open many different clients files without issue. A one slide Keynote posted in dropbox or other transfer site would suffice.

  • Amyindallas Level 1 Level 1 (0 points)

    I am having this same problem. I work with a creative team and any files that I get from my co-worker just says, "Keynote File cannot be opened."

     

    It's very frustrating.

  • Catherine Gleason Level 1 Level 1 (5 points)

    I was wondering if it had something to do with Fetch since my coworker doesn't use that to download from an FTP and they were able to open all of my files. I haven't had a chance to try any other storage/file transfer and/or downloading software.

     

    Gary, when I get a chance to post something I will let you know. Thanks for offering to help out.

  • RonBenza Level 1 Level 1 (0 points)

    I too keep getting this error message: "You need a newer version of Keynote to open this presentation". However, I already have 6.2 installed. My little work around is to right-click on the file and choose "Keynote (default) (6.2)". That seems to work. I have also re-started my iMac several times so I know its not that issue ie the newer version not auto-loading.

    So, I'm thinking this is a bug that Apple needs to fix.

    Anyone else have any better idea?

  • Catherine Gleason Level 1 Level 1 (5 points)

    I was able to open files downloaded with Filezilla instead of Fetch. My co-workers use Cyberduck and that worked also. I tried the right click and changing the default on a file downloaded with Fetch but it didn't work. It doesn't give me the default 6.2 option either, just default. My computer does not have the older version of keynote on it.

  • 1drw1 Level 1 Level 1 (0 points)

    I have the same problem. I think that the 6.2 upgrade is another app all together. The old version is the default and the only one that recognizes the presentation files. I wonder how do I make the new version the default app?

  • RonBenza Level 1 Level 1 (0 points)

    I'm stuggling with that too. On my iMac where the 6.2 is installed, the "about Keynote" shows 5.3. I have to right-click the file icon to open it in 6.2.

    On my MacAir, both (about Keynote + file icon) show the 6.2 install.

    I can't figure out how to get my iMac to read the 6.2 as THE file. Not sure if it's possible. Feels like a bug to me.

  • greetingsfrompa Level 1 Level 1 (0 points)

    I have a big presentation due tomorrow and cannot access it. Very disappointing. This is my first iMac. A continuing problem with a flickering screen is bad enough, but a problem that interferes with my job is unacceptable.

  • mmjudd Level 1 Level 1 (0 points)

    Same problem! Seems I can only open the file if it comes zipped to me. Any file that is emailed to me won't open in the newer or older version of keynote. Anyone find a fix yet?

  • mmjudd Level 1 Level 1 (0 points)

    Hi Guys,

     

    Apparently this is a problem with gmail, dropbox, basecamp, and other file sharing sites (Apple know about it and is having issues fixing it since it deals with 3rd parties). The only way to send a file to someone (or yourself) and still be able to open it afterwards is to compress it first. Turn the keynote presentation into a .zip file and then send. When you download it later - you should be able to open.

     

    Hopefully this works!

  • RonBenza Level 1 Level 1 (0 points)

    I learned the hard way a long time ago that when sending files, zipping or stuffing is a must. Fonts in particular get easily corrupted.

    What was odd for me is that Keynote was not opening in my installed 6.2 download. And this had nothing to do with sending the file. It was as if my machine was stuck in the 5.3 mode only.

    And here's the odder bit, it seems to have sorted itself out on it's own...without restarting the iMac. That tells me this can come back. Not sure. Oh well, will call it a "victory"...

Previous 1 2 Next