14 Replies Latest reply: Sep 30, 2014 8:39 AM by jasonbenali2
sve106 Level 1 Level 1

Hello support community,

 

Iam not able to invite any other developers to my developer team in the "member center" area.

 

The "send inivitation" button is enabled but clicking on it has no effect.

 

I tried it in Internet Explorer 8, Firefox and Chrome.

 

Thanks in Advance for any help.

  • guy.hoozdis Level 1 Level 1

    What makes you say "clicking it has no effect"?  Is it that you don't see an email in then inbox of your invitee?  If so, then I think you just need to wait for a while.  It seems to me that mail delivery delay is a big problem for Apple when any invitations, password reset, ownership verification, or similar activity ever needs to be done.

     

    You probbably don't like that answer.  I sure don't, so I'll give you some guidance on how to look into what *IS* actually happening when you press the button - simply Chrome / Firefox Developer Tools.  Both of those browsers have them as a standard feature in the browser, so you don't have to install any plugins or extensions.  If I remember correctly, I don't think M$ added anything comprable until IE 10 - I'm pretty sure IE 8 won't have the Developer Tools feature.

     

    Debug the Button Yourself

    Start up either Chrome or Firefox.

    Visit the page with the button you are interested in proving that it *IS* or *IS NOT* doing anything - right click on it, then select "Inspect Element". 

  • HyperNova Software Level 6 Level 6

    Safari is the only officiallly supported browser.

    Try it.

  • MERZPK Level 1 Level 1

    Even with Safari isn't working.
    Nothing seems to happen after clicking and I don't get any invitation emails.
    Any ideas on this?
    Thnxs.

  • Systems U-tad Level 1 Level 1

    Same thing happening here.

    Tried Safari on a MacOS X Mavericks, and Chrome.

  • vancoja Level 1 Level 1

    Seems the call to saveInvitation.action is returning an HTML file with the message "We are unable to process your request." etc.

    Obviously that is not the JSON the script is expecting, resulting in a JavaScript error.

     

    Bottom line: POST request is sent for the invite but the service is not working anymore...

  • vancoja Level 1 Level 1

    Found the issue! If the invite email address contains a "-" the request fails, but if the email domain is just alpha (eg. @apple.com) the invite works.

  • mikeatOLB Level 1 Level 1

    This was definitely the issue for me. All the emails I was trying had a hyphen in it. When a tried a different email, the invite was successful.

  • Carsten Cyliax Level 1 Level 1

    I'm having the same problem. I'd like to invite one of our developers, but the domain of our company contains a "-". But all the other members of our developer team are signed in with the same email domain without any problems.

    Is this problem going to be fixed? What else can I do?

    Thanks for your help!

  • jeo-apple Level 1 Level 1

    I can confirm the same problem, only email address without "-" works.

    This seems a newer bug because few month ago we invited several developer with "-"

     

    To apple team, please fix it!

  • StonyW Level 1 Level 1
    1. Request URL:https://developer.apple.com/membercenter/saveInvitation.action
    2. Request Method:POST
    3. Form Data:
    4. fName=fsa&lName=fasfe&emailValue=fafef%40feifdsa-ifdsa.com&iphoneRole=2&macRole= &adssuv-value=eIFQMXipEn8iXpXUv842QRa7%2B36%2FQZx%2BXFgQoMSvq%2BPMEbUPr9WWkgoG2B %2FnbgLBU4UIWs93Ih5w%0D%0AZ4lcWuc7Seme1GFCkyz%2FrEnEGLueDY4lrsgX%0D%0A


    5. because the emailValue contains '-', the response is:
    6. Apple Developer Program

    7. Big Warning

      We are unable to process your request.

       

      Please go back to the previous page, or quit your browser and try your request again.
      If you require assistance, please contact Apple Developer Support.

  • BPKBPK Level 1 Level 1

    Same for me - had to provide another email address for my developer which was a pain. Please fix

  • AdmRiVinA Level 1 Level 1

    We are one month later and this still does not work.
    I urgently need to invite a client to our account, they have a - in their domain name.

    Please fix.

  • Helge Schwarz Level 1 Level 1
    expertise.ipad
    iPad

    You should as a dev know that taking a bug to the community support forum won't fix anything.

     

    That is the site this belongs to

    http://bugreport.apple.com/

    alternatively you can try to deal with dev support, but usually radar is better.

  • jasonbenali2 Level 1 Level 1

    OK - so after trying lots of different things, I found a workaround for this:

     

    - Use Safari

    - Use the bulk uploader, download and edit the sample txt file, select the appropriate dev programme and button should activate

    - It worked